Bug 217552 - kwin crashed when I opened gwenview [KWin::Scene::Window::buildQuads, KWin::Scene::paintSimpleScreen, KWin::Scene::finalPaintScreen]
Summary: kwin crashed when I opened gwenview [KWin::Scene::Window::buildQuads, KWin::S...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-06 12:02 UTC by Alexander
Modified: 2009-12-08 09:45 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander 2009-12-06 12:02:58 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)))
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)) (Compiled from sources)
Qt Version: 4.6.0
Operating System: Linux 2.6.31-ARCH x86_64

-- Information about the crash:
I switched to the Dolphin window and clicked on the picture.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#5  KWin::Scene::Window::buildQuads (this=0x10da2a0, force=<value optimized out>) at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/scene.cpp:485
#6  0x00007f058113e49d in KWin::Scene::paintSimpleScreen (this=0xca1f90, orig_mask=<value optimized out>, region=<value optimized out>)
    at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/scene.cpp:237
#7  0x00007f058113c205 in KWin::Scene::finalPaintScreen (this=0xca1f90, mask=0, region=<value optimized out>, data=<value optimized out>)
    at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/scene.cpp:176
#8  0x00007f0581152cd6 in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=0, region=) at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/effects.cpp:126
#9  0x00007f05704cdf8f in KWin::LogoutEffect::paintScreen (this=0xd95010, mask=0, region=<value optimized out>, data=...)
    at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/effects/logout/logout.cpp:196
#10 0x00007f0581152d6e in KWin::EffectsHandlerImpl::paintScreen (this=0xd2f9d0, mask=0, region=) at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/effects.cpp:122
#11 0x00007f05704d45b2 in KWin::PresentWindowsEffect::paintScreen (this=0xd82850, mask=0, region=)
    at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/effects/presentwindows/presentwindows.cpp:191
#12 0x00007f0581152d6e in KWin::EffectsHandlerImpl::paintScreen (this=0xd2f9d0, mask=0, region=) at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/effects.cpp:122
#13 0x00007f057f967e9f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...)
    at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/lib/kwineffects.cpp:227
#14 0x00007f0581152d6e in KWin::EffectsHandlerImpl::paintScreen (this=0xd2f9d0, mask=0, region=) at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/effects.cpp:122
#15 0x00007f057f967e9f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...)
    at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/lib/kwineffects.cpp:227
#16 0x00007f0581152d6e in KWin::EffectsHandlerImpl::paintScreen (this=0xd2f9d0, mask=0, region=) at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/effects.cpp:122
#17 0x00007f057f967e9f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...)
    at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/lib/kwineffects.cpp:227
#18 0x00007f0581152d6e in KWin::EffectsHandlerImpl::paintScreen (this=0xd2f9d0, mask=0, region=) at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/effects.cpp:122
#19 0x00007f05704f20d5 in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=...)
    at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/effects/slide/slide.cpp:86
#20 0x00007f0581152d6e in KWin::EffectsHandlerImpl::paintScreen (this=0xd2f9d0, mask=0, region=) at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/effects.cpp:122
#21 0x00007f05704fe1b4 in KWin::CoverSwitchEffect::paintScreen (this=0xd79670, mask=0, region=<value optimized out>, data=...)
    at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/effects/coverswitch/coverswitch.cpp:124
#22 0x00007f0581152d6e in KWin::EffectsHandlerImpl::paintScreen (this=0xd2f9d0, mask=0, region=) at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/effects.cpp:122
#23 0x00007f057f967e9f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...)
    at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/lib/kwineffects.cpp:227
#24 0x00007f0581152d6e in KWin::EffectsHandlerImpl::paintScreen (this=0xd2f9d0, mask=0, region=) at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/effects.cpp:122
#25 0x00007f057f967e9f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...)
    at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/lib/kwineffects.cpp:227
#26 0x00007f0581152d6e in KWin::EffectsHandlerImpl::paintScreen (this=0xd2f9d0, mask=0, region=) at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/effects.cpp:122
#27 0x00007f058113e005 in KWin::Scene::paintScreen (this=0xca1f90, mask=0x7fffc9833e0c, region=0x7fffc9833f30) at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/scene.cpp:134
#28 0x00007f058114c5ef in KWin::SceneOpenGL::paint (this=0xca1f90, damage=<value optimized out>, toplevels=<value optimized out>)
    at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/scene_opengl.cpp:747
#29 0x00007f0581138907 in KWin::Workspace::performCompositing (this=<value optimized out>) at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/composite.cpp:424
#30 0x00007f05810c433e in KWin::Workspace::qt_metacall (this=0xcdd7d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffc98340e0) at /mnt/tmpfs/src/build/kwin/workspace.moc:535
#31 0x00007f057cd2f0b3 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#32 0x00007f057cd2b983 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#33 0x00007f057d460b7c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#34 0x00007f057d46723f in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#35 0x00007f0580924056 in KApplication::notify (this=0x7fffc9834af0, receiver=0xcddc40, event=0x7fffc9834790)
    at /home/progdan/PKGBUILDs/kde-4.4-unstable/kde-4.4-unstable/build/kdelibs/trunk/src/kdelibs-4.3.80svn1054661/kdeui/kernel/kapplication.cpp:302
#36 0x00007f057cd1c0ec in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#37 0x00007f057cd48d22 in ?? () from /usr/lib/libQtCore.so.4
#38 0x00007f057cd45858 in ?? () from /usr/lib/libQtCore.so.4
#39 0x00007f05765471fe in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#40 0x00007f057654abb8 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#41 0x00007f057654ace0 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#42 0x00007f057cd45523 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#43 0x00007f057d50837e in ?? () from /usr/lib/libQtGui.so.4
#44 0x00007f057cd1aa22 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#45 0x00007f057cd1adfc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#46 0x00007f057cd1eb2b in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#47 0x00007f05810dd60e in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /mnt/tmpfs/src/kdebase-workspace-4.3.80svn1054661/kwin/main.cpp:526
#48 0x00007f0580d57b6d in __libc_start_main () from /lib/libc.so.6
#49 0x0000000000400629 in _start ()

This bug may be a duplicate of or related to bug 195104.

Possible duplicates by query: bug 216609, bug 192172, bug 216813, bug 195104, bug 217461.

Reported using DrKonqi
Comment 1 Martin Flöser 2009-12-06 12:07:24 UTC

*** This bug has been marked as a duplicate of bug 195104 ***
Comment 2 Martin Flöser 2009-12-08 09:45:38 UTC

*** This bug has been marked as a duplicate of bug 216908 ***