Bug 217761 - Kwin crashed after exiting VLC [KWin::Scene::Window::buildQuads, KWin::Scene::paintSimpleScreen, KWin::Scene::finalPaintScreen]
Summary: Kwin crashed after exiting VLC [KWin::Scene::Window::buildQuads, KWin::Scene:...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-07 20:38 UTC by jbrsubscribe
Modified: 2009-12-08 09:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jbrsubscribe 2009-12-07 20:38:30 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)) "release 196")
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)) "release 196"
Qt Version: 4.6.0
Operating System: Linux 2.6.31.5-0.1-default x86_64
Distribution: "openSUSE 11.2 (x86_64)"

-- Information about the crash:
crashed after exiting media player VLC. No, I can't tell you anymore. I'm trying to help here. :)
What more would you like me to say? Of course I can fill this area with words, but that would not really help, would it?


 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#5  KWin::Scene::Window::buildQuads (this=0x12c4250, force=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:485
#6  0x00007fac724006bc in KWin::Scene::paintSimpleScreen (this=0x8f8220, orig_mask=<value optimized out>, region=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:237
#7  0x00007fac723fe115 in KWin::Scene::finalPaintScreen (this=0x8f8220, mask=0, region=<value optimized out>, data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:176
#8  0x00007fac72414fc6 in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:126
#9  0x00007fac5d65040f in KWin::LogoutEffect::paintScreen (this=0x9e8090, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/logout/logout.cpp:196
#10 0x00007fac7241505e in KWin::EffectsHandlerImpl::paintScreen (this=0x8b5660, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#11 0x00007fac5d66f5f0 in KWin::ShadowEffect::paintScreen (this=0x842550, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/shadow/shadow.cpp:182
#12 0x00007fac7241505e in KWin::EffectsHandlerImpl::paintScreen (this=0x8b5660, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#13 0x00007fac5d656ae2 in KWin::PresentWindowsEffect::paintScreen (this=0xa81e50, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/presentwindows/presentwindows.cpp:191
#14 0x00007fac7241505e in KWin::EffectsHandlerImpl::paintScreen (this=0x8b5660, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#15 0x00007fac70c5711f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#16 0x00007fac7241505e in KWin::EffectsHandlerImpl::paintScreen (this=0x8b5660, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#17 0x00007fac70c5711f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#18 0x00007fac7241505e in KWin::EffectsHandlerImpl::paintScreen (this=0x8b5660, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#19 0x00007fac70c5711f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#20 0x00007fac7241505e in KWin::EffectsHandlerImpl::paintScreen (this=0x8b5660, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#21 0x00007fac70c5711f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#22 0x00007fac7241505e in KWin::EffectsHandlerImpl::paintScreen (this=0x8b5660, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#23 0x00007fac70c5711f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#24 0x00007fac7241505e in KWin::EffectsHandlerImpl::paintScreen (this=0x8b5660, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#25 0x00007fac5d63c752 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/desktopgrid/desktopgrid.cpp:151
#26 0x00007fac7241505e in KWin::EffectsHandlerImpl::paintScreen (this=0x8b5660, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#27 0x00007fac70c5711f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#28 0x00007fac7241505e in KWin::EffectsHandlerImpl::paintScreen (this=0x8b5660, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#29 0x00007fac70c5711f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#30 0x00007fac7241505e in KWin::EffectsHandlerImpl::paintScreen (this=0x8b5660, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#31 0x00007fac5d63a782 in KWin::BoxSwitchEffect::paintScreen (this=0x8ad0c0, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/boxswitch/boxswitch.cpp:140
#32 0x00007fac7241505e in KWin::EffectsHandlerImpl::paintScreen (this=0x8b5660, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#33 0x00007fac5d674245 in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/slide/slide.cpp:86
#34 0x00007fac7241505e in KWin::EffectsHandlerImpl::paintScreen (this=0x8b5660, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#35 0x00007fac70c5711f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#36 0x00007fac7241505e in KWin::EffectsHandlerImpl::paintScreen (this=0x8b5660, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#37 0x00007fac5d67d141 in KWin::ZoomEffect::paintScreen (this=<value optimized out>, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/zoom/zoom.cpp:73
#38 0x00007fac7241505e in KWin::EffectsHandlerImpl::paintScreen (this=0x8b5660, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#39 0x00007fac5d6a5fd5 in KWin::TrackMouseEffect::paintScreen (this=0xa712b0, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/trackmouse/trackmouse.cpp:71
#40 0x00007fac7241505e in KWin::EffectsHandlerImpl::paintScreen (this=0x8b5660, mask=0, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#41 0x00007fac72400225 in KWin::Scene::paintScreen (this=0x8f8220, mask=0x7fff65a57d4c, region=0x7fff65a57e70) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:134
#42 0x00007fac7240e8f0 in KWin::SceneOpenGL::paint (this=0x8f8220, damage=<value optimized out>, toplevels=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene_opengl.cpp:747
#43 0x00007fac723fabc7 in KWin::Workspace::performCompositing (this=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/composite.cpp:424
#44 0x00007fac723862fe in KWin::Workspace::qt_metacall (this=0x7d37c0, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff65a58020)
    at /usr/src/debug/kdebase-workspace-4.3.80/build/kwin/workspace.moc:535
#45 0x00007fac6e00bd73 in QMetaObject::activate (sender=0x7d3c30, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x6d) at kernel/qobject.cpp:3294
#46 0x00007fac6e0089e3 in QObject::event (this=0x7d3c30, e=0x7fff65a58720) at kernel/qobject.cpp:1224
#47 0x00007fac6e741bcc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#48 0x00007fac6e7481fd in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#49 0x00007fac71be58f6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#50 0x00007fac6dff901c in QCoreApplication::notifyInternal (this=0x7fff65a58b30, receiver=0x7d3c30, event=0x7fff65a58720) at kernel/qcoreapplication.cpp:704
#51 0x00007fac6e025d55 in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:215
#52 QTimerInfoList::activateTimers (event=<value optimized out>, receiver=<value optimized out>) at kernel/qeventdispatcher_unix.cpp:617
#53 0x00007fac6e0228c8 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#54 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#55 0x00007fac67bc8dde in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#56 0x00007fac67bcc7a8 in ?? () from /usr/lib64/libglib-2.0.so.0
#57 0x00007fac67bcc8d0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#58 0x00007fac6e022593 in QEventDispatcherGlib::processEvents (this=0x60e040, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#59 0x00007fac6e7ee9be in ?? () from /usr/lib64/libQtGui.so.4
#60 0x00007fac6dff7942 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#61 0x00007fac6dff7d1c in QEventLoop::exec (this=0x7fff65a58a70, flags=) at kernel/qeventloop.cpp:201
#62 0x00007fac6dffba5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#63 0x00007fac7239f8be in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/main.cpp:526
#64 0x00007fac72014a7d in __libc_start_main () from /lib64/libc.so.6
#65 0x0000000000400699 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 217552, bug 217461, bug 216813, bug 216609, bug 196152.

Reported using DrKonqi
Comment 1 Martin Flöser 2009-12-07 20:50:50 UTC

*** This bug has been marked as a duplicate of bug 195104 ***
Comment 2 Martin Flöser 2009-12-08 09:44:47 UTC

*** This bug has been marked as a duplicate of bug 216908 ***