Bug 216609 - kwin crashed when I clicked the "show hidden icons" for the systray [KWin::Scene::Window::buildQuads, KWin::Scene::paintSimpleScreen, KWin::Scene::finalPaintScreen]
Summary: kwin crashed when I clicked the "show hidden icons" for the systray [KWin::Sc...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-29 08:59 UTC by Bruno Bigras
Modified: 2009-12-08 09:46 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Bigras 2009-11-29 08:59:29 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)))
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)) (Compiled from sources)
Qt Version: 4.6.0
Operating System: Linux 2.6.31-15-generic x86_64
Distribution: Ubuntu 9.10

-- Information about the crash:
kwin crashed when I clicked the "show hidden icons" for the systray. The icons were shown as expected.

The crash does not seem to be reproducible.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#6  KWin::Scene::Window::buildQuads (this=0x26a4ba0, force=<value optimized out>) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/scene.cpp:485
#7  0x00007f94cc71ebb7 in KWin::Scene::paintSimpleScreen (this=<value optimized out>, orig_mask=<value optimized out>, region=<value optimized out>)
    at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/scene.cpp:237
#8  0x00007f94cc71d7f2 in KWin::Scene::finalPaintScreen (this=0x214fde0, mask=8, region=<value optimized out>, data=<value optimized out>)
    at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/scene.cpp:176
#9  0x00007f94cc7333f9 in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=8, region=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects.cpp:126
#10 0x00007f94ba803dd3 in KWin::LogoutEffect::paintScreen (this=0x21ba160, mask=8, region=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects/logout/logout.cpp:196
#11 0x00007f94cc7333c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x212a070, mask=8, region=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects.cpp:122
#12 0x00007f94ba81b43a in KWin::ShadowEffect::paintScreen (this=0x21887a0, mask=8, region=<value optimized out>, data=...)
    at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects/shadow/shadow.cpp:182
#13 0x00007f94cc7333c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x212a070, mask=8, region=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects.cpp:122
#14 0x00007f94ba8118a2 in KWin::PresentWindowsEffect::paintScreen (this=0x21b1520, mask=8, region=)
    at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects/presentwindows/presentwindows.cpp:191
#15 0x00007f94cc7333c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x212a070, mask=8, region=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects.cpp:122
#16 0x00007f94cbfdf5ef in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...)
    at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/lib/kwineffects.cpp:227
#17 0x00007f94cc7333c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x212a070, mask=8, region=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects.cpp:122
#18 0x00007f94cbfdf5ef in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...)
    at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/lib/kwineffects.cpp:227
#19 0x00007f94cc7333c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x212a070, mask=8, region=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects.cpp:122
#20 0x00007f94cbfdf5ef in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...)
    at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/lib/kwineffects.cpp:227
#21 0x00007f94cc7333c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x212a070, mask=8, region=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects.cpp:122
#22 0x00007f94cbfdf5ef in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...)
    at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/lib/kwineffects.cpp:227
#23 0x00007f94cc7333c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x212a070, mask=8, region=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects.cpp:122
#24 0x00007f94ba7f85b0 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=...)
    at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects/desktopgrid/desktopgrid.cpp:151
#25 0x00007f94cc7333c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x212a070, mask=8, region=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects.cpp:122
#26 0x00007f94ba8217ff in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=...)
    at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects/slide/slide.cpp:86
#27 0x00007f94cc7333c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x212a070, mask=8, region=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects.cpp:122
#28 0x00007f94cbfdf5ef in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...)
    at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/lib/kwineffects.cpp:227
#29 0x00007f94cc7333c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x212a070, mask=8, region=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects.cpp:122
#30 0x00007f94cbfdf5ef in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...)
    at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/lib/kwineffects.cpp:227
#31 0x00007f94cc7333c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x212a070, mask=8, region=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects.cpp:122
#32 0x00007f94ba82caa4 in KWin::CoverSwitchEffect::paintScreen (this=0x21da120, mask=8, region=<value optimized out>, data=...)
    at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects/coverswitch/coverswitch.cpp:124
#33 0x00007f94cc7333c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x212a070, mask=8, region=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects.cpp:122
#34 0x00007f94cbfdf5ef in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...)
    at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/lib/kwineffects.cpp:227
#35 0x00007f94cc7333c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x212a070, mask=8, region=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects.cpp:122
#36 0x00007f94ba82960e in KWin::ZoomEffect::paintScreen (this=<value optimized out>, mask=8, region=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects/zoom/zoom.cpp:73
#37 0x00007f94cc7333c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x212a070, mask=8, region=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/effects.cpp:122
#38 0x00007f94cc71f436 in KWin::Scene::paintScreen (this=0x214fde0, mask=0x7fff15c869ac, region=0x7fff15c86ad0) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/scene.cpp:134
#39 0x00007f94cc72b0bd in KWin::SceneOpenGL::paint (this=0x214fde0, damage=) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/scene_opengl.cpp:747
#40 0x00007f94cc7191cd in KWin::Workspace::performCompositing (this=<value optimized out>) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/composite.cpp:424
#41 0x00007f94cc6a6f35 in KWin::Workspace::qt_metacall (this=0x2105d50, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff15c86cf0)
    at /home/bruno/kde4/trunk/bld/KDE/kdebase/workspace/kwin/workspace.moc:535
#42 0x00007f94c9649813 in QMetaObject::metacall (object=0x2105d50, cl=QMetaObject::InvokeMetaMethod, idx=173, argv=0x7fff15c86cf0)
    at /home/bruno/kdeqt/4.6/src/qt/qt/src/corelib/kernel/qmetaobject.cpp:237
#43 0x00007f94c965d221 in QMetaObject::activate (sender=0x21061c0, m=0x7f94c9994c00, local_signal_index=0, argv=0x0) at /home/bruno/kdeqt/4.6/src/qt/qt/src/corelib/kernel/qobject.cpp:3279
#44 0x00007f94c96b7891 in QTimer::timeout (this=0x21061c0) at .moc/debug-shared/moc_qtimer.cpp:134
#45 0x00007f94c9665b91 in QTimer::timerEvent (this=0x21061c0, e=0x7fff15c87520) at /home/bruno/kdeqt/4.6/src/qt/qt/src/corelib/kernel/qtimer.cpp:271
#46 0x00007f94c965912d in QObject::event (this=0x21061c0, e=0x7fff15c87520) at /home/bruno/kdeqt/4.6/src/qt/qt/src/corelib/kernel/qobject.cpp:1212
#47 0x00007f94c9e65038 in QApplicationPrivate::notify_helper (this=0x1f1a900, receiver=0x21061c0, e=0x7fff15c87520) at /home/bruno/kdeqt/4.6/src/qt/qt/src/gui/kernel/qapplication.cpp:4242
#48 0x00007f94c9e6297f in QApplication::notify (this=0x7fff15c879a0, receiver=0x21061c0, e=0x7fff15c87520) at /home/bruno/kdeqt/4.6/src/qt/qt/src/gui/kernel/qapplication.cpp:3661
#49 0x00007f94cb64fd9e in KApplication::notify (this=0x7fff15c879a0, receiver=0x21061c0, event=0x7fff15c87520) at /home/bruno/kde4/trunk/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:289
#50 0x00007f94c964249d in QCoreApplication::notifyInternal (this=0x7fff15c879a0, receiver=0x21061c0, event=0x7fff15c87520)
    at /home/bruno/kdeqt/4.6/src/qt/qt/src/corelib/kernel/qcoreapplication.cpp:704
#51 0x00007f94c9e567e5 in QCoreApplication::sendEvent (receiver=0x21061c0, event=0x7fff15c87520) at ../../include/QtCore/../../../../../src/qt/qt/src/corelib/kernel/qcoreapplication.h:215
#52 0x00007f94c967b7cd in QTimerInfoList::activateTimers (this=0x1f1e690) at /home/bruno/kdeqt/4.6/src/qt/qt/src/corelib/kernel/qeventdispatcher_unix.cpp:603
#53 0x00007f94c96772cc in timerSourceDispatch (source=0x1f1e630) at /home/bruno/kdeqt/4.6/src/qt/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:184
#54 0x00007f94c96773b3 in idleTimerSourceDispatch (source=0x1f1e6f0) at /home/bruno/kdeqt/4.6/src/qt/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:231
#55 0x00007f94c1f19bbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#56 0x00007f94c1f1d588 in ?? () from /lib/libglib-2.0.so.0
#57 0x00007f94c1f1d6b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#58 0x00007f94c967850d in QEventDispatcherGlib::processEvents (this=0x1f00f50, flags=...) at /home/bruno/kdeqt/4.6/src/qt/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:407
#59 0x00007f94c9f349d2 in QGuiEventDispatcherGlib::processEvents (this=0x1f00f50, flags=...) at /home/bruno/kdeqt/4.6/src/qt/qt/src/gui/kernel/qguieventdispatcher_glib.cpp:202
#60 0x00007f94c963fce8 in QEventLoop::processEvents (this=0x7fff15c878e0, flags=...) at /home/bruno/kdeqt/4.6/src/qt/qt/src/corelib/kernel/qeventloop.cpp:149
#61 0x00007f94c963fe3c in QEventLoop::exec (this=0x7fff15c878e0, flags=...) at /home/bruno/kdeqt/4.6/src/qt/qt/src/corelib/kernel/qeventloop.cpp:197
#62 0x00007f94c9642b62 in QCoreApplication::exec () at /home/bruno/kdeqt/4.6/src/qt/qt/src/corelib/kernel/qcoreapplication.cpp:981
#63 0x00007f94c9e62532 in QApplication::exec () at /home/bruno/kdeqt/4.6/src/qt/qt/src/gui/kernel/qapplication.cpp:3570
#64 0x00007f94cc6c5c79 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /home/bruno/kde4/trunk/src/KDE/kdebase/workspace/kwin/main.cpp:526
#65 0x00007f94c67ffabd in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff15c87ea8) at libc-start.c:220
#66 0x0000000000400889 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 192172, bug 195104, bug 196152.

Reported using DrKonqi
Comment 1 Martin Flöser 2009-11-29 09:52:46 UTC

*** This bug has been marked as a duplicate of bug 195104 ***
Comment 2 Martin Flöser 2009-12-08 09:46:40 UTC

*** This bug has been marked as a duplicate of bug 216908 ***