Bug 216813 - Kwin crashes and desktop is slow when using yast [KWin::Scene::Window::buildQuads, KWin::Scene::paintSimpleScreen, KWin::Scene::finalPaintScreen]
Summary: Kwin crashes and desktop is slow when using yast [KWin::Scene::Window::buildQ...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-30 14:59 UTC by András Manţia
Modified: 2009-12-08 09:46 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description András Manţia 2009-11-30 14:59:19 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)))
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)) (Compiled from sources)
Qt Version: 4.6.0
Operating System: Linux 2.6.31.5-0.1-default x86_64
Distribution: "openSUSE 11.2 (x86_64)"

-- Information about the crash:
I have KDE trunk on an openSUSE 11.2 desktop, and recently I saw KWin crashing from time to time. When it does, what I can see is a very slow refresh of the screen (line by line drawing is visible, either from top to down, or bottom to up). The system is unusable at this stage. I have to disable/enable compositing to get back the control of the desktop.
It happened two times in a row in the past minutes, both times when I run Yast2 package manager and searched for some packages (yast is a Qt application). 
 The system has an nvidia card, nvidia binary driver 190.42, compositing enabled, dual head, two screens side by side. On the second screen I had only an openoffice instance running, yast was on the first screen.

The crash can be reproduced everytime.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#5  KWin::Scene::Window::buildQuads (this=0x116bc90, force=<value optimized out>) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/scene.cpp:485
#6  0x00007fa8a763864c in KWin::Scene::paintSimpleScreen (this=0x16622d0, orig_mask=<value optimized out>, region=<value optimized out>)
    at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/scene.cpp:237
#7  0x00007fa8a76360a5 in KWin::Scene::finalPaintScreen (this=0x16622d0, mask=8, region=<value optimized out>, data=<value optimized out>)
    at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/scene.cpp:176
#8  0x00007fa8a764cf46 in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects.cpp:126
#9  0x00007fa89210c40f in KWin::LogoutEffect::paintScreen (this=0x9c2f00, mask=8, region=<value optimized out>, data=...)
    at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects/logout/logout.cpp:196
#10 0x00007fa8a764cfde in KWin::EffectsHandlerImpl::paintScreen (this=0x12a88a0, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects.cpp:122
#11 0x00007fa89212b560 in KWin::ShadowEffect::paintScreen (this=0x9d1770, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects/shadow/shadow.cpp:182
#12 0x00007fa8a764cfde in KWin::EffectsHandlerImpl::paintScreen (this=0x12a88a0, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects.cpp:122
#13 0x00007fa892112ae2 in KWin::PresentWindowsEffect::paintScreen (this=0xecb520, mask=8, region=)
    at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects/presentwindows/presentwindows.cpp:191
#14 0x00007fa8a764cfde in KWin::EffectsHandlerImpl::paintScreen (this=0x12a88a0, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects.cpp:122
#15 0x00007fa8a6ef20cf in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...)
    at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/lib/kwineffects.cpp:227
#16 0x00007fa8a764cfde in KWin::EffectsHandlerImpl::paintScreen (this=0x12a88a0, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects.cpp:122
#17 0x00007fa8a6ef20cf in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...)
    at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/lib/kwineffects.cpp:227
#18 0x00007fa8a764cfde in KWin::EffectsHandlerImpl::paintScreen (this=0x12a88a0, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects.cpp:122
#19 0x00007fa8a6ef20cf in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...)
    at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/lib/kwineffects.cpp:227
#20 0x00007fa8a764cfde in KWin::EffectsHandlerImpl::paintScreen (this=0x12a88a0, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects.cpp:122
#21 0x00007fa8a6ef20cf in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...)
    at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/lib/kwineffects.cpp:227
#22 0x00007fa8a764cfde in KWin::EffectsHandlerImpl::paintScreen (this=0x12a88a0, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects.cpp:122
#23 0x00007fa8920f87b2 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=...)
    at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects/desktopgrid/desktopgrid.cpp:151
#24 0x00007fa8a764cfde in KWin::EffectsHandlerImpl::paintScreen (this=0x12a88a0, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects.cpp:122
#25 0x00007fa8921301a5 in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=...)
    at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects/slide/slide.cpp:86
#26 0x00007fa8a764cfde in KWin::EffectsHandlerImpl::paintScreen (this=0x12a88a0, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects.cpp:122
#27 0x00007fa8920f67e2 in KWin::BoxSwitchEffect::paintScreen (this=0x91bed0, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects/boxswitch/boxswitch.cpp:140
#28 0x00007fa8a764cfde in KWin::EffectsHandlerImpl::paintScreen (this=0x12a88a0, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects.cpp:122
#29 0x00007fa8a6ef20cf in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...)
    at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/lib/kwineffects.cpp:227
#30 0x00007fa8a764cfde in KWin::EffectsHandlerImpl::paintScreen (this=0x12a88a0, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects.cpp:122
#31 0x00007fa8a6ef20cf in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...)
    at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/lib/kwineffects.cpp:227
#32 0x00007fa8a764cfde in KWin::EffectsHandlerImpl::paintScreen (this=0x12a88a0, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects.cpp:122
#33 0x00007fa89213c464 in KWin::CoverSwitchEffect::paintScreen (this=0x971180, mask=8, region=<value optimized out>, data=...)
    at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects/coverswitch/coverswitch.cpp:124
#34 0x00007fa8a764cfde in KWin::EffectsHandlerImpl::paintScreen (this=0x12a88a0, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects.cpp:122
#35 0x00007fa8a6ef20cf in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...)
    at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/lib/kwineffects.cpp:227
#36 0x00007fa8a764cfde in KWin::EffectsHandlerImpl::paintScreen (this=0x12a88a0, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects.cpp:122
#37 0x00007fa892139091 in KWin::ZoomEffect::paintScreen (this=<value optimized out>, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects/zoom/zoom.cpp:73
#38 0x00007fa8a764cfde in KWin::EffectsHandlerImpl::paintScreen (this=0x12a88a0, mask=8, region=) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/effects.cpp:122
#39 0x00007fa8a76381b5 in KWin::Scene::paintScreen (this=0x16622d0, mask=0x7fff7f592efc, region=0x7fff7f593020) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/scene.cpp:134
#40 0x00007fa8a7646870 in KWin::SceneOpenGL::paint (this=0x16622d0, damage=<value optimized out>, toplevels=<value optimized out>)
    at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/scene_opengl.cpp:747
#41 0x00007fa8a7632a77 in KWin::Workspace::performCompositing (this=<value optimized out>) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/composite.cpp:424
#42 0x00007fa8a75be43e in KWin::Workspace::qt_metacall (this=0x831160, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff7f5931d0)
    at /home/andris/development/build/kde-trunk/kdebase/workspace/kwin/workspace.moc:535
#43 0x00007fa8a4390c41 in QMetaObject::metacall (object=0x831160, cl=InvokeMetaMethod, idx=173, argv=0x7fff7f5931d0)
    at /home/andris/development/sources/kde-trunk/qt-copy/src/corelib/kernel/qmetaobject.cpp:237
#44 0x00007fa8a43a7099 in QMetaObject::activate (sender=0x8315d0, m=0x7fa8a4708bc0, local_signal_index=0, argv=0x0)
    at /home/andris/development/sources/kde-trunk/qt-copy/src/corelib/kernel/qobject.cpp:3286
#45 0x00007fa8a440e941 in QTimer::timeout (this=0x8315d0) at .moc/debug-shared/moc_qtimer.cpp:134
#46 0x00007fa8a43b083b in QTimer::timerEvent (this=0x8315d0, e=0x7fff7f593bb0) at /home/andris/development/sources/kde-trunk/qt-copy/src/corelib/kernel/qtimer.cpp:271
#47 0x00007fa8a43a282f in QObject::event (this=0x8315d0, e=0x7fff7f593bb0) at /home/andris/development/sources/kde-trunk/qt-copy/src/corelib/kernel/qobject.cpp:1216
#48 0x00007fa8a4bd7578 in QApplicationPrivate::notify_helper (this=0x62c500, receiver=0x8315d0, e=0x7fff7f593bb0)
    at /home/andris/development/sources/kde-trunk/qt-copy/src/gui/kernel/qapplication.cpp:4253
#49 0x00007fa8a4bd4aa6 in QApplication::notify (this=0x7fff7f594040, receiver=0x8315d0, e=0x7fff7f593bb0) at /home/andris/development/sources/kde-trunk/qt-copy/src/gui/kernel/qapplication.cpp:3663
#50 0x00007fa8a656b956 in KApplication::notify (this=0x7fff7f594040, receiver=0x8315d0, event=0x7fff7f593bb0) at /home/andris/development/sources/kde-trunk/kdelibs/kdeui/kernel/kapplication.cpp:302
#51 0x00007fa8a4388be4 in QCoreApplication::notifyInternal (this=0x7fff7f594040, receiver=0x8315d0, event=0x7fff7f593bb0)
    at /home/andris/development/sources/kde-trunk/qt-copy/src/corelib/kernel/qcoreapplication.cpp:704
#52 0x00007fa8a4bc665b in QCoreApplication::sendEvent (receiver=0x8315d0, event=0x7fff7f593bb0)
    at ../../include/QtCore/../../../../../sources/kde-trunk/qt-copy/src/corelib/kernel/qcoreapplication.h:215
#53 0x00007fa8a43c929d in QTimerInfoList::activateTimers (this=0x630310) at /home/andris/development/sources/kde-trunk/qt-copy/src/corelib/kernel/qeventdispatcher_unix.cpp:603
#54 0x00007fa8a43c467b in timerSourceDispatch (source=0x6302b0) at /home/andris/development/sources/kde-trunk/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:184
#55 0x00007fa8a43c4762 in idleTimerSourceDispatch (source=0x630370) at /home/andris/development/sources/kde-trunk/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:231
#56 0x00007fa89c7fedde in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#57 0x00007fa89c8027a8 in ?? () from /usr/lib64/libglib-2.0.so.0
#58 0x00007fa89c8028d0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#59 0x00007fa8a43c5af7 in QEventDispatcherGlib::processEvents (this=0x612bc0, flags=...) at /home/andris/development/sources/kde-trunk/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:407
#60 0x00007fa8a4cbd8d4 in QGuiEventDispatcherGlib::processEvents (this=0x612bc0, flags=...) at /home/andris/development/sources/kde-trunk/qt-copy/src/gui/kernel/qguieventdispatcher_glib.cpp:202
#61 0x00007fa8a4385c08 in QEventLoop::processEvents (this=0x7fff7f593f70, flags=...) at /home/andris/development/sources/kde-trunk/qt-copy/src/corelib/kernel/qeventloop.cpp:149
#62 0x00007fa8a4385d5e in QEventLoop::exec (this=0x7fff7f593f70, flags=...) at /home/andris/development/sources/kde-trunk/qt-copy/src/corelib/kernel/qeventloop.cpp:201
#63 0x00007fa8a43892e6 in QCoreApplication::exec () at /home/andris/development/sources/kde-trunk/qt-copy/src/corelib/kernel/qcoreapplication.cpp:981
#64 0x00007fa8a4bd4644 in QApplication::exec () at /home/andris/development/sources/kde-trunk/qt-copy/src/gui/kernel/qapplication.cpp:3572
#65 0x00007fa8a75d772e in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /home/andris/development/sources/kde-trunk/kdebase/workspace/kwin/main.cpp:526
#66 0x00007fa8a132da7d in __libc_start_main () from /lib64/libc.so.6
#67 0x0000000000400889 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 216609, bug 192172, bug 195104, bug 196152.

Reported using DrKonqi
Comment 1 Martin Flöser 2009-11-30 15:09:54 UTC

*** This bug has been marked as a duplicate of bug 195104 ***
Comment 2 Martin Flöser 2009-12-08 09:46:18 UTC

*** This bug has been marked as a duplicate of bug 216908 ***