Bug 187767 - Wish: Resize individual panel plasmoids, regardless of panel height
Summary: Wish: Resize individual panel plasmoids, regardless of panel height
Status: RESOLVED DUPLICATE of bug 182193
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Unspecified
: NOR wishlist
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-21 08:17 UTC by Dotan Cohen
Modified: 2012-09-09 13:29 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
Screenshot illustrating problematic situation that depends on this bug (18.05 KB, image/png)
2009-04-25 13:26 UTC, Dotan Cohen
Details
screenshot of trunk (22.25 KB, image/jpeg)
2009-04-25 14:12 UTC, Ivan Čukić
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2009-03-21 08:17:51 UTC
Version:            (using KDE 4.2.1)
Installed from:    Ubuntu Packages

Many panel plasmoids do not size themselves properly in panel configurations that the designers did not consider. For instance, the Composting Effects toggle in vertical panels is huge:
https://bugs.kde.org/show_bug.cgi?id=187099

Additionally, some people would like plasmoids such as the clock to be smaller:
https://bugs.kde.org/show_bug.cgi?id=185447

While some people would like plasmoids such as the clock to be larger:
https://bugs.kde.org/show_bug.cgi?id=165416

As these plasmoids automatically resize themselves to the size of the panel, it would be nice if there were a way for the user to resize each plasmoid independently of panel size. This means zooming the plasmoid in or out based on the user's preference.
Comment 1 Dotan Cohen 2009-04-25 13:26:25 UTC
Created attachment 33087 [details]
Screenshot illustrating problematic situation that depends on this bug

In the attached screenshot the Lancelot menu and the Task Bar can be seen on a vertical panel. The Lancelot menu is already too big, so the user cannot make the panel any wider and ideally it would be thinner to make the Lancelot menu smaller. However, the Task Bar is too narrow and only a few letters of each line can be read, making the text useless. If the user could zoom the Lancelot menu independently of the panel size, then the problem would have a solution.

I could demonstrate with many other Plasmoids, notably the Effects button, the digital clock, Battery Monitor, Trash, Calendar, Device Notifier, Folder View, and System Monitor.
Comment 2 Ivan Čukić 2009-04-25 14:12:35 UTC
Created attachment 33088 [details]
screenshot of trunk

most applets have maximum size set, this is a screenshot of the trunk - with Lancelot, device notifier and task manager.
Comment 3 Dotan Cohen 2009-06-12 18:37:45 UTC
Thanks, Ivan, but the minimum or maximum as set by the author cannot possible take into account all the possible use cases. Also, often a user has a legitimate reason for not wanting a plasmoid to be the minimum or maximum possible size.
Comment 4 Aaron J. Seigo 2009-06-13 18:43:55 UTC
zooming in/out makes precisely zero sense. resizing, sure, but zooming is not appropriate in this case.

in this case, i'd suggest writing a different panel containment that allows individual tweaking and sizing.
Comment 5 Dotan Cohen 2009-06-13 20:14:13 UTC
> zooming in/out makes precisely zero sense. resizing, sure, but
> zooming is not appropriate in this case.

Thanks. In my language they are the same word, and I did not realize the difference. I updated the bug title.


> in this case, i'd suggest writing a different panel containment that
> allows individual tweaking and sizing.

This is exactly the fix that the problem needs (I don't know about a _different_ containment, but individual tweaking and sizing is a must). Thanks, Aaron!
Comment 6 Aaron J. Seigo 2009-06-13 21:19:12 UTC
> I  don't know about a _different_ containment, 
> but individual tweaking and sizing is a must

for the benefit of others who may read this and decide to try and implement it: it is not a must in the sense it's required in PanelContainment. a separate containment is the way to go.
Comment 7 piemonkey 2009-07-04 01:11:18 UTC
A quick search gave me 6 copies of this bug, but I can't mark them as duplicates. It seems a lot of people have this problem.

Duplicates:
bug 168579, bug 173949, bug 182193, bug 183519, bug 167132
Comment 8 Dotan Cohen 2009-07-04 02:21:19 UTC
Bug 168579: Request to put icons next to each other in vertical panels. Not a dupe.

Bug 173949: Many bugs in one, marked as dupe of Bug 193015.

Bug 182193: Requests that individual widget sizes be configurable. This is a dupe of that bug, marking as such.

Bug 183519: Complains that button size is not variable, it's a dupe or been duped by me, I will look for it and mark one as such.

Bug 167132: Complains that some plasmoids are specifically too big. Not a dupe.

*** This bug has been marked as a duplicate of bug 182193 ***