Bug 167132 - some plasmoids are far too big on a vertical panel
Summary: some plasmoids are far too big on a vertical panel
Status: RESOLVED UNMAINTAINED
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR wishlist
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 188603 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-07-21 13:15 UTC by Peter Lewis
Modified: 2018-06-08 20:06 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
screenshot showing problem (29.99 KB, image/png)
2008-11-28 17:49 UTC, Dotan Cohen
Details
Screenshot illustrating problem (285.09 KB, image/png)
2009-08-31 12:25 UTC, Dotan Cohen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Lewis 2008-07-21 13:15:39 UTC
Version:           KDE 4.0.98, plasma workspace 0.1 (using KDE 4.0.98)
Installed from:    Ubuntu Packages
OS:                Linux

Some plasmoids, such as the new device notifier and battery charge monitor appear far too large on a vertical panel. This is since the panel needs a decent width to be usable, but the effect is that these plasmoids take up too much space.

IMO there are a couple of ways of solving the problem:

1. Make the things icons in the system tray instead - I'm not sure why the battery monitor was taken out of the system tray in the first place. This way they get grouped with other similar, small icons.

2. Find a way to group plasmoids to enable them to stay small and take up less space (a bit like the system tray anyway, I guess).

This looks really bad at the moment, if you ask me, as I don't need this much screen space taken up just in case I plug in a USB stick.

Cheers!
Comment 1 Peter Lewis 2008-07-21 13:19:03 UTC
You can see what I mean here: http://www.petesodyssey.org/files/big_plasmoids.png

Thanks!
Comment 2 Dotan Cohen 2008-11-28 17:48:33 UTC
In the latest Trunk I can confirm this issue for the following icons:
Battery Monitor
Trash
Calendar
Device Notifier
Folder View
System Monitor - Tempurature
Comment 3 Dotan Cohen 2008-11-28 17:49:01 UTC
Created attachment 28891 [details]
screenshot showing problem
Comment 4 Dotan Cohen 2009-04-25 13:27:01 UTC
A possible solution to the issue is filed here:
https://bugs.kde.org/show_bug.cgi?id=187767
Comment 5 piemonkey 2009-07-04 01:11:11 UTC
A quick search gave me 6 copies of this bug, but I can't mark them as duplicates. It seems a lot of people have this problem.

Duplicates:
bug 168579, bug 173949, bug 182193, bug 183519, bug 187767
Comment 6 Dotan Cohen 2009-07-04 02:32:22 UTC
Bug 168579: Request to put icons next to each other in vertical panels. Not a
dupe.

Bug 173949: Many bugs in one, marked as dupe of Bug 193015.

Bug 182193: Requests that individual widget sizes be configurable. Not a
dupe.

Bug 183519: Complains that button size is not variable, it's a dupe or been
duped by me, I will look for it and mark one as such.

Bug 187767: Dupe of 182193.

Thanks, piemonkey!
Comment 7 Dotan Cohen 2009-08-20 17:49:34 UTC
*** Bug 188603 has been marked as a duplicate of this bug. ***
Comment 8 Dotan Cohen 2009-08-31 12:25:36 UTC
Created attachment 36592 [details]
Screenshot illustrating problem

This is getting ridiculous. Despite the wide (as opposed to tall) format of all other KDE icons and plasmoids, the Battery Monitor icon is almost twice as tall as it is wide in a vertical panel. See attached screenshot.
Comment 9 Gerald B. 2011-09-10 10:12:18 UTC
The virtual desktop plasmoid is also one of the plasmoids that do not visually scale well.
Comment 10 Nate Graham 2018-06-08 20:06:52 UTC
Hello!

This feature request was filed for KDE Plasma 4, which reached end-of-support status in August 2015. KDE Plasma 5's desktop shell has been almost completely rewritten for better performance and usability, so it is likely that this feature request is already implemented in Plasma 5, or is no longer applicable.

Accordingly, we hope you understand why we must close this feature request. If the requested feature is still desired but not implemented in KDE Plasma 5.12 or later, please feel free to open a new ticket in the "plasmashell" product after reading https://community.kde.org/Get_Involved/Bug_Reporting

If you would like to get involved in KDE's bug triaging effort so that future mass bug closes like this are less likely, please read https://community.kde.org/Get_Involved#Bug_Triaging

Thanks for your understanding!

Nate Graham