Bug 182193 - Need to be able to set widget size in panels
Summary: Need to be able to set widget size in panels
Status: RESOLVED UNMAINTAINED
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR wishlist
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 187767 192250 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-28 19:18 UTC by Oriol Mirosa
Modified: 2018-06-08 20:04 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
Here is how my vertical panel looks now (47.36 KB, image/png)
2009-01-28 19:21 UTC, Oriol Mirosa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oriol Mirosa 2009-01-28 19:18:00 UTC
Version:            (using KDE 4.2.0)
OS:                Linux
Installed from:    Ubuntu Packages

There is no way to control how 'tall' widgets are going to be in vertical panels, which leads to funny outcomes. In my panel, for instance, the task manager takes so much space that it makes the 'quicklauncher' very small and all the icons in it are tiny. If I remove the task manager, then the quicklauncher is huge and the icons are immense too. The behavior is not consistent either. When I first installed the quicklauncher the icons were of ok size, but after I played around a little with the panel I got to the current problems and I cannot change that again. Another example of the issue is the clock. I have it at the bottom of my vertical panel, showing the time and the date. There is a large amount of space between the time and the date, as well as between the time and the next widget above it, the systray (which does not happen in horizontal panels). It takes way too much space for the clock.

Bottom line is that although you can rearrange the order of the widgets, there is no way to control their relative sizes, which leads to funny looking panel arrangements.
Comment 1 Oriol Mirosa 2009-01-28 19:21:09 UTC
Created attachment 30679 [details]
Here is how my vertical panel looks now
Comment 2 piemonkey 2009-07-04 01:10:59 UTC
A quick search gave me 6 copies of this bug, but I can't mark them as duplicates. It seems a lot of people have this problem.

Duplicates:
bug 168579, bug 173949, bug 183519, bug 167132, bug 187767
Comment 3 Dotan Cohen 2009-07-04 02:21:19 UTC
*** Bug 187767 has been marked as a duplicate of this bug. ***
Comment 4 Dotan Cohen 2009-07-04 02:26:38 UTC
Bug 168579: Request to put icons next to each other in vertical panels. Not a
dupe.

Bug 173949: Many bugs in one, marked as dupe of Bug 193015.

Bug 183519: Complains that button size is not variable, it's a dupe or been
duped by me, I will look for it and mark one as such.

Bug 187767: Dupe of this bug. Marked, thanks.
Comment 5 Marcelo Sales 2009-08-14 01:22:58 UTC
This problem makes the Battery Monitor plasmoid, among others, completely unusable in vertical plasma panels.
Besides, plasmoids like the K Menu or the Device Notifier can't be placed side by side in vertical panels, taking up to much vertical space and wasting the horizontal space next to them.
These limitations restrict very much the use of vertical plasma panels. That's a pity, because otherwise they could help us to make a better use of the desktop space in wide screen monitors, which seem to be more and more common these days.
Comment 6 Dotan Cohen 2009-08-20 17:51:10 UTC
*** Bug 192250 has been marked as a duplicate of this bug. ***
Comment 7 Stefan Endrullis 2009-08-20 18:50:43 UTC
And what about the horizontal panel? There you are unable to resize plasmoids as well. The plasmoids even don't care about the number of rows you have configured for your "KDE4 kicker" (however it's called now). For instance the Battery Monitor plasmoid is now 4 times larger than it was in KDE3. That's just a waste of space!
Comment 8 Dotan Cohen 2009-08-22 18:14:28 UTC
@Stefan: You are right and I am removing the word "vertical" from the title.
Comment 9 Stefan Endrullis 2009-08-22 21:57:18 UTC
Thanks.
Comment 10 Stefan Endrullis 2009-08-29 19:50:12 UTC
*** This bug has been confirmed by popular vote. ***
Comment 11 Dotan Cohen 2009-11-28 17:40:40 UTC
There are some important comments from Aaron Seigo regarding implementation in dupe Bug #187767.
Comment 12 Paul Pogonyshev 2015-02-09 23:49:58 UTC
Another usecase for sizing: some widgets want to be squarish, even if they would look perfect otherwise too. As a result, in a vertical panel they took too much space. One example of this is CPU Monitor.
Comment 13 Nate Graham 2018-06-08 20:04:31 UTC
Hello!

This feature request was filed for KDE Plasma 4, which reached end-of-support status in August 2015. KDE Plasma 5's desktop shell has been almost completely rewritten for better performance and usability, so it is likely that this feature request is already implemented in Plasma 5, or is no longer applicable.

Accordingly, we hope you understand why we must close this feature request. If the requested feature is still desired but not implemented in KDE Plasma 5.12 or later, please feel free to open a new ticket in the "plasmashell" product after reading https://community.kde.org/Get_Involved/Bug_Reporting

If you would like to get involved in KDE's bug triaging effort so that future mass bug closes like this are less likely, please read https://community.kde.org/Get_Involved#Bug_Triaging

Thanks for your understanding!

Nate Graham