Bug 193015 - Feature request: Plasmoid-container Plasmoid
Summary: Feature request: Plasmoid-container Plasmoid
Status: RESOLVED UNMAINTAINED
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Unspecified
: NOR wishlist
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-17 16:58 UTC by Dotan Cohen
Modified: 2018-06-08 20:26 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
Screenshot showing current vertical panel with Plasmoids (42.52 KB, image/png)
2009-05-18 09:08 UTC, Dotan Cohen
Details
Screenshot showing proposed Plasmoid container in vertical panel with Plasmoids (39.35 KB, image/png)
2009-05-18 09:08 UTC, Dotan Cohen
Details
Where to do this in KDE-3 (73.46 KB, image/png)
2009-08-19 17:11 UTC, James Richard Tyrer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2009-05-17 16:58:15 UTC
Version:            (using KDE 4.2.3)
Installed from:    Ubuntu Packages

In KDE 4 many Plasmoids seem out of place suspended without background in the panel. This is due to the KDE 4 panel's "shiny" two-tone appearance. I propose that there be a Plasmoid-container Plasmoid which would provide a background similar in appearance to the System Tray and also to the Task Bar items.
Comment 1 Dotan Cohen 2009-05-17 16:59:01 UTC
Just to clarify, Plasmoids would not _have_ to be in the container, the user could put them there at his discretion. Also, there could be more than one container per panel.
Comment 2 Dotan Cohen 2009-05-18 09:08:11 UTC
Created attachment 33789 [details]
Screenshot showing current vertical panel with Plasmoids
Comment 3 Dotan Cohen 2009-05-18 09:08:48 UTC
Created attachment 33790 [details]
Screenshot showing proposed Plasmoid container in vertical panel with Plasmoids
Comment 4 Dotan Cohen 2009-07-04 02:14:50 UTC
*** Bug 173949 has been marked as a duplicate of this bug. ***
Comment 5 James Richard Tyrer 2009-07-11 21:37:01 UTC
IIUC, you mean something like KDE-3 "Button Backgrounds" which are missing from Plasma.
Comment 6 Dotan Cohen 2009-07-11 22:38:22 UTC
Actually, James, I do not know what that feature is, I never used it nor heard of it in KDE 3.
Comment 7 Scott Stubbs 2009-08-19 15:58:00 UTC
From the screen shots I do agree that is what is being requested (well the analog of it anyway). However Dotan is marking other bugs as duplicates when they are asking for the containment plasmoid, cause that is what he named this one.

If one was able to set the colour for the background on a containment plasmoid (describe in Bug 173949), I believe that would also be a solution to this bug (the one he thought of when he named it).

If anyone else comes across this bug please look at Bug 173949.
Comment 8 James Richard Tyrer 2009-08-19 17:11:33 UTC
Created attachment 36281 [details]
Where to do this in KDE-3

In KDE-3 this is possible but there are a fixed set of choices.  IMHO, only the button option is needed.  However, you should be able to select the color of the button.
Comment 9 Dotan Cohen 2009-08-20 12:19:58 UTC
> However Dotan is marking other bugs as duplicates when
> they are asking for the containment plasmoid, cause that
> is what he named this one.

I was very clear in mentioning on the single bug that I marked as a dupe why it was marked as a dupe and not the other way around:
https://bugs.kde.org/show_bug.cgi?id=173949#c3


Furthermore, although it is not mentioned in this bug (it probably should be), the container plasmoid would provide a solution to several other bugs that have issues with Plasmoid sizes, such as the battery icon and the digital clock. Those bugs that would be solved by implementing this one do have that mentioned on them.
Comment 10 Nate Graham 2018-06-08 20:26:23 UTC
Hello!

This feature request was filed for KDE Plasma 4, which reached end-of-support status in August 2015. KDE Plasma 5's desktop shell has been almost completely rewritten for better performance and usability, so it is likely that this feature request is already implemented in Plasma 5, or is no longer applicable.

Accordingly, we hope you understand why we must close this feature request. If the requested feature is still desired but not implemented in KDE Plasma 5.12 or later, please feel free to open a new ticket in the "plasmashell" product after reading https://community.kde.org/Get_Involved/Bug_Reporting

If you would like to get involved in KDE's bug triaging effort so that future mass bug closes like this are less likely, please read https://community.kde.org/Get_Involved#Bug_Triaging

Thanks for your understanding!

Nate Graham