Bug 169408 - Wish: Drag and drop image file to onto Gwenview window in view mode to view that image
Summary: Wish: Drag and drop image file to onto Gwenview window in view mode to view t...
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR wishlist with 5 votes (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
: 170551 193547 241149 262963 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-08-18 23:16 UTC by Ivo Anjo
Modified: 2018-06-03 17:21 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 18.08.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivo Anjo 2008-08-18 23:16:14 UTC
Version:            (using KDE 4.1.0)
OS:                Linux
Installed from:    SuSE RPMs

It would be nice if I could both drop a picture on the gwenview window while in view mode, and drag a picture from there.

Both operations work while in browse mode, and if dragging from the picture directly can pose problems with regards to dragging to move the picture around (although in many modes like fit or window bigger than picture dragging does nothing), maybe a draggable link could be added to the sidebar.
Comment 1 Aurelien Gateau 2008-09-10 17:46:48 UTC
*** Bug 170551 has been marked as a duplicate of this bug. ***
Comment 2 Aurelien Gateau 2009-06-08 09:35:35 UTC
*** Bug 193547 has been marked as a duplicate of this bug. ***
Comment 3 Sergey 2010-06-14 14:58:02 UTC
Join. This is a really missed feature.
Comment 4 Jekyll Wu 2012-01-03 09:04:31 UTC
*** Bug 241149 has been marked as a duplicate of this bug. ***
Comment 5 Jekyll Wu 2012-01-03 12:13:39 UTC
*** Bug 262963 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2017-09-11 03:26:09 UTC
You can now as of Gwenview 17.11.70 drag from the thumbnail pane while in View mode. But you can't drag a picture to the window to replace the current vierw with the dragged picture.
Comment 7 Huon 2018-06-02 23:31:02 UTC
Git commit 131d25855e11174ab978386c14ab09cdc07f3fb9 by Huon Imberger.
Committed on 02/06/2018 at 23:30.
Pushed by huoni into branch 'master'.

Allow dragging files/folders to View mode

Summary:
Specifically accepts drop events within the viewport of {nav View} mode.
If a folder that contains images is dropped, it will open that folder
and remain in {nav View} mode with the first image selected. If the
folder doesn't contain images, it switches to {nav Browse} mode.
Dragging multiple items is supported but only the first item is opened.
FIXED-IN: 18.08.0

{F5781556}

Test Plan:
Test with different image formats, as well as unsupported format (Gwenview
should display a nice error).
Test with folder (with and without images within).
{nav Browse} mode and the {nav Thumbnail Bar} drag drop should work as before.
Drop operations should not be accepted anywhere else in the GUI where they aren't
already supported. In other words, this should only add drop functionality to the
{nav View} viewport.

Ensure drops are only accepted for URL mimetypes (e.g. ignore text).

Reviewers: #gwenview, rkflx, ngraham

Reviewed By: #gwenview, rkflx

Tags: #gwenview

Differential Revision: https://phabricator.kde.org/D11879

M  +4    -0    app/mainwindow.cpp
M  +2    -0    app/viewmainpage.cpp
M  +4    -0    app/viewmainpage.h
M  +22   -0    lib/documentview/documentview.cpp
M  +6    -0    lib/documentview/documentview.h

https://commits.kde.org/gwenview/131d25855e11174ab978386c14ab09cdc07f3fb9
Comment 8 Ivo Anjo 2018-06-03 09:28:43 UTC
Woah! Took a bit longer than I expected but thank you!

I actually no longer use KDE (on Unity now), but I *do* still use gwenview over the usual gnome image viewer, so 🎉🎉🎉
Comment 9 Nate Graham 2018-06-03 17:21:15 UTC
Great!

BTW, if you like Unity, you might consider checking out KDE Plasma again. IMHO, you can set Plasma up to emulate the look-and-feel of Unity much better than Canonical could when they switched to GNOME 3 with Ubuntu 18.04.