Bug 262963 - No Drag & drop in gwenview
Summary: No Drag & drop in gwenview
Status: RESOLVED DUPLICATE of bug 169408
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-12 16:07 UTC by krienke
Modified: 2012-10-19 13:27 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description krienke 2011-01-12 16:07:07 UTC
Version:           2.5 (using KDE 4.5.5) 
OS:                Linux

I opened a photo in gwenview by clicking on the file in dolphin. Now I wanted to drag another photo (jpg) from dolphin on gwenview to view this photo, but gwenview does not accept drag and drop. The mouse cursor changes to a one-way- road icon when I drag the jpg file on gwenviews window.

I think this should work right out of the box in a modern gui.

Thanks
Rainer

Reproducible: Didn't try

Steps to Reproduce:
Open a photo in gwenview then try to dra another photo from dolphin on gwenview.

Actual Results:  
Drag-operation is not accepted by gwenview

Expected Results:  
The photo dragged from dolphin on gwenviews window should be displayed.
Comment 1 Hans-Rudi Denzler 2011-01-12 20:54:03 UTC
It works in 'Browse' mode which displays a 'folder' (4.6 RC 2).
Comment 2 krienke 2011-01-13 08:43:34 UTC
Well I do not yet have 4.6 RC2 so I cannot say what browse mode is. But why should drag and drop only work in a specific mode?

Whenever gwenview displays an image it should be possible to drop another file on gwenview to display the new dopped file, this is what a user would expect.

In KDE 4.5.5 the only mode wehre drag and drop works with gwenview is in menu (german) "Ansicht->Übersicht" where you see all photos that are contained in a folder. Dragging an image on gwenview in this mode starts a copy operation which is ok because gwenview acts as a kind of filemanager here. But if gwenview displays a photo it should be able to accept a drop operation in order to show the dropped file. 

Thanks
Rainer
Comment 3 Hans-Rudi Denzler 2011-01-13 10:46:42 UTC
"Ansicht->Übersicht" is 'Browse' (Help > Switch Application Language...):
Drag and drop 'Browse' mode: copy
Drag and drop 'View'   mode: open (not yet implemented)
Comment 4 Jekyll Wu 2012-01-03 12:13:39 UTC

*** This bug has been marked as a duplicate of bug 169408 ***