Bug 158088 - Knotify constantly crash with SIGABRT signal
Summary: Knotify constantly crash with SIGABRT signal
Status: RESOLVED FIXED
Alias: None
Product: Phonon
Classification: Unclassified
Component: Xine backend (show other bugs)
Version: unspecified
Platform: Compiled Sources Tru64
: NOR crash (vote)
Target Milestone: ---
Assignee: Matthias Kretz
URL:
Keywords:
: 154011 161795 164665 166179 166401 166432 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-02-20 11:04 UTC by Sylvain "Skarsnik" Colinet
Modified: 2009-02-15 09:52 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sylvain "Skarsnik" Colinet 2008-02-20 11:04:47 UTC
Version:            (using Devel)
Installed from:    Compiled sources
Compiler:          gcc 4.2.3  
OS:                Linux

Knotify crash when kde start and often crash after

compiled with qt4.4 from qt-copy
kdebase revision 777004
Debian unstable

Libxine not installed


Application: KNotify (knotify4), signal SIGABRT
Using host libthread_db library "/lib/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 0xb65116c0 (LWP 3339)]
[New Thread 0xb407fb90 (LWP 3341)]
[New Thread 0xb4880b90 (LWP 3340)]
[KCrash handler]
#6  0xffffe410 in __kernel_vsyscall ()
#7  0xb6741ef5 in raise () from /lib/i686/cmov/libc.so.6
#8  0xb6743871 in abort () from /lib/i686/cmov/libc.so.6
#9  0xb7cbd184 in qt_message_output (msgType=QtFatalMsg, 
    buf=0xb407c820 "ASSERT: \"s_instance->m_nullPort\" in file /mnt/data/KDE4/kde-svn/kdebase/runtime/phonon/xine/xineengine.cpp, line 254")
    at /mnt/data/KDE4/kde-svn/qt-copy/src/corelib/global/qglobal.cpp:2047
#10 0xb7cbd1e9 in qFatal (msg=0xb7e2d0a4 "ASSERT: \"%s\" in file %s, line %d")
    at /mnt/data/KDE4/kde-svn/qt-copy/src/corelib/global/qglobal.cpp:2249
#11 0xb7cbd645 in qt_assert (assertion=0xb4a45221 "s_instance->m_nullPort", 
    file=0xb4a44bb4 "/mnt/data/KDE4/kde-svn/kdebase/runtime/phonon/xine/xineengine.cpp", line=254)
    at /mnt/data/KDE4/kde-svn/qt-copy/src/corelib/global/qglobal.cpp:1821
#12 0xb4a1a4cc in Phonon::Xine::XineEngine::nullPort ()
    at /mnt/data/KDE4/kde-svn/kdebase/runtime/phonon/xine/xineengine.cpp:254
#13 0xb4a21006 in Phonon::Xine::XineStream::createStream (this=0x814c928)
    at /mnt/data/KDE4/kde-svn/kdebase/runtime/phonon/xine/xinestream.cpp:372
#14 0xb4a24661 in Phonon::Xine::XineStream::event (this=0x814c928, 
    ev=0x80f5cb0)
    at /mnt/data/KDE4/kde-svn/kdebase/runtime/phonon/xine/xinestream.cpp:931
#15 0xb7046d11 in QApplicationPrivate::notify_helper (this=0x806ba18, 
    receiver=0x814c928, e=0x80f5cb0)
    at /mnt/data/KDE4/kde-svn/qt-copy/src/gui/kernel/qapplication.cpp:3757
#16 0xb704702a in QApplication::notify (this=0xbf87ef6c, receiver=0x814c928, 
    e=0x80f5cb0)
    at /mnt/data/KDE4/kde-svn/qt-copy/src/gui/kernel/qapplication.cpp:3351
#17 0xb6d27bc9 in KApplication::notify (this=0xbf87ef6c, receiver=0x814c928, 
    event=0x80f5cb0)
    at /mnt/data/KDE4/kde-svn/kdelibs/kdeui/kernel/kapplication.cpp:311
#18 0xb7dc9f1f in QCoreApplication::notifyInternal (this=0xbf87ef6c, 
    receiver=0x814c928, event=0x80f5cb0)
    at /mnt/data/KDE4/kde-svn/qt-copy/src/corelib/kernel/qcoreapplication.cpp:586
#19 0xb7dce139 in QCoreApplication::sendEvent (receiver=0x814c928, 
    event=0x80f5cb0)
    at ../../include/QtCore/../../../../qt-copy/src/corelib/kernel/qcoreapplication.h:215
#20 0xb7dca4bc in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, 
    event_type=0, data=0x814c500)
    at /mnt/data/KDE4/kde-svn/qt-copy/src/corelib/kernel/qcoreapplication.cpp:1191
#21 0xb7dca729 in QCoreApplication::sendPostedEvents (receiver=0x0, 
    event_type=0)
    at /mnt/data/KDE4/kde-svn/qt-copy/src/corelib/kernel/qcoreapplication.cpp:1084
#22 0xb7e006ce in QCoreApplication::sendPostedEvents ()
    at ../../include/QtCore/../../../../qt-copy/src/corelib/kernel/qcoreapplication.h:220
#23 0xb7dff86f in postEventSourceDispatch (s=0x80f7278)
    at /mnt/data/KDE4/kde-svn/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:211
#24 0xb65c62b6 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#25 0xb65c9643 in ?? () from /usr/lib/libglib-2.0.so.0
#26 0x0814c398 in ?? ()
#27 0x00000000 in ?? ()

Thread 1 (Thread 0xb65116c0 (LWP 3339)):
#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb7c51aa5 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/i686/cmov/libpthread.so.0
#2  0xb7cc7cf8 in QMutexPrivate::wait (this=0x814eb80, timeout=-1)
    at /mnt/data/KDE4/kde-svn/qt-copy/src/corelib/thread/qmutex_unix.cpp:85
#3  0xb7cc190d in QMutex::lock (this=0x814c954)
    at /mnt/data/KDE4/kde-svn/qt-copy/src/corelib/thread/qmutex.cpp:188
#4  0xb4a20338 in Phonon::Xine::XineStream::closeBlocking (this=0x814c928)
    at /mnt/data/KDE4/kde-svn/kdebase/runtime/phonon/xine/xinestream.cpp:1214
#5  0xb4a30e43 in ~MediaObject (this=0x814afb8)
    at /mnt/data/KDE4/kde-svn/kdebase/runtime/phonon/xine/mediaobject.cpp:117
#6  0xb6ae66f1 in Phonon::MediaNodePrivate::deleteBackendObject (
    this=0x80f3270) at /mnt/data/KDE4/kde-svn/kdelibs/phonon/medianode.cpp:78
#7  0xb6af423c in ~FactoryPrivate (this=0x8104ef0)
    at /mnt/data/KDE4/kde-svn/kdelibs/phonon/factory.cpp:133
#8  0xb6af376e in destroy ()
    at /mnt/data/KDE4/kde-svn/kdelibs/phonon/factory.cpp:47
#9  0xb6adf523 in ~CleanUpGlobalStatic (this=0xb6b06850)
    at /mnt/data/KDE4/kde-svn/kdelibs/phonon/globalstatic_p.h:57
#10 0xb6af35cc in __tcf_0 ()
    at /mnt/data/KDE4/kde-svn/kdelibs/phonon/factory.cpp:47
#11 0xb6744ef4 in exit () from /lib/i686/cmov/libc.so.6
#12 0xb70c431f in qt_xio_errhandler ()
    at /mnt/data/KDE4/kde-svn/qt-copy/src/gui/kernel/qapplication_x11.cpp:590
#13 0xb6d27116 in KApplication::xioErrhandler (this=0xbf87ef6c, dpy=0x8075a18)
    at /mnt/data/KDE4/kde-svn/kdelibs/kdeui/kernel/kapplication.cpp:418
#14 0xb6d27156 in kde_xio_errhandler (dpy=0x8075a18)
    at /mnt/data/KDE4/kde-svn/kdelibs/kdeui/kernel/kapplication.cpp:130
#15 0xb799833d in _XIOError () from /usr/lib/libX11.so.6
#16 0xb799ad23 in _XEventsQueued () from /usr/lib/libX11.so.6
#17 0xb798679f in XEventsQueued () from /usr/lib/libX11.so.6
#18 0xb71005af in x11EventSourceCheck (s=0x806e980)
    at /mnt/data/KDE4/kde-svn/qt-copy/src/gui/kernel/qguieventdispatcher_glib.cpp:89
#19 0xb65c902b in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#20 0xb65c9417 in ?? () from /usr/lib/libglib-2.0.so.0
#21 0x0806d698 in ?? ()
#22 0x7fffffff in ?? ()
#23 0x080d5fa0 in ?? ()
#24 0x00000005 in ?? ()
#25 0xb65c9bfe in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#26 0xb7dfeb08 in QEventDispatcherGlib::processEvents (this=0x806b0b0, 
    flags=@0xbf87ee28)
    at /mnt/data/KDE4/kde-svn/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:327
#27 0xb70fffe0 in QGuiEventDispatcherGlib::processEvents (this=0x806b0b0, 
    flags=@0xbf87ee5c)
    at /mnt/data/KDE4/kde-svn/qt-copy/src/gui/kernel/qguieventdispatcher_glib.cpp:204
#28 0xb7dc677e in QEventLoop::processEvents (this=0xbf87eedc, 
    flags=@0xbf87ee94)
    at /mnt/data/KDE4/kde-svn/qt-copy/src/corelib/kernel/qeventloop.cpp:146
#29 0xb7dc692b in QEventLoop::exec (this=0xbf87eedc, flags=@0xbf87eee4)
    at /mnt/data/KDE4/kde-svn/qt-copy/src/corelib/kernel/qeventloop.cpp:197
#30 0xb7dca84a in QCoreApplication::exec ()
    at /mnt/data/KDE4/kde-svn/qt-copy/src/corelib/kernel/qcoreapplication.cpp:838
#31 0xb7046a2a in QApplication::exec ()
    at /mnt/data/KDE4/kde-svn/qt-copy/src/gui/kernel/qapplication.cpp:3289
#32 0x0804d2ec in main (argc=-1226273528, argv=0x80d29d8)
    at /mnt/data/KDE4/kde-svn/kdebase/runtime/knotify/main.cpp:68
#0  0xffffe410 in __kernel_vsyscall ()
Comment 1 Sylvain "Skarsnik" Colinet 2008-02-21 11:18:59 UTC
I install libxine and this bugs doesn't occur anymore. Maybe some test in Phonon/Knotify is missing
Comment 2 Matthias Kretz 2008-02-21 20:37:21 UTC
Did the cmake check for kdebase not complain? Did you compile with KDE4_DISABLE_MULTIMEDIA? If you let me know what check exactly is missing or if there's bad wording somewhere I'll fix it.
Comment 3 Sylvain "Skarsnik" Colinet 2008-02-22 01:58:22 UTC
I install all headers need for building kdebase and kdelibs (and phonon) but not all the libraries itself (libxine package was broken), sorry I run cmakekde over kdelibs, etc.. and don't pay attention when all is seem fine :).

Recently I install libxine (package fixed \o/) and knotify doesn't complain 
aynmore, maybe phonon can tell knotify (or other apps) "Hey I can't play anything because lib aren't here!, install it or tell me where they are and I can work!"


Comment 4 Matthias Kretz 2008-02-23 12:03:22 UTC
The problem is that I still don't know what was actually missing and what was 
there. Did you only have to fix your libxine package or did you have to 
recompile phonon-xine, or even recompile more of KDE? Did you only miss the 
libxine plugins? All of them or specific ones?
Comment 5 Sylvain "Skarsnik" Colinet 2008-02-24 00:56:34 UTC
I compile kdelib with only the xine's headers, the library (.so file) wasn't here, Irun kde4, knotify crash, I install the library, knotify don't crash 
Comment 6 Matthias Kretz 2008-02-24 01:27:12 UTC
kdelibs does not use xine. Do you mean kdebase? And if yes, it is impossible 
to link if the .so file is not present. So it should have failed at linking 
phonon-xine. So either make in kdebase failed or you did have both the xine 
headers and lib installed at the time.
Comment 7 Sylvain "Skarsnik" Colinet 2008-02-24 02:12:32 UTC
Yes I meant kdebase. I search in CMakelog and output, The only match for 'xine' is  the line wich test the presence of xinelib (compiling a small src file). I don't know what mess I have done, I will try to reproduce that with another debian installation
Comment 8 Michael 2008-03-09 14:23:27 UTC
I have this crash too (I've taken to moving knotify4 to prevent the annoying popups) here is the latest iteration of the bug.  I do not mind re-emerging or trying more updated packages.

What do you need more info on?



Application: KNotify (knotify4), signal SIGABRT 
 Using host libthread_db library "/lib/libthread_db.so.1". 
 [Thread debugging using libthread_db enabled] 
 [New Thread 0x2ac61bd46cf0 (LWP 18500)] 
 [New Thread 0x44808950 (LWP 18514)] 
 [New Thread 0x44007950 (LWP 18513)] 
 [New Thread 0x43806950 (LWP 18512)] 
 [New Thread 0x43005950 (LWP 18511)] 
 [New Thread 0x42804950 (LWP 18510)] 
 [New Thread 0x42003950 (LWP 18509)] 
 [New Thread 0x41802950 (LWP 18508)] 
 [New Thread 0x41001950 (LWP 18504)] 
 [New Thread 0x40800950 (LWP 18502)] 
 [KCrash handler] 
 #5  0x00002ac61a0eb3c5 in *__GI_raise (sig=<value optimized out>) 
     at ../nptl/sysdeps/unix/sysv/linux/raise.c:64 
 #6  0x00002ac61a0ec73e in *__GI_abort () at abort.c:88 
 #7  0x00002ac61a0e4b1f in *__GI___assert_fail ( 
     assertion=0x2ac61f923350 "plug->gen.slave == plug->req_slave", 
     file=0x2ac61f92331a "pcm_plug.c", line=67, 
     function=0x2ac61f9235a0 "snd_pcm_plug_close") at assert.c:78 
 #8  0x00002ac61f8f6614 in snd_pcm_plug_close (pcm=0xe08200) at pcm_plug.c:67 
 #9  0x00002ac61f8e1b35 in snd_pcm_close (pcm=0xe08200) at pcm.c:707 
 #10 0x00002aaaab58ea47 in ao_alsa_open (this_gen=0x819400, bits=16, 
     rate=48000, mode=<value optimized out>) at audio_alsa_out.c:620 
 #11 0x00002ac61f65ccd3 in ao_change_settings (this=0x834e40, bits=16, rate=6, 
     mode=4) at audio_out.c:1438 
 #12 0x00002ac61f65ef7f in ao_open (this_gen=0x834e40, stream=0x7ce000, 
     bits=16, rate=44100, mode=4) at audio_out.c:1497 
 #13 0x00002aaab178f5b6 in vorbis_decode_data (this_gen=0xdf3450, 
     buf=<value optimized out>) at xine_vorbis_decoder.c:205 
 #14 0x00002ac61f6598a1 in audio_decoder_loop ( 
     stream_gen=<value optimized out>) at audio_decoder.c:360 
 #15 0x00002ac61583a047 in start_thread (arg=<value optimized out>) 
     at pthread_create.c:296 
 #16 0x00002ac61a17b28d in clone () from /lib64/libc.so.6 
 #17 0x0000000000000000 in ?? () 
 
 Thread 2 (Thread 0x44808950 (LWP 18514)): 
 #0  0x00002ac61583e6a6 in pthread_cond_wait@@GLIBC_2.3.2 () 
    from /lib64/libpthread.so.0 
 #1  0x00002ac61f66107b in xine_event_wait (queue=0xdce120) at events.c:56 
 #2  0x00002ac61f6610f5 in listener_loop (queue_gen=<value optimized out>) 
     at events.c:214 
 #3  0x00002ac61583a047 in start_thread (arg=<value optimized out>) 
     at pthread_create.c:296 
 #4  0x00002ac61a17b28d in clone () from /lib64/libc.so.6 
 #5  0x0000000000000000 in ?? () 
 
 Thread 1 (Thread 0x2ac61bd46cf0 (LWP 18500)): 
 #0  0x00002ac61583e897 in pthread_cond_timedwait@@GLIBC_2.3.2 () 
    from /lib64/libpthread.so.0 
 #1  0x00002ac61545eb57 in QWaitCondition::wait (this=<value optimized out>, 
     mutex=0x95b620, time=10000) at thread/qwaitcondition_unix.cpp:86 
 #2  0x00002ac61545df76 in QThread::wait (this=<value optimized out>, 
     time=10000) at thread/qthread_unix.cpp:561 
 #3  0x00002ac61f3d4ee4 in ~XineEngine (this=0x72b770) 
     at /var/tmp/portage/kde-base/kdebase-9999.4/work/kdebase-9999.4/runtime/phonon/xine/xineengine.cpp:86 
 #4  0x00002ac61f3e9c26 in ~Backend (this=0x727460) 
     at /var/tmp/portage/kde-base/kdebase-9999.4/work/kdebase-9999.4/runtime/phonon/xine/backend.cpp:96 
 #5  0x00002ac618dcc36e in ~FactoryPrivate (this=0x708eb0) 
     at /var/tmp/portage/kde-base/kdelibs-9999.4/work/kdelibs-9999.4/phonon/factory.cpp:139 
 #6  0x00002ac61a0ed9e9 in *__GI_exit (status=1) at exit.c:75 
 #7  0x00002ac6171fa6d8 in qt_xio_errhandler () 
     at kernel/qapplication_x11.cpp:590 
 #8  0x00002ac6187897c0 in KApplication::xioErrhandler (this=0x7fff95b18ff0, 
     dpy=0x648610) 
     at /var/tmp/portage/kde-base/kdelibs-9999.4/work/kdelibs-9999.4/kdeui/kernel/kapplication.cpp:418 
 #9  0x00002ac6163087c4 in _XIOError (dpy=0x648610) at XlibInt.c:2940 
 #10 0x00002ac61630acff in _XEventsQueued (dpy=0x648610, 
     mode=<value optimized out>) at XlibInt.c:788 
 #11 0x00002ac6162f9c5e in XEventsQueued (dpy=0x648610, mode=2) at Pending.c:44 
 #12 0x00002ac61722c93c in x11EventSourceCheck (s=0x635e40) 
     at kernel/qguieventdispatcher_glib.cpp:89 
 #13 0x00002ac61b329c8d in IA__g_main_context_check (context=0x635120, 
     max_priority=2147483647, fds=0x2ac61583dc60, n_fds=<value optimized out>) 
     at gmain.c:2569 
 #14 0x00002ac61b32a005 in g_main_context_iterate (context=0x635120, block=1, 
     dispatch=1, self=<value optimized out>) at gmain.c:2691 
 #15 0x00002ac61b32a7ae in IA__g_main_context_iteration (context=0x635120, 
     may_block=1) at gmain.c:2753 
 #16 0x00002ac61556df4e in QEventDispatcherGlib::processEvents (this=0x625fa0, 
     flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:325 
 #17 0x00002ac61722c99f in QGuiEventDispatcherGlib::processEvents ( 
     this=0x95b70c, flags=<value optimized out>) 
     at kernel/qguieventdispatcher_glib.cpp:204 
 #18 0x00002ac615541318 in QEventLoop::processEvents ( 
     this=<value optimized out>, flags=<value optimized out>) 
     at kernel/qeventloop.cpp:146 
 #19 0x00002ac61554145a in QEventLoop::exec (this=0x7fff95b18f30, 
     flags=@0x7fff95b18f40) at kernel/qeventloop.cpp:197 
 #20 0x00002ac6155436b0 in QCoreApplication::exec () 
     at kernel/qcoreapplication.cpp:838 
 #21 0x00000000004064cf in main (argc=1, argv=0x7fff95b19398) 
     at /var/tmp/portage/kde-base/kdebase-9999.4/work/kdebase-9999.4/runtime/knotify/main.cpp:68 
 #22 0x00002ac61a0d8b74 in __libc_start_main (main=0x405f40 <main>, argc=1, 
     ubp_av=0x7fff95b19398, init=<value optimized out>, 
     fini=<value optimized out>, rtld_fini=<value optimized out>, 
     stack_end=0x7fff95b19388) at libc-start.c:229 
 #23 0x0000000000405ea9 in _start () 
 #0  0x00002ac61583e897 in pthread_cond_timedwait@@GLIBC_2.3.2 () 
    from /lib64/libpthread.so.0 
Comment 9 Martin von Gagern 2008-04-18 22:34:21 UTC
Symptoms happened here on my Gentoo Linux as well. For me, removing ~/.xine/config was the solution, which I found after seeing xine_config_load in my backtrace. Probably a xine bug, this one here at least.
Comment 10 Lubos Lunak 2008-07-21 16:23:00 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 11 Olivier Goffart 2008-07-21 18:01:13 UTC
*** Bug 166179 has been marked as a duplicate of this bug. ***
Comment 12 Olivier Goffart 2008-07-21 18:01:27 UTC
*** Bug 166401 has been marked as a duplicate of this bug. ***
Comment 13 Olivier Goffart 2008-07-21 18:01:39 UTC
*** Bug 166432 has been marked as a duplicate of this bug. ***
Comment 14 Olivier Goffart 2008-07-21 18:01:54 UTC
*** Bug 164665 has been marked as a duplicate of this bug. ***
Comment 15 Olivier Goffart 2008-07-21 18:02:02 UTC
*** Bug 161795 has been marked as a duplicate of this bug. ***
Comment 16 Olivier Goffart 2008-07-21 18:02:12 UTC
*** Bug 154011 has been marked as a duplicate of this bug. ***
Comment 17 Matthias Kretz 2008-12-29 17:16:04 UTC
Is this crash still reproducible? The failed assertion on a missing null xine plugin up in the report is valid and tells you about a broken installation. All the other reports are probably only symptoms of a different problem. Any recent crash backtrace available?
Comment 18 Öyvind Saether 2009-01-17 11:45:04 UTC
@Matthias Kretz  2008-12-29: KDE 4.1.96, I get frequent pop-ups with knotify crashing.

rogram: KNotify (knotify4), signal SIGSEGV
Using host libthread_db library "/lib/libthread_db.so.1".

Thread 1 (Thread 0xb66456d0 (LWP 17335)):
[KCrash Handler]
#6  QMetaObject::activate (sender=0x0, m=0xb7c21db0, local_signal_index=4, argv=0xbfcdb76c) at kernel/qobject.cpp:3094
#7  0xb7c1ab13 in Phonon::AudioOutputAdaptor::outputDeviceIndexChanged (this=0x0, _t1=0) at /tmp/portage/media-sound/phonon-4.2.96/work/phonon_build/phonon/moc_audiooutputadaptor_p.cpp:185
#8  0xb7c05f9d in Phonon::AudioOutputPrivate::handleAutomaticDeviceChange (this=0x80b2518, device2=@0xbfcdb874, type=Phonon::AudioOutputPrivate::FallbackChange)
    at /tmp/portage/media-sound/phonon-4.2.96/work/phonon-4.2.96/phonon/audiooutput.cpp:366
#9  0xb7c07f62 in Phonon::AudioOutputPrivate::setupBackendObject (this=0x80b2518) at /tmp/portage/media-sound/phonon-4.2.96/work/phonon-4.2.96/phonon/audiooutput.cpp:269
#10 0xb7c0693c in Phonon::AudioOutputPrivate::init (this=0x80b2518, c=Phonon::NotificationCategory) at /tmp/portage/media-sound/phonon-4.2.96/work/phonon-4.2.96/phonon/audiooutput.cpp:85
#11 0x08052394 in PlayerPool::getPlayer (this=0x8081c34) at /tmp/portage/kde-base/knotify-4.1.96/work/knotify-4.1.96/knotify/notifybysound.cpp:59
#12 0x08052b16 in NotifyBySound::notify (this=0x80b45a0, eventId=71, config=0x818f5d0) at /tmp/portage/kde-base/knotify-4.1.96/work/knotify-4.1.96/knotify/notifybysound.cpp:237
#13 0x0804e485 in KNotify::emitEvent (this=0xbfcdc4d8, e=0x818f5c8) at /tmp/portage/kde-base/knotify-4.1.96/work/knotify-4.1.96/knotify/knotify.cpp:176
#14 0x0804e6de in KNotify::event (this=0xbfcdc4d8, event=@0x8248e80, appname=@0x823c810, contexts=@0xbfcdbae8, text=@0x81ae3f0, pixmap=@0xbfcdbad4, actions=@0x82363d0, winId=96468994)
    at /tmp/portage/kde-base/knotify-4.1.96/work/knotify-4.1.96/knotify/knotify.cpp:126
#15 0x0804eaf6 in KNotifyAdaptor::event (this=0x80e2908, event=@0x8248e80, fromApp=@0x823c810, contexts=@0x8223c40, text=@0x81ae3f0, image=@0x81692c8, actions=@0x82363d0, winId=<value optimized out>)
    at /tmp/portage/kde-base/knotify-4.1.96/work/knotify-4.1.96/knotify/knotify.cpp:235
#16 0x0804f625 in KNotifyAdaptor::qt_metacall (this=0x80e2908, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfcdbbe8)
    at /tmp/portage/kde-base/knotify-4.1.96/work/knotify_build/knotify/knotify.moc:208
#17 0xb7981713 in QDBusConnectionPrivate::deliverCall (this=0x8068e78, object=0x80e2908, msg=@0x82457a8, metaTypes=@0x80e70e4, slotIdx=8) at qdbusintegrator.cpp:855
#18 0xb79829a1 in QDBusConnectionPrivate::activateCall (this=0x8068e78, object=0x80e2908, flags=273, msg=@0x82457a8) at qdbusintegrator.cpp:767
#19 0xb7982daf in QDBusConnectionPrivate::activateObject (this=0x8068e78, node=@0x8245794, msg=@0x82457a8, pathStartPos=7) at qdbusintegrator.cpp:1312
#20 0xb798329a in QDBusActivateObjectEvent::placeMetaCall (this=0x8245768) at qdbusintegrator.cpp:1406
#21 0xb788b201 in QObject::event (this=0xbfcdc4d8, e=0x8245768) at kernel/qobject.cpp:1152
#22 0xb6f2ed44 in QApplicationPrivate::notify_helper (this=0x8078378, receiver=0xbfcdc4d8, e=0x8245768) at kernel/qapplication.cpp:3809
#23 0xb6f36b2e in QApplication::notify (this=0xbfcdc4ec, receiver=0xbfcdc4d8, e=0x8245768) at kernel/qapplication.cpp:3399
#24 0xb7e1aa9d in KApplication::notify (this=0xbfcdc4ec, receiver=0xbfcdc4d8, event=0x8245768) at /tmp/portage/kde-base/kdelibs-4.1.96/work/kdelibs-4.1.96/kdeui/kernel/kapplication.cpp:307
#25 0xb787b926 in QCoreApplication::notifyInternal (this=0xbfcdc4ec, receiver=0xbfcdc4d8, event=0x8245768) at kernel/qcoreapplication.cpp:593
#26 0xb787c564 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x805e640) at kernel/qcoreapplication.h:215
#27 0xb787c75d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1097
#28 0xb78a607f in postEventSourceDispatch (s=0x8070980) at kernel/qcoreapplication.h:220
#29 0xb67fc340 in IA__g_main_context_dispatch (context=0x8070900) at gmain.c:2144
#30 0xb67ffa13 in g_main_context_iterate (context=0x8070900, block=1, dispatch=1, self=0x8078e68) at gmain.c:2778
#31 0xb67ffbd1 in IA__g_main_context_iteration (context=0x8070900, may_block=1) at gmain.c:2841
#32 0xb78a5ca8 in QEventDispatcherGlib::processEvents (this=0x8078df0, flags={i = -1077034040}) at kernel/qeventdispatcher_glib.cpp:325
#33 0xb6fc46e5 in QGuiEventDispatcherGlib::processEvents (this=0x8078df0, flags={i = -1077033992}) at kernel/qguieventdispatcher_glib.cpp:204
#34 0xb787a02a in QEventLoop::processEvents (this=0xbfcdc470, flags={i = -1077033928}) at kernel/qeventloop.cpp:149
#35 0xb787a1e2 in QEventLoop::exec (this=0xbfcdc470, flags={i = -1077033864}) at kernel/qeventloop.cpp:200
#36 0xb787c825 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:851
#37 0xb6f2ebb7 in QApplication::exec () at kernel/qapplication.cpp:3337
#38 0x0804d79b in main (argc=1, argv=0xbfcdc634) at /tmp/portage/kde-base/knotify-4.1.96/work/knotify-4.1.96/knotify/main.cpp:73
Comment 19 Jeremy Whiting 2009-02-05 04:16:29 UTC
I get the same backtrace as Øyvind Sæther on x86 platform, built from sources, reproducible every time by running some flash that produces sound in firefox, then getting a notification.
Comment 20 Öyvind Saether 2009-02-05 15:40:40 UTC
I have NOT seen this "knotify" crash after rebuilding the "media-sound/phonon" WITHOUT the "gstreamer" (USE="xcb xine -debug -gstreamer"). I started building it with USE="-gstreamer" around 4.1.96 (perhaps exactly 4.1.96, which is when I got this problem).
Comment 21 Matthias Kretz 2009-02-15 09:52:57 UTC
#18 is a different bug, already reported somewhere else and should be fixed in trunk and branch.

Closing this bug now as I believe this is fixed or invalid depending on what of the three different bugs in the comments you're interested.