Bug 166179 - knotify4 sometimes crashes when playing sound
Summary: knotify4 sometimes crashes when playing sound
Status: RESOLVED DUPLICATE of bug 158088
Alias: None
Product: kdelibs
Classification: Unclassified
Component: knotify (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Olivier Goffart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-09 23:10 UTC by Frederik Himpe
Modified: 2008-07-21 18:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frederik Himpe 2008-07-09 23:10:10 UTC
Version:           4.0.85 (using Devel)
Installed from:    Compiled sources

Sometimes (probably when trying to play a sound), knotify4 crashes. This is the backtrace:

Application: KNotify (knotify4), signal SIGSEGV
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0x7fadc0a49700 (LWP 12189)]
[New Thread 0x493f9950 (LWP 21683)]
[New Thread 0x48bf8950 (LWP 21682)]
[New Thread 0x483f7950 (LWP 21681)]
[New Thread 0x473f5950 (LWP 21680)]
[New Thread 0x46bf4950 (LWP 21679)]
[New Thread 0x40efc950 (LWP 21676)]
[New Thread 0x433ed950 (LWP 21675)]
[New Thread 0x44bf0950 (LWP 21674)]
[New Thread 0x43bee950 (LWP 21673)]
[New Thread 0x45bf2950 (LWP 21662)]
[New Thread 0x453f1950 (LWP 21661)]
[New Thread 0x47bf6950 (LWP 12217)]
[New Thread 0x42bec950 (LWP 12200)]
[New Thread 0x423eb950 (LWP 12199)]
[New Thread 0x41bea950 (LWP 12192)]
[KCrash handler]
#5  0x00007fadb61dfc70 in close_internal (stream=0x1ca1ea0) at xine.c:443
#6  0x00007fadb61dfd6b in xine_dispose (stream=0x1ca1ea0) at xine.c:492
#7  0x00007fadb6442b79 in ~XineStream (this=0x16de8b0)
    at /usr/src/debug/kdebase-runtime-4.0.84/phonon/xine/xinestream.cpp:105
#8  0x00007fadb645779c in ~XineStreamKeeper (this=0x7fada4001280)
    at /usr/lib/qt4/include/QtCore/qshareddata.h:152
#9  0x00007fadc0138a3d in QObject::event (this=0x7fada4001280, e=0xe)
    at kernel/qobject.cpp:1124
#10 0x00007fadbf65cebd in QApplicationPrivate::notify_helper (this=0x135e4a0, 
    receiver=0x7fada4001280, e=0x7fada4003550) at kernel/qapplication.cpp:3772
#11 0x00007fadbf664b9a in QApplication::notify (this=0x7fffc8a7a970, 
    receiver=0x7fada4001280, e=0x7fada4003550) at kernel/qapplication.cpp:3739
#12 0x00007fadbee6beeb in KApplication::notify (this=0x7fffc8a7a970, 
    receiver=0x7fada4001280, event=0x7fada4003550)
    at /usr/src/debug/kdelibs-4.0.85/kdeui/kernel/kapplication.cpp:311
#13 0x00007fadc012999f in QCoreApplication::notifyInternal (
    this=0x7fffc8a7a970, receiver=0x7fada4001280, event=0x7fada4003550)
    at kernel/qcoreapplication.cpp:587
#14 0x00007fadc012a64a in QCoreApplicationPrivate::sendPostedEvents (
    receiver=0x0, event_type=0, data=0x157e890)
    at kernel/qcoreapplication.h:215
#15 0x00007fadc0152153 in postEventSourceDispatch (s=<value optimized out>)
    at kernel/qcoreapplication.h:220
#16 0x00007fadbd3b67d2 in g_main_context_dispatch ()
   from /usr/lib64/libglib-2.0.so.0
#17 0x00007fadbd3b9f6d in ?? () from /usr/lib64/libglib-2.0.so.0
#18 0x00007fadbd3ba12b in g_main_context_iteration ()
   from /usr/lib64/libglib-2.0.so.0
#19 0x00007fadc0151ddf in QEventDispatcherGlib::processEvents (
    this=0x157ecb0, flags=<value optimized out>)
    at kernel/qeventdispatcher_glib.cpp:325
#20 0x00007fadc01282b2 in QEventLoop::processEvents (
    this=<value optimized out>, flags={i = 1111404592})
    at kernel/qeventloop.cpp:149
#21 0x00007fadc012843d in QEventLoop::exec (this=0x423eb070, flags=
      {i = 1111404672}) at kernel/qeventloop.cpp:200
#22 0x00007fadc003d9d8 in QThread::exec (this=<value optimized out>)
    at thread/qthread.cpp:433
#23 0x00007fadb6439a63 in Phonon::Xine::XineThread::run (this=0x152a030)
    at /usr/src/debug/kdebase-runtime-4.0.84/phonon/xine/xinethread.cpp:111
#24 0x00007fadc0040935 in QThreadPrivate::start (arg=0x152a030)
    at thread/qthread_unix.cpp:190
#25 0x00007fadbe17d2a3 in start_thread () from /lib64/libpthread.so.0
#26 0x00007fadbe46e03d in clone () from /lib64/libc.so.6

Thread 14 (Thread 0x42bec950 (LWP 12200)):
#0  0x00007fadbe466872 in select () from /lib64/libc.so.6
#1  0x00007fadb620a414 in xine_usec_sleep (usec=<value optimized out>)
    at utils.c:485
#2  0x00007fadb61f020b in video_out_loop (this_gen=<value optimized out>)
    at video_out.c:1246
#3  0x00007fadbe17d2a3 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fadbe46e03d in clone () from /lib64/libc.so.6

Thread 13 (Thread 0x47bf6950 (LWP 12217)):
#0  0x00007fadbe180f59 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
#1  0x00007fadb61f3683 in ao_loop (this_gen=<value optimized out>)
    at audio_out.c:346
#2  0x00007fadbe17d2a3 in start_thread () from /lib64/libpthread.so.0
#3  0x00007fadbe46e03d in clone () from /lib64/libc.so.6

Thread 12 (Thread 0x453f1950 (LWP 21661)):
#0  0x00007fadbe17fe80 in __pthread_mutex_unlock_usercnt ()
   from /lib64/libpthread.so.0
#1  0x00007fadb11ac4d2 in ao_alsa_handle_event_thread (
    data=<value optimized out>) at audio_alsa_out.c:247
#2  0x00007fadbe17d2a3 in start_thread () from /lib64/libpthread.so.0
#3  0x00007fadbe46e03d in clone () from /lib64/libc.so.6

Thread 11 (Thread 0x45bf2950 (LWP 21662)):
#0  0x00007fadbe180f59 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
#1  0x00007fadb61f3683 in ao_loop (this_gen=<value optimized out>)
    at audio_out.c:346
#2  0x00007fadbe17d2a3 in start_thread () from /lib64/libpthread.so.0
#3  0x00007fadbe46e03d in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x43bee950 (LWP 21673)):
#0  0x00007fadbe45fe2b in read () from /lib64/libc.so.6
#1  0x00007fadb6a7f3e5 in ?? () from /usr/lib64/libasound.so.2
#2  0x00007fadb6a7a758 in snd_hctl_handle_events ()
   from /usr/lib64/libasound.so.2
#3  0x00007fadb6a842b5 in snd_mixer_handle_events ()
   from /usr/lib64/libasound.so.2
#4  0x00007fadb11ac578 in ao_alsa_handle_event_thread (
    data=<value optimized out>) at audio_alsa_out.c:175
#5  0x00007fadbe17d2a3 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fadbe46e03d in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x44bf0950 (LWP 21674)):
#0  0x00007fadbe180f59 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
#1  0x00007fadb61f3683 in ao_loop (this_gen=<value optimized out>)
    at audio_out.c:346
#2  0x00007fadbe17d2a3 in start_thread () from /lib64/libpthread.so.0
#3  0x00007fadbe46e03d in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x433ed950 (LWP 21675)):
#0  0x00007fadbe180f59 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
#1  0x00007fadb61e60eb in fifo_buffer_get (fifo=0x1cf47a0) at buffer.c:230
#2  0x00007fadb61ebebe in video_decoder_loop (
    stream_gen=<value optimized out>) at video_decoder.c:130
#3  0x00007fadbe17d2a3 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fadbe46e03d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x40efc950 (LWP 21676)):
#0  0x00007fadbe180f59 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
#1  0x00007fadb61e60eb in fifo_buffer_get (fifo=0x155e640) at buffer.c:230
#2  0x00007fadb61ecf6e in audio_decoder_loop (
    stream_gen=<value optimized out>) at audio_decoder.c:66
#3  0x00007fadbe17d2a3 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fadbe46e03d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x46bf4950 (LWP 21679)):
#0  0x00007fadbe17e93b in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007fadb11ac563 in ao_alsa_handle_event_thread (
    data=<value optimized out>) at audio_alsa_out.c:171
#2  0x00007fadbe17d2a3 in start_thread () from /lib64/libpthread.so.0
#3  0x00007fadbe46e03d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x473f5950 (LWP 21680)):
#0  0x00007fadbe180f59 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
#1  0x00007fadb61f3683 in ao_loop (this_gen=<value optimized out>)
    at audio_out.c:346
#2  0x00007fadbe17d2a3 in start_thread () from /lib64/libpthread.so.0
#3  0x00007fadbe46e03d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x483f7950 (LWP 21681)):
#0  0x00007fadbe180f59 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
#1  0x00007fadb61e60eb in fifo_buffer_get (fifo=0x1c7afe0) at buffer.c:230
#2  0x00007fadb61ebebe in video_decoder_loop (
    stream_gen=<value optimized out>) at video_decoder.c:130
#3  0x00007fadbe17d2a3 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fadbe46e03d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x48bf8950 (LWP 21682)):
#0  0x00007fadbe180f59 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
#1  0x00007fadb61e60eb in fifo_buffer_get (fifo=0x1569d40) at buffer.c:230
#2  0x00007fadb61ecf6e in audio_decoder_loop (
    stream_gen=<value optimized out>) at audio_decoder.c:66
#3  0x00007fadbe17d2a3 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fadbe46e03d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x493f9950 (LWP 21683)):
#0  0x00007fadbe180f59 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
#1  0x00007fadb61f627b in listener_loop (queue_gen=<value optimized out>)
    at events.c:56
#2  0x00007fadbe17d2a3 in start_thread () from /lib64/libpthread.so.0
#3  0x00007fadbe46e03d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fadc0a49700 (LWP 12189)):
#0  0x00007fadbe180f59 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
#1  0x00007fadc0041919 in QWaitCondition::wait (this=0x16d54b8, 
    mutex=0x16d5498, time=18446744073709551615)
    at thread/qwaitcondition_unix.cpp:88
#2  0x00007fadb64428f4 in Phonon::Xine::XineStream::closeBlocking (
    this=0x16d5440)
    at /usr/src/debug/kdebase-runtime-4.0.84/phonon/xine/xinestream.cpp:1249
#3  0x00007fadb6453c99 in ~MediaObject (this=0x1c82920)
    at /usr/src/debug/kdebase-runtime-4.0.84/phonon/xine/mediaobject.cpp:120
#4  0x00007fadbea2871b in Phonon::MediaNodePrivate::deleteBackendObject ()
   from /usr/lib64/libphonon.so.4
#5  0x00007fadbea37bb4 in Phonon::FactoryPrivate::~FactoryPrivate ()
   from /usr/lib64/libphonon.so.4
#6  0x00007fadbe3c585d in exit () from /lib64/libc.so.6
#7  0x00007fadbf6b6768 in qt_xio_errhandler ()
    at kernel/qapplication_x11.cpp:590
#8  0x00007fadbee6b8e0 in KApplication::xioErrhandler (this=0x7fffc8a7a970, 
    dpy=0x1363be0)
    at /usr/src/debug/kdelibs-4.0.85/kdeui/kernel/kapplication.cpp:418
#9  0x00007fadbb6c6e83 in _XIOError () from /usr/lib64/libX11.so.6
#10 0x00007fadbb6d0471 in ?? () from /usr/lib64/libX11.so.6
#11 0x00007fadbb6d055a in _XEventsQueued () from /usr/lib64/libX11.so.6
#12 0x00007fadbb6af20e in XEventsQueued () from /usr/lib64/libX11.so.6
#13 0x00007fadbf6ed6cc in x11EventSourceCheck (s=0x1361a30)
    at kernel/qguieventdispatcher_glib.cpp:89
#14 0x00007fadbd3b950a in g_main_context_check ()
   from /usr/lib64/libglib-2.0.so.0
#15 0x00007fadbd3b9e51 in ?? () from /usr/lib64/libglib-2.0.so.0
#16 0x00007fadbd3ba12b in g_main_context_iteration ()
   from /usr/lib64/libglib-2.0.so.0
#17 0x00007fadc0151ddf in QEventDispatcherGlib::processEvents (
    this=0x1351fd0, flags=<value optimized out>)
    at kernel/qeventdispatcher_glib.cpp:325
#18 0x00007fadbf6ed50f in QGuiEventDispatcherGlib::processEvents (
    this=0x1c69b1c, flags=<value optimized out>)
    at kernel/qguieventdispatcher_glib.cpp:204
#19 0x00007fadc01282b2 in QEventLoop::processEvents (
    this=<value optimized out>, flags={i = -928536464})
    at kernel/qeventloop.cpp:149
#20 0x00007fadc012843d in QEventLoop::exec (this=0x7fffc8a7a8b0, flags=
      {i = -928536384}) at kernel/qeventloop.cpp:200
#21 0x00007fadc012a90d in QCoreApplication::exec ()
    at kernel/qcoreapplication.cpp:845
#22 0x00000000004065bb in _start ()
Comment 1 Lubos Lunak 2008-07-21 16:23:21 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 2 Olivier Goffart 2008-07-21 18:01:12 UTC

*** This bug has been marked as a duplicate of 158088 ***