Bug 166401 - knotify crashes on notification or dialog
Summary: knotify crashes on notification or dialog
Status: RESOLVED DUPLICATE of bug 158088
Alias: None
Product: kdelibs
Classification: Unclassified
Component: knotify (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Olivier Goffart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-12 21:48 UTC by Diarmuid Bourke
Modified: 2008-07-21 18:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diarmuid Bourke 2008-07-12 21:48:12 UTC
Version:            (using Devel)
Installed from:    Compiled sources
Compiler:          gcc 4.2.3 
OS:                Linux

I've compiled kde4 from svn under Ubuntu 8.04 running in vmware-server.
Whenever a notification occurs, knotify4 crashes and recursively crashes repeatedly.

Application: KNotify (knotify4), signal SIGABRT
[Thread debugging using libthread_db enabled]
[New Thread 0xb6761720 (LWP 26737)]
[New Thread 0xb42e7b90 (LWP 26739)]
[New Thread 0xb4ae8b90 (LWP 26738)]
[KCrash handler]
#6  0xb7f5f410 in __kernel_vsyscall ()
#7  0xb699b085 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb699ca01 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb7d61895 in qt_message_output (msgType=QtFatalMsg, 
    buf=0xb42e4820 "ASSERT: \"s_instance->m_nullPort\" in file /home/diarmuid/kde/src/KDE/kdebase/runtime/phonon/xine/xineengine.cpp, line 256")
    at /home/diarmuid/kde/src/qt-copy/src/corelib/global/qglobal.cpp:2058
#10 0xb7d61919 in qFatal (msg=0xb7eb8104 "ASSERT: \"%s\" in file %s, line %d")
    at /home/diarmuid/kde/src/qt-copy/src/corelib/global/qglobal.cpp:2260
#11 0xb7d61d71 in qt_assert (assertion=0xb4c034cd "s_instance->m_nullPort", 
    file=0xb4c0310c "/home/diarmuid/kde/src/KDE/kdebase/runtime/phonon/xine/xineengine.cpp", line=256)
    at /home/diarmuid/kde/src/qt-copy/src/corelib/global/qglobal.cpp:1828
#12 0xb4bd5ad6 in Phonon::Xine::XineEngine::nullPort ()
    at /home/diarmuid/kde/src/KDE/kdebase/runtime/phonon/xine/xineengine.cpp:256
#13 0xb4bdc558 in Phonon::Xine::XineStream::createStream (this=0x8136828)
    at /home/diarmuid/kde/src/KDE/kdebase/runtime/phonon/xine/xinestream.cpp:379
#14 0xb4bdfd20 in Phonon::Xine::XineStream::event (this=0x8136828, 
    ev=0x8138330)
    at /home/diarmuid/kde/src/KDE/kdebase/runtime/phonon/xine/xinestream.cpp:959
#15 0xb72c152d in QApplicationPrivate::notify_helper (this=0x8076410, 
    receiver=0x8136828, e=0x8138330)
    at /home/diarmuid/kde/src/qt-copy/src/gui/kernel/qapplication.cpp:3772
#16 0xb72c1813 in QApplication::notify (this=0xbfcfb78c, receiver=0x8136828, 
    e=0x8138330)
    at /home/diarmuid/kde/src/qt-copy/src/gui/kernel/qapplication.cpp:3366
#17 0xb6f96741 in KApplication::notify (this=0xbfcfb78c, receiver=0x8136828, 
    event=0x8138330)
    at /home/diarmuid/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:311
#18 0xb7e6068a in QCoreApplication::notifyInternal (this=0xbfcfb78c, 
    receiver=0x8136828, event=0x8138330)
    at /home/diarmuid/kde/src/qt-copy/src/corelib/kernel/qcoreapplication.cpp:583
#19 0xb7e641c9 in QCoreApplication::sendEvent (receiver=0x8136828, 
    event=0x8138330)
    at ../../include/QtCore/../../../../src/qt-copy/src/corelib/kernel/qcoreapplication.h:215
#20 0xb7e60ba2 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, 
    event_type=0, data=0x812f7d8)
    at /home/diarmuid/kde/src/qt-copy/src/corelib/kernel/qcoreapplication.cpp:1195
#21 0xb7e60d53 in QCoreApplication::sendPostedEvents (receiver=0x0, 
    event_type=0)
    at /home/diarmuid/kde/src/qt-copy/src/corelib/kernel/qcoreapplication.cpp:1091
#22 0xb7e915a2 in QCoreApplication::sendPostedEvents ()
    at ../../include/QtCore/../../../../src/qt-copy/src/corelib/kernel/qcoreapplication.h:220
#23 0xb7e907b3 in postEventSourceDispatch (s=0x8101ba8)
    at /home/diarmuid/kde/src/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:211
#24 0xb681cbf8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#25 0xb681fe5e in ?? () from /usr/lib/libglib-2.0.so.0
#26 0xb68203ac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#27 0xb7e8fbcc in QEventDispatcherGlib::processEvents (this=0x8072d50, 
    flags=@0xb42e7224)
    at /home/diarmuid/kde/src/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:325
#28 0xb7e5d54a in QEventLoop::processEvents (this=0xb42e729c, 
    flags=@0xb42e7264)
    at /home/diarmuid/kde/src/qt-copy/src/corelib/kernel/qeventloop.cpp:149
#29 0xb7e5d789 in QEventLoop::exec (this=0xb42e729c, flags=@0xb42e72a4)
    at /home/diarmuid/kde/src/qt-copy/src/corelib/kernel/qeventloop.cpp:196
#30 0xb7d684a1 in QThread::exec (this=0x8120468)
    at /home/diarmuid/kde/src/qt-copy/src/corelib/thread/qthread.cpp:433
#31 0xb4bd222b in Phonon::Xine::XineThread::run (this=0x8120468)
    at /home/diarmuid/kde/src/KDE/kdebase/runtime/phonon/xine/xinethread.cpp:111
#32 0xb7d6c405 in QThreadPrivate::start (arg=0x8120468)
    at /home/diarmuid/kde/src/qt-copy/src/corelib/thread/qthread_unix.cpp:190
#33 0xb7ced4fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#34 0xb6a46e5e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb6761720 (LWP 26737)):
#0  0xb7f5f410 in __kernel_vsyscall ()
#1  0xb7cf1aa5 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb7d6b108 in QMutexPrivate::wait (this=0x8131d20, timeout=-1)
    at /home/diarmuid/kde/src/qt-copy/src/corelib/thread/qmutex_unix.cpp:85
#3  0xb7d65a06 in QMutex::lock (this=0x8136854)
    at /home/diarmuid/kde/src/qt-copy/src/corelib/thread/qmutex.cpp:188
#4  0xb4bdb852 in Phonon::Xine::XineStream::closeBlocking (this=0x8136828)
    at /home/diarmuid/kde/src/KDE/kdebase/runtime/phonon/xine/xinestream.cpp:1242
#5  0xb4bee001 in ~MediaObject (this=0x812df18)
    at /home/diarmuid/kde/src/KDE/kdebase/runtime/phonon/xine/mediaobject.cpp:120
#6  0xb6d8bf1d in Phonon::MediaNodePrivate::deleteBackendObject ()
   from /home/diarmuid/kde/lib/libphonon.so.4
#7  0xb6d9e29c in Phonon::FactoryPrivate::~FactoryPrivate ()
   from /home/diarmuid/kde/lib/libphonon.so.4
#8  0xb6d9d372 in Phonon::._252::destroy ()
   from /home/diarmuid/kde/lib/libphonon.so.4
#9  0xb6d804af in Phonon::CleanUpGlobalStatic::~CleanUpGlobalStatic ()
   from /home/diarmuid/kde/lib/libphonon.so.4
#10 0xb6d9d1d0 in __tcf_0 () from /home/diarmuid/kde/lib/libphonon.so.4
#11 0xb699e084 in exit () from /lib/tls/i686/cmov/libc.so.6
#12 0xb7331567 in qt_xio_errhandler ()
    at /home/diarmuid/kde/src/qt-copy/src/gui/kernel/qapplication_x11.cpp:590
#13 0xb6f95c90 in KApplication::xioErrhandler (this=0xbfcfb78c, dpy=0x80804e0)
    at /home/diarmuid/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:418
#14 0xb6f95cd0 in kde_xio_errhandler (dpy=0x80804e0)
    at /home/diarmuid/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:130
#15 0xb7a2f892 in _XIOError () from /usr/lib/libX11.so.6
#16 0xb7a36fb7 in ?? () from /usr/lib/libX11.so.6
#17 0xb7a3771f in _XEventsQueued () from /usr/lib/libX11.so.6
#18 0xb7a20a4f in XEventsQueued () from /usr/lib/libX11.so.6
#19 0xb736994e in x11EventSourcePrepare (s=0x8079038, timeout=0xbfcfb578)
    at /home/diarmuid/kde/src/qt-copy/src/gui/kernel/qguieventdispatcher_glib.cpp:81
#20 0xb681f3e0 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#21 0xb681fb09 in ?? () from /usr/lib/libglib-2.0.so.0
#22 0xb68203ac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#23 0xb7e8fbcc in QEventDispatcherGlib::processEvents (this=0x8071150, 
    flags=@0xbfcfb654)
    at /home/diarmuid/kde/src/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:325
#24 0xb7369428 in QGuiEventDispatcherGlib::processEvents (this=0x8071150, 
    flags=@0xbfcfb684)
    at /home/diarmuid/kde/src/qt-copy/src/gui/kernel/qguieventdispatcher_glib.cpp:204
#25 0xb7e5d54a in QEventLoop::processEvents (this=0xbfcfb700, 
    flags=@0xbfcfb6c4)
    at /home/diarmuid/kde/src/qt-copy/src/corelib/kernel/qeventloop.cpp:149
#26 0xb7e5d789 in QEventLoop::exec (this=0xbfcfb700, flags=@0xbfcfb708)
    at /home/diarmuid/kde/src/qt-copy/src/corelib/kernel/qeventloop.cpp:196
#27 0xb7e60e73 in QCoreApplication::exec ()
    at /home/diarmuid/kde/src/qt-copy/src/corelib/kernel/qcoreapplication.cpp:845
#28 0xb72c1246 in QApplication::exec ()
    at /home/diarmuid/kde/src/qt-copy/src/gui/kernel/qapplication.cpp:3304
#29 0x0804da2b in main (argc=-1223630552, argv=0x80d8ef0)
    at /home/diarmuid/kde/src/KDE/kdebase/runtime/knotify/main.cpp:73
#0  0xb7f5f410 in __kernel_vsyscall ()
Comment 1 Lubos Lunak 2008-07-21 16:23:24 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 2 Olivier Goffart 2008-07-21 18:01:26 UTC

*** This bug has been marked as a duplicate of 158088 ***