Bug 164665 - system preferences -> notifications (systemeinstellungen -> benachrichtigungen) crashs when trying to play a sound twice
Summary: system preferences -> notifications (systemeinstellungen -> benachrichtigunge...
Status: RESOLVED DUPLICATE of bug 158088
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_notify (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-22 14:53 UTC by Christoph W.
Modified: 2008-07-21 18:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph W. 2008-06-22 14:53:44 UTC
Version:            (using KDE 4.0.4)
Installed from:    SuSE RPMs
OS:                Linux

in the system preferences -> notifications (systemeinstellungen -> benachrichtigungen) menu i can playback the chosen sounds once but on the second try the window crashes. this is reproduceable and yields the following backtrace:

[?1034h(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb65388e0 (LWP 28443)]
[New Thread 0xafd08b90 (LWP 28474)]
[New Thread 0xb0914b90 (LWP 28473)]
[New Thread 0xb12d9b90 (LWP 28467)]
[New Thread 0xb1adab90 (LWP 28466)]
[New Thread 0xb24a8b90 (LWP 28465)]
[New Thread 0xb2ca9b90 (LWP 28464)]
[New Thread 0xb34aab90 (LWP 28463)]
[New Thread 0xb3cb5b90 (LWP 28460)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb47d5a5e in ?? () from /usr/lib/libxine.so.1
#7  0xb48409db in ?? () from /usr/lib/kde4/phonon_xine.so
#8  0xb6b6fecc in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#9  0xb6b7631e in QApplication::notify () from /usr/lib/libQtGui.so.4
#10 0xb7b8736d in KApplication::notify () from /usr/lib/libkdeui.so.5
#11 0xb760db51 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#12 0xb760e411 in QCoreApplicationPrivate::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#13 0xb763632a in QEventDispatcherUNIX::processEvents ()
   from /usr/lib/libQtCore.so.4
#14 0xb760c2ca in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#15 0xb760c48a in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#16 0xb7530be3 in QThread::exec () from /usr/lib/libQtCore.so.4
#17 0xb4840728 in ?? () from /usr/lib/kde4/phonon_xine.so
#18 0xb75339b7 in ?? () from /usr/lib/libQtCore.so.4
#19 0xb74d7175 in start_thread () from /lib/libpthread.so.0
#20 0xb68bddce in clone () from /lib/libc.so.6

Thread 5 (Thread 0xb1adab90 (LWP 28466)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb74dac15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb47dff78 in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 4 (Thread 0xb12d9b90 (LWP 28467)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb74dac15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb47f1858 in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 3 (Thread 0xb0914b90 (LWP 28473)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb74dac15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb47ee76c in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xafd08b90 (LWP 28474)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb74daf42 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#2  0xb47eaa7e in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 0xb65388e0 (LWP 28443)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb74daf42 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#2  0xb753471c in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#3  0xb75337b4 in QThread::wait () from /usr/lib/libQtCore.so.4
#4  0xb48460cd in ?? () from /usr/lib/kde4/phonon_xine.so
#5  0xb4859d6e in ?? () from /usr/lib/kde4/phonon_xine.so
#6  0xb4bc1a5a in ?? () from /usr/lib/libphonon.so.4
#7  0xb4bc0d95 in ?? () from /usr/lib/libphonon.so.4
#8  0xb4bb0dab in ?? () from /usr/lib/libphonon.so.4
#9  0xb681d8f1 in exit () from /lib/libc.so.6
#10 0xb6bc7bbb in ?? () from /usr/lib/libQtGui.so.4
#11 0xb7b86d37 in KApplication::xioErrhandler () from /usr/lib/libkdeui.so.5
#12 0xb7b86d76 in ?? () from /usr/lib/libkdeui.so.5
#13 0xb72e3322 in _XIOError () from /usr/lib/libX11.so.6
#14 0xb72eb385 in ?? () from /usr/lib/libX11.so.6
#15 0xb72ebba5 in _XEventsQueued () from /usr/lib/libX11.so.6
#16 0xb72d3acf in XEventsQueued () from /usr/lib/libX11.so.6
#17 0xb6bfa44d in ?? () from /usr/lib/libQtGui.so.4
#18 0xb760c2ca in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#19 0xb760c48a in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#20 0xb760e66d in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#21 0xb6b6fd47 in QApplication::exec () from /usr/lib/libQtGui.so.4
#22 0x0805b847 in _start ()
#0  0xffffe430 in __kernel_vsyscall ()
Comment 1 George Goldberg 2008-06-27 04:44:06 UTC
I can't reproduce this crash using svn trunk r824163 (approx KDE 4.1 beta 2).
Comment 2 Lubos Lunak 2008-07-21 16:23:15 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 3 Olivier Goffart 2008-07-21 18:01:53 UTC

*** This bug has been marked as a duplicate of 158088 ***