Bug 166432 - crach by playing sound in Configure Notifications
Summary: crach by playing sound in Configure Notifications
Status: RESOLVED DUPLICATE of bug 158088
Alias: None
Product: kopete
Classification: Unclassified
Component: general (show other bugs)
Version: 0.50.1
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-13 11:02 UTC by skatefreak
Modified: 2008-07-21 18:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description skatefreak 2008-07-13 11:02:24 UTC
Version:           0.50.1 (using 4.0.4 (KDE 4.0.4 >= 20080505) "release 15.1", compiled sources)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.25.9-0.2-default

Go to Settings and than go to Configure Notifications. When the checkbox "Play a sound" is Checked and I click on the button to play the sound, I hear the sound and than Kopete crashes. I tried it several times and each time Kopete crashed. The only used plugin is the History plugin

Here is the backtrace from the KDE Crash Handler
[?1034h(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0x7f700a11a700 (LWP 25600)]
[New Thread 0x44aa0950 (LWP 25676)]
[New Thread 0x4429f950 (LWP 25675)]
[New Thread 0x43a9e950 (LWP 25673)]
[New Thread 0x4329d950 (LWP 25672)]
[New Thread 0x42a9c950 (LWP 25671)]
[New Thread 0x4229b950 (LWP 25670)]
[New Thread 0x41007950 (LWP 25669)]
[New Thread 0x41a9a950 (LWP 25666)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#5  0x00007f6fef4d0731 in ?? () from /usr/lib64/libxine.so.1
#6  0x00007f6fef7311ed in ?? () from /usr/lib64/kde4/phonon_xine.so
#7  0x00007f6fef7309f0 in ?? () from /usr/lib64/kde4/phonon_xine.so
#8  0x00007f7003aca92d in QApplicationPrivate::notify_helper ()
   from /usr/lib64/libQtGui.so.4
#9  0x00007f7003ad0cfa in QApplication::notify () from /usr/lib64/libQtGui.so.4
#10 0x00007f7007a88b7b in KApplication::notify () from /usr/lib64/libkdeui.so.5
#11 0x00007f7005d7ce9c in QCoreApplication::notifyInternal ()
   from /usr/lib64/libQtCore.so.4
#12 0x00007f7005d7d7cb in QCoreApplicationPrivate::sendPostedEvents ()
   from /usr/lib64/libQtCore.so.4
#13 0x00007f7005da3590 in QEventDispatcherUNIX::processEvents ()
   from /usr/lib64/libQtCore.so.4
#14 0x00007f7005d7b7f2 in QEventLoop::processEvents ()
   from /usr/lib64/libQtCore.so.4
#15 0x00007f7005d7b985 in QEventLoop::exec () from /usr/lib64/libQtCore.so.4
#16 0x00007f7005ca8cfc in QThread::exec () from /usr/lib64/libQtCore.so.4
#17 0x00007f6fef7306d1 in ?? () from /usr/lib64/kde4/phonon_xine.so
#18 0x00007f7005cab764 in ?? () from /usr/lib64/libQtCore.so.4
#19 0x00007f7005a3c040 in start_thread () from /lib64/libpthread.so.0
#20 0x00007f70011c90cd in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x4329d950 (LWP 25672)):
#0  0x00007f7005a3fdd9 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
#1  0x00007f6fef4d9f2b in ?? () from /usr/lib64/libxine.so.1
#2  0x00007f6fef4e102e in ?? () from /usr/lib64/libxine.so.1
#3  0x00007f7005a3c040 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f70011c90cd in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x43a9e950 (LWP 25673)):
#0  0x00007f7005a3fdd9 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
#1  0x00007f6fef4ea65b in ?? () from /usr/lib64/libxine.so.1
#2  0x00007f7005a3c040 in start_thread () from /lib64/libpthread.so.0
#3  0x00007f70011c90cd in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x4429f950 (LWP 25675)):
#0  0x00007f7005a3fdd9 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
#1  0x00007f6fef4e7a23 in ?? () from /usr/lib64/libxine.so.1
#2  0x00007f7005a3c040 in start_thread () from /lib64/libpthread.so.0
#3  0x00007f70011c90cd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x44aa0950 (LWP 25676)):
#0  0x00007f7005a4005d in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
#1  0x00007f6fef4e4575 in ?? () from /usr/lib64/libxine.so.1
#2  0x00007f7005a3c040 in start_thread () from /lib64/libpthread.so.0
#3  0x00007f70011c90cd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f700a11a700 (LWP 25600)):
#0  0x00007f7005a4005d in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
#1  0x00007f7005cac467 in QWaitCondition::wait ()
   from /usr/lib64/libQtCore.so.4
#2  0x00007f7005cab547 in QThread::wait () from /usr/lib64/libQtCore.so.4
#3  0x00007f6fef7359b5 in ?? () from /usr/lib64/kde4/phonon_xine.so
#4  0x00007f6fef747f33 in ?? () from /usr/lib64/kde4/phonon_xine.so
#5  0x00007f7006963ba0 in ?? () from /usr/lib64/libphonon.so.4
#6  0x00007f700112b26d in exit () from /lib64/libc.so.6
#7  0x00007f7003b1c2b8 in ?? () from /usr/lib64/libQtGui.so.4
#8  0x00007f7007a88580 in KApplication::xioErrhandler ()
   from /usr/lib64/libkdeui.so.5
#9  0x00007f7004de4ee4 in _XIOError () from /usr/lib64/libX11.so.6
#10 0x00007f7004dec918 in ?? () from /usr/lib64/libX11.so.6
#11 0x00007f7004ded076 in _XEventsQueued () from /usr/lib64/libX11.so.6
#12 0x00007f7004dd5623 in XEventsQueued () from /usr/lib64/libX11.so.6
#13 0x00007f7003b4b613 in ?? () from /usr/lib64/libQtGui.so.4
#14 0x00007f7005d7b7f2 in QEventLoop::processEvents ()
   from /usr/lib64/libQtCore.so.4
#15 0x00007f7005d7b985 in QEventLoop::exec () from /usr/lib64/libQtCore.so.4
#16 0x00007f7005d7da25 in QCoreApplication::exec ()
   from /usr/lib64/libQtCore.so.4
#17 0x00000000004461ac in _start ()
#0  0x00007f7005a4005d in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
Comment 1 Christophe Giboudeaux 2008-07-13 11:23:38 UTC
Please read the following page and provide a useful backtrace for this crash : http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports
Comment 2 Stefan Sarzio 2008-07-18 11:15:06 UTC
Works fine on Kubuntu 8.04, KDE 4.1 RC 1
Comment 3 Lubos Lunak 2008-07-21 16:23:22 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 4 Olivier Goffart 2008-07-21 18:01:37 UTC

*** This bug has been marked as a duplicate of 158088 ***