Bug 155150 - Different wallpaper on each virtual desktop
Summary: Different wallpaper on each virtual desktop
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: containment-desktop (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 1707 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 72836 163073 170005 173472 218453 219127 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-05 17:04 UTC by Jan Wolf
Modified: 2015-11-19 22:57 UTC (History)
48 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
how I've understand plasma (136.19 KB, image/png)
2009-03-05 23:11 UTC, FiNeX
Details
Example (112.66 KB, image/png)
2009-03-06 11:32 UTC, FiNeX
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Wolf 2008-01-05 17:04:01 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources

It would be nice if it was possible to assign different wallpapers to each virtual desktop again, like it was in KDE 3.
Comment 1 Peter Tselios 2008-02-12 08:57:15 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 Christophe Giboudeaux 2008-06-02 19:03:24 UTC
*** Bug 163073 has been marked as a duplicate of this bug. ***
Comment 3 Aaron J. Seigo 2008-08-28 23:02:19 UTC
*** Bug 170005 has been marked as a duplicate of this bug. ***
Comment 4 George Kiagiadakis 2008-10-24 22:46:34 UTC
*** Bug 173472 has been marked as a duplicate of this bug. ***
Comment 5 Nicolas L. 2008-11-01 14:16:26 UTC
this seems an important feature for kde 4.2, to make kde4 ok for desktop use
Comment 6 Pino Toscano 2008-11-02 16:44:31 UTC
*** Bug 164779 has been marked as a duplicate of this bug. ***
Comment 7 George 2008-12-01 16:27:02 UTC
this is the same as per desktop containments?
Comment 8 Jonathan Thomas 2008-12-01 16:45:35 UTC
Per-desktop containments provide this feature, yes.
Comment 9 Mario 2009-02-06 23:08:51 UTC
It's a very feature for kde 4.2, to make kde4 ok for desktop use
Comment 10 David Bush 2009-03-05 02:09:50 UTC
Here's a recent quote from "kubicle" in the thread at

http://kubuntuforums.net/forums/index.php?topic=3102057.msg171550#msg171550

**************************

That "weirdness" is by design. Activities (accessible via 'zoom out' and 'activity bar') are separate from virtual desktops. Activities change widget sets (and different backgrounds if you like) but keep your open windows the same, while virtual desktops can have different windows open but use the same widget set and background.

It's possible to "align" activities with virtual desktops (to have different activities on different virtual desktops...see kjjjshab's link above)...and a GUI option to change this is planned in KDE4.3

************************

I'm glad to hear that "aligning activities with desktops" will be a GUI option in 4.3. But great googly moogly, how do you ever expect to compete with Windows for popularity with this programmer's mindset? The average computer user doesn't care about the distinction between an activity and a desktop. This "alignment GUI" should have been part of KDE 4.0. Don't give us something useful and user friendly, then take it away and tell us it's for our own good!
Comment 11 Aaron J. Seigo 2009-03-05 21:49:50 UTC
@David: so different wallpapers is so critical to the user experience that we should keep it in place even if it comes at the cost of even more important changes not being possible? obviously not.

and this has nothing to do with "a programmer's mindset" and *everything* to do with reaching REAL user needs. and no, setting a wallpaper per desktop is not a critical user need.

how do i plan on competing with windows? (which is a stupid troll like question, tbh, but i'll answer it anyways) simple: by providing features they don't have. which plasma does. features that people actually go "oh, i'd switch because of that." i mean, ignoring the fact that windows doesn't have workspaces/desktops to begin with (making this a moot point anyways) and ignoring the fact that only some people who use multiple workspaces use separate wallpapers (ditto), having wallpaper-per-virtual-desktop doesn't bring people over in the quite the same that, say, being able to have different sets of tools organized into Activities that you can change based on what you are doing does.

*sigh*
Comment 12 adam 2009-03-05 22:13:34 UTC
Try considering the competition here as gnome, rather than windows necessarily. That's who KDE is losing its crucial user base to. This functionality is available in gnome but not KDE in one of the distros I use (ubuntu), and as a result of this, real users are choosing gnome over KDE. Sure it's a gimmick, but it's a helpful piece of functionality for regular people using real computers, and there's no reason that programmers should dictate to them rather than listening to their needs. Otherwise those workflows will just flow elsewhere.
Comment 13 Bernd Paysan 2009-03-05 22:31:00 UTC
Windows 7 will have workspaces. Having a different background window on each workspace is a nice tool for orientation; I have been using that for years, and I still stick to KDE 3.5 - not only for that reason, but it is one of the features I miss from KDE 4. On KDE 4 or Mac OS X (which doesn't support that either), I'm often lost on an empty space, and don't know if going left, right, up or down will get me to my used spaces - so I have to click on spaces (in Mac OS X) or go to top right corner (that's what I defined for KDE 4) to get an overview.

Since Mac OS X doesn't provide different pictures per workspace, I doubt Windows will (they steal from Mac OS X). But what we discuss here is not features in Windows or so, but programmer mindset. It reminds me on a story my mom told me about two of her ants, who both bought a new hat at the same time. One said to the other "but I like my new hat much more than you yours". How on earth did she know? How do *you* know we users don't have that as critical need? More than 1000 users voted for this bug; this is the only objective criteria you have. You might not need this, I don't need widgets lying around on my desktop (therefore, I have little incentive to leave KDE 3.5).

Having workspaces tied with activities (and let each have another background image) would be a very good solution, maybe add the option to have "sticky" plasmoids which are on all activities. In general, I see big progress in KDE 4, and only a few obscure missing features (like missing SSL client authentication in Kmail and this bug here) keep me sticking to KDE 3.5.
Comment 14 Aaron J. Seigo 2009-03-05 22:50:57 UTC
@adam: "This functionality is
available in gnome but not KDE in one of the distros I use (ubuntu), and as a
result of this, real users are choosing gnome over KDE."

and real users are choosing KDE over GNOME for other things we have in Plasma that GNOME doesn't. including in the wallpapers.

"but it's a helpful piece of functionality for regular people using real
computers,"

look, if i disagreed that there weren't some significant number of people who would actually like this i wouldn't keep this report open, i wouldn't work on solutions for it (see comment above). so you don't need to convince me that it's useful for some people.

but, look, don't harass me about it. don't give me this weak BS about "oh no, people are leaving in droves because of it", "how will we ever compete with windows" because it's all CRAP. right about now, i have less than zero interest on working on this issue. you have quite precisely worked in the opposite direction you were trying to go. good job! now someone else can go implement it, but i'll go deal with features that:

a) have actually significant numbers of users
b) have actually significant impacts on usage
c) don't come with people who figure the best way to get something out of me is to make comments like these.

@Bernd: "Having a different background window on each
workspace is a nice tool for orientation;"

there's a reason it's still open as a report. nobody's saying otherwise.

"How do *you* know we users don't have that as critical need?"

because i, unlike you, am actually in touch with our wider user base. for nearly any annoyance, missing feature or outright bug i can find you someone who considers it a critical issue. often several someones. that's just the nature of working on software that has 10s of millions of users.

"More than 1000 users voted for this bug"

people can put up to 20 votes on a bug; so yes, somewhere upwards of 50 people voted for it. but not 1000.

"this is the only objective criteria you have"

no, actually, it's not.

"You might not need this,"

agreed. then again, i implement and fix things i don't need all the time.

"I don't need widgets lying around on my desktop"

let's just take away all those little things in your panel too, then. they happen to be the same thing in kde 4. enjoy!

"would be a very good solution,"

great, so how about you stop wasting my time with your polemicizing on bugs.kde.org so i can continue working on these things? yay! really, it's either that or i just give up on bugs.kde.org altogether.

every. single. comment. you. make. ends up in my inbox. and i read them because i try to care about what happens here so that we can make kde better. these kinds of comments on bugs do not help that happen.

my hopefully not naive hope is that by spending a bit of time with comments like this one some of the people who use bugs.k.o will learn and start using it with a bit more care.

"maybe add the option to have "sticky" plasmoids which are on all activities."

no, this would cause far too many other problems.

"In general, I see big progress in KDE 4,"

you know, this ought to make me smile. in this exact moment, it doesn't. good job.
Comment 15 FiNeX 2009-03-05 23:09:05 UTC
@All: Activities and workspaces have been developed with different goals. While workspaces have been developed (and used, and appreciated) for having more working space, activities give more specialized work spaces.

Actually workspaces are managed by the window manager. On a lower level (try to watch to kwin+plasma on a vertical view) there is plasma desktop which can manage different activities.

When you try to understand this (on a sort of 3d perspective), having different wallpapers for each workspace became not logical. In this way it can be understand why this feature shouldn't be implemented "by design".

Probably the better solution to satisfy all people which voted to this bug is to implement a different plasma desktop, let me call a "fork", where we loose the third dimension and we return back to the old two dimensional desktop like kde 3 or gnome.
I'm not sure that mixing the concept of plasma-desktop with the old idea is good... sincerly, I don't like mixtures :-)


P.S: I'll try to attach a simple schema which could help to understand the issue.
Comment 16 FiNeX 2009-03-05 23:11:40 UTC
Created attachment 31808 [details]
how I've understand plasma
Comment 17 FiNeX 2009-03-05 23:16:13 UTC
Anyway, after understanding how plasma works, I've liked it... and now this bug has 20 votes less :-)
Comment 18 Thomas Weissel 2009-03-06 03:10:46 UTC
@aaron... i think its time to thank you very much for your work... if you (or someone else) finds the time to implement this feature... great! maybe through the option to set different activities as different sides of the cube (which i already tried to enable in 4.2) or however you will manage it.. if not.. so i am sure it is because of many other important things (maybe closing some real annoying bugs) i think this feature will be there someday.. and then it is surely very welcome by some users.. thx again .. kde4 is a great piece of software and it proves that the open democratic method of creating free software is as good as the known method of creating proprietary software..  who cares about win7

i find it somewhat amusing that we are able to say.. this free software.. our software (thats what i see in kde) is as good as aero .. even better.. thanx to u guys..
Comment 19 neal konneker 2009-03-06 04:14:05 UTC
Before I whine let me agree with Xapient that I appreciate all that you do and I patiently waiting for the fixes.  I voted for this bug because it used to be available, so one would logically assume that something that worked before and now didn't is a bug.  I said I am patiently awaiting the fixes because although I prefer KDE, when I was 'upgraded' to KDE 4, not only did I NOT see any enhancements (plasma didn't work) I couldn't even get it to work without some serious flaky behavior (bugs), so I switched to Gnome.  I freely admit that the problems I experienced are probably due to my lack of expertise, but more and more I get tired of fighting my computer and simply want it to work.  So, I understand you developers are working hard and appreciate your efforts and will simply wait until KDE 4 has upgraded to where it works for me again.
Comment 20 Bernd Paysan 2009-03-06 10:33:19 UTC
Window-manager-view (or "stacked 3D view"): I agree that something like the workspace with widgets in it should be managed by the window manager - after all, a widget is just a sort of window. This is quite logical. However, the background image doesn't have to be part of the workspace - it can be underneath (in the 3D view), and belong to the application space (which is shifted around when changing workspaces). I don't know that much about Plasma's internal design, but I hope you have not designed it for a particular purpose, but as a flexible tool to deal with and arrange widgets.

The 3D view should look like this:

apps -> application window stack, managed by window manager with decorations from window manager theme.
panel -> plasma stack, sticky window, managed by special purpose layout manager (no decorations, no overlapping).
activities -> plasma stack, maybe sticky window, managed by nested window manager without decorations. Decorations from Plasma theme.
desktop -> plasma desktop/panel view; managed by layout manager, otherwise the same.
background -> background image(s), background programs, either sticky (single background image/program) or tied to the virtual desktop, managed by window manager without decoration.

This sounds more logical to me, i.e. if you want to bring the activities to the top in a Mac OS X like fashion (stack: activities, apps, optional desktop, background), it is a trivial exercise - a Mac OS X mimic would hide the activities in normal operation (only having a desktop view). Of course you can zoom in and out of your different activities, and can have different schemes how the activities are tied to workspaces - zoom in and out, sticky window, non-sticky (attached to the workspace), workspace-like switching with active edges in activity mode, sticky plasmoids, etc.

Think of plasma and the window manager as tools to mimic the behavior the user is used to, not as something that makes decisions for him.
Comment 21 FiNeX 2009-03-06 11:32:48 UTC
Created attachment 31827 [details]
Example

Do you mean something like this (except for the panel containments management)?
Comment 22 Bernd Paysan 2009-03-06 11:46:28 UTC
@FiNeX: Yes, you got it. The panel itself is floating either on top, or between window layer and plasma layer when you allow windows to cover the panel.

The background really should be the image view plasmoid, expanded to full screen (not a special purpose background), and could be replaced with other plasmoids which are suitable for full screen view.
Comment 23 adam 2009-03-06 19:08:33 UTC
Wow, I am chastened now that I see a little more of the issues at work here, and really cheered to see this collaboration happening. I really appreciate the work you are all doing. From a humble user, thank you all and keep it up!
Comment 24 Jan Wolf 2009-03-10 21:20:08 UTC
Don't the perVirtualDesktopViews implement this behaviour sufficiently?

At least for me the ability to tie the virtual desktops to different customizable activities provided this functionality in a way that was even better than just plain custom wallpapers, because it made it possible to have different backends for what specific function that desktop should have (i.e. folder view or widget space).
Comment 25 Tomasz Kaźmierczak 2009-03-10 22:41:53 UTC
After reading recent comments by me, this bug has lost 20 more votes;)

I think the main problem with people perceiving lack of the feature in question as a bug, is that there is very few information about that new feature in KDE4 - the workspaces. At least was the case with me - I just simply didn't know about it (yes, I've read somewhere about KDE's new approach to user's "activities", or something like that, but there was no mention about what it actually means, about how it is implemented).

It should be at least more visually "indicated" in the new KDE that there is a possibility to define different workspaces, so that people would notice it before even thinking about setting different wallpapers on different virtual desktops.
Comment 26 list 2009-03-10 23:31:06 UTC
Hello, gentlemen,
I'll describe you my usage pattern which I've been using with KDE3 for several years:

- I had 6-8 desktops
- I was changing these desktops with single key (row of multimedia keys was mapped to desktop1, 2, 3, etc.)
- panel was autohiding
- every desktop had different color -- please note, that this was my ONLY indicator on which desktop I am
- I never used any icons or gadgets on desktop

I could have used this happily ever after.

But then came KDE4 :(

What options do I have now?

Use desktops:
- bad: background cannot be changed, so I don't have any visual indicator which desktop is active
- otherwise it's ok: keys work, desktop cube rotation or desktop wall are nice (but not really needed); I like also expose, but actually I never use it

Use workspaces
- first observation: since few minutes I didn't know they existed, so the UI for them is really hidden; I didn't study it much, but for my usage pattern they seem like a duplication for desktop
- bad: I didn't find a way to attach a key (but maybe this exists hidden somewhere... ?)
- good: desktop background can be changed, hurray!
- probably bad: desktop cube rotation doesn't seem to be compatible with this idea
- strange: If I zoom out to see workspaces, the window is still the same size, so it doesn't feel like zooming out
- bad: expose effect doesn't seem to be compatible with workspaces

So my resume is:
- in KDE4 there is no way to support what I've been using in KDE3
- I probably don't understand the concept of workspaces (is it my fault or bad design?)

So I still prefer separate backgrounds for every desktop. Obviously there are some people that enjoy workspaces - that's OK - let every person use what's appropriate to him.
Comment 27 Shlomi Fish 2009-03-29 16:35:01 UTC
Hi!

I am a developer in C, C++ and other programming languages with some experience contributing to KDE apps. This bug is the main reason why I'm usually still using KDE 3 as my desktop environment, despite the fact that I've converted to using mostly KDE 4 apps.

Now, I'm interested in contributing to fix this bug in KDE 4.3, but I'll need some guidance. Where should it be done? (Plasma I presume) How should it be done? What should the accompanying GUI look like? Etc.

My personal preference is for each activity to have configurable wallpapers for each virtual desktops. Associating activities with virtual desktops sounds too techie and too counter-intuitive for me.

Regards,

-- Shlomi Fish
Comment 28 Diego 2009-04-01 09:54:52 UTC
Stephan Binner seems to know about a fix for this issue, but he doesn't mention where's the patch:
http://www.kdedevelopers.org/node/3926
Comment 29 Bernd Paysan 2009-04-01 17:04:14 UTC
(In reply to comment #28)
> http://www.kdedevelopers.org/node/3926

LOL, great april hoax!
Comment 30 Stefan Endrullis 2009-04-01 17:14:58 UTC
But there's really a Live CD of Ubuntu Intrepid which brings back the old desktop functionality: http://apt.pearsoncomputing.net/
And THAT is not a hoax!
Comment 31 Scott 2009-04-10 01:44:42 UTC
It looks like this will be in kde 4.3
http://www.notmart.org/index.php/Software/Dashboards,_activities_and_deskt
Comment 32 Bernd Paysan 2009-05-21 19:49:07 UTC
I'm using KDE 4.2.3 from OpenSuSE build service right now, and the multiple activities attached to virtual desktops there work quite well. This gives me basically what I want. After selecting the option in "Configure Plasma", it first created a lot of activities, which I had to remove afterwards. What I also find confusing is when I switch an activity in one desktop, it seems to affect activities in other desktops as well. I'd prefer the following: If you select that feature, assing each available activity to one desktop, and create new if there are not enough. But no more than there are virtual desktops.

So the requested feature is now there, just with a few rough edges.
Comment 33 markw 2009-05-26 02:37:58 UTC
(In reply to comment #11)
> @David: so different wallpapers is so critical to the user experience that we
> should keep it in place even if it comes at the cost of even more important
> changes not being possible? obviously not.

Of course, you don't actually argue for what these 'more important' changes are; if you did this, of course, there is the danger that users reply that your 'more important' functionality isn't more important to them.

> ...with reaching REAL user needs. and no, setting a wallpaper per desktop is not a
> critical user need.

Well it is for me, for similar reasons to other people in this thread. You seem content to tell users what they need, so maybe you want to tell me what is wrong with my workflow.

> 
> *sigh*

You can say that again.
Comment 34 list 2009-05-26 23:37:06 UTC
It's not a critical need, it's important need.

All the arguments have been told already - users want it, concurrent DEs have it, the current approach with activities+desktops doesn't solve it (at least not for me and most users in this discussion).

Simply telling that users don't need it to users who are telling you they need it won't change your users' mind :)
Comment 35 Aaron J. Seigo 2009-05-27 00:16:02 UTC
@Shlomi Fish: there are two places this could go. one would be in the Image wallpaper in kdebase/workspace/plasma/wallpapers/image and the other would be in Containment/Wallpaper itself in libplasma.

Containment knows which desktop it is associated with, if any, but that really doesn't say anything about what the current desktop is. this also isn't really broadly applicable to every kind of wallpaper: weather is the same regardless of desktop, the mandelbrot is the mandelbrot regardless of desktop, etc.

if it was in Containment you could pick different wallpaper plugins per desktop ..... but i think that's just going to lead to an awful mess in the code.

there's also the issue of the configuration UI, which lives in plasma-desktop (workspace/plasma/shells/desktop) ... another mess would result there i think.

so the best place for this i think is the Image plugin itself. KWindowSystem can tell it when the desktop changes and it can provide per-desktop settings in its own configuration details.

plasma-devel at kde.org or #plasma on irc.freenode.net for questions, reviewboard.kde.org for patch review.
Comment 36 FiNeX 2009-08-21 01:18:32 UTC
@Aaron + @Shlomi Fish:
I've a question. Adding this feature to the image plugin could be in conflict with the current implementation of the desktop containment. Should the "different activities for each virtual desktop" be disabled when different wallpapers are on each virtual desktop in the same containment (and vice-versa)?
Comment 37 Janet 2009-08-22 16:48:09 UTC
My thoughts on it: I understand the activities as transparent layers above the desktops. The activities hold the widgets, but the desktops are the base, the background. A desktop per definition is something solid and the background where you put things onto. Something that's just an overlay (activity) like a table cloth shouldn't contain something that's meant to be a part of the underlying base by definition (background! picture). It just should cover it (partially and if wanted).

What I expect is to have different wallpapers for the desktops defined in the desktop plus transparent activities with different widgets. I don't want different widgets for every desktop but that happens when I bind the activities to the desktops because I want the different wallpapers. Yes, I really want both, independent from each other: different wallpapers for the desktops and different acitivities independent from the desktops (which show the wallpaper of the desktop, maybe together with an additional activity wallpaper overlay).

When the activity-overlays were transparent without the *need* to have a wallpaper and when at the same time the desktops would contain the wallpapers it also maybe would be possible to have overlay wallpapers. The background wallpaper from the desktop plus another smaller picture (belonging to the acitivity-overlay) with alphatransparency above it. So I could have a fullscreen wallpaper for my desktop and for some activities extra pictures. That really would be cool. That would be what I expect of activities: being overlays, layers which let the desktop shine through.

By now it seems to be vice-versa: you have the activity with the background and the widgets and put the desktop with the application windows as overlay on top of it.

Or there could be a third layer just for the background picture(s). And it should be visible unless the activities don't have fullscreen non-transparent own pictures defined. If they have, that should overlay the background picture, partially or full, depending on the picture and the settings.
Comment 38 FiNeX 2009-08-22 17:15:41 UTC
I want to add a small thought.

The meaning of activities (in my mind) is like having more desks. On my studio I've a table with the PC, another one with some books and a third one where I write. I change the activity (use PC, write or read) and I change the table and the tablecloth of each table is different from the others (like different wallpapers for different activities). On one desk I've a calendar and a clock (like the plasmoids), on another desk I've some newspapers (like the RSS).

Now if I want to change the tablecloth... http://www.youtube.com/watch?v=l_jzFHj0MhA

I like how plasma has been implemented because it is like my room :-)
Comment 39 Marco Lambertz 2009-08-28 11:21:10 UTC
Should be marked as FIXED as it possible sine 4.3.
Comment 40 Maciej Warnecki 2009-08-28 11:28:07 UTC
@Marco, AFAIK, it is only available in different "plasma workspaces" - so I need to click the Cashew, select "Zoom out", select different plasma workspace, click Zoom In - I know about that, but I want to make it possible with virtual desktops inside ONE plasma workspace - that's how Compiz worked, and I'm not interested in having few icon layouts and different plasmoid sets - I just want to have 4 virtual desktops each with different wallpaper. The way I see it, it hasn't been done yet. At least not in 4.3.
Comment 41 Andrey 2009-08-28 21:53:13 UTC
I think Maciej Warnecki is right.

You see, there are two features:

1) Different _activities_ on each virtual desktop.(This feature is implemented and it seems to work.)

2) Different _wallpapers_ on each virtual desktop. (This feature is Not implemented, hence this bug report.)

I will try to explain...

1) I have very well thought-out and very convenient widget layout, which is active on all 4 virtual desktops I use. Everything is almost perfect. Except wallpapers, which are the same on all screens.

2) So I set different activities per each desktop to get different wallpapers. But my *perfect* widget layout remains only on one virtual desktop (random or first one, I don't know). But I want to have my perfect widget layout on all screens! So I actually don't want to have different activities per virtual desktop, just different wallpapers. 

Of course I can try to somehow readjust another 3 desktops to be like the first 'perfect' one. But what if I have 8 virtual desktops (yes, I do actually have them)? Should I adjust it 7 times? Should I somehow edit plasma configuration file and make 7 clones of first activity? 

But in the beginning I just wanted different wallpapers, nothing else and nothing more.
Comment 42 Charles T Bell 2009-10-25 00:38:47 UTC
This can also be used to automatically identify which desktop is in use at any give time without having to look at the panel.
Comment 43 maciek gajewski 2009-11-01 09:12:34 UTC
I had a little nervous breakdown yesterday, when I installed new Kubuntu with kde 4.3, and discovered that I still can't have different wallpapers on my desktops. I was confident this was fixed in 4.3.
Comment 44 paul 2009-11-01 18:10:02 UTC
Will any future version of KDE 4 contain the ability to assign different wallpapers to separate desktops as was available in KDE 3.5?  This feature was for me one of the most valuable tools in KDE 3.5, so much so that I bought Hydravision, a multiple desktop/wallpaper add-in for my Windows XP box.
Comment 45 Bernd Paysan 2009-11-01 22:56:10 UTC
At least you can tie activities to virtual desktops - click on the cashew on the top right corner, select "Configure Plasma..." and set the top checkmark there.  The configuration is not all that robust, but once you have one for your favorite number of virtual desktops, just keep it.

Don't ever click on the second checkmark there, but this is worth another bug report...
Comment 46 claydoh 2009-11-02 00:24:55 UTC
It also drags performance down on older systems such as mine with only 32mb vram. So unfortunately that is not a viable option at the time.
Comment 47 Christoph Feck 2009-12-18 18:11:49 UTC
*** Bug 219127 has been marked as a duplicate of this bug. ***
Comment 48 abrahams 2009-12-27 19:42:52 UTC
I too am one of those who relied heavily on differently-colored desktops in KDE 3.5 and switched only reluctantly to KDE 4.0 because of the lack of it.  Frankly, I don't understand "activities", perhaps because I haven't found a good explanation of them yet.  In addition, when trying to follow some of the advice I got about getting the different colors, my laptop (an Acer Aspire 3100, not a very old machine) just hung, probably because the computational load of all the new machinery was just too much for it.  That's not a problem I had in KDE 3.5.

A very basic usability principle is that simple essential things should be easy to do.  At a *minimum*, there should be an explanation of how a newcomer to KDE4 can get the desired effect without having to deal right off with all the new generality.  I don't want to be told how to do twelve other marvelous things, or at least not yet; I want to be told how to do what I want to do.
Comment 49 Maciej Warnecki 2010-01-02 20:51:44 UTC
Well, After trying this:

https://bugs.kde.org/show_bug.cgi?id=155150#c45

I got exactly what I wanted (different wallpapers on virtual desktops, no activities at all)

Other side effect (or feature, depends on how you look at it ;)) is that the plasmoid placement is independent on each of the virtual desktops, meaning I can have analog clock on dekstops 1 and 3, daisy plasmoid 2 and 4, and so on...
Comment 50 ancow 2010-01-02 21:16:23 UTC
Actually, you have one activity per desktop, which means that you need to configure your plasmoids for every single desktop, making this option *really* unattractive for some of us... (If anything, I would want to be able to freely configure which activity is tied to which desktop. That would actually be a nice feature...)
Comment 51 Maciej Warnecki 2010-01-03 10:10:33 UTC
What I did, was creating 4 different plasma activities, configure each one
with the same plasmoids and different wallpapers, and then bind each of them
to a different virtual desktop, as explained in Comment #45. Now, I'm not
using activities at all. But if I were to go into the plasma acitivities
chooser screen, I'd see 4 different plasma activities with the same contents
as every of my virtual desktops. (so plasma activity 1 looks like virtual
desktop 1, 2 like 2 and so on...)
Worth a try!
Comment 52 ancow 2010-01-03 10:42:24 UTC
(In reply to comment #51)
> What I did, was creating 4 different plasma activities, configure each one
> with the same plasmoids and different wallpapers, and then bind each of them
> to a different virtual desktop, as explained in Comment #45.

In other words, you're using one activity per desktop...

> Now, I'm not
> using activities at all.

This statement conflicts with your first sentence. You're either using one activity per desktop or not using them at all.

> But if I were to go into the plasma acitivities
> chooser screen, I'd see 4 different plasma activities with the same contents
> as every of my virtual desktops. (so plasma activity 1 looks like virtual
> desktop 1, 2 like 2 and so on...)
> Worth a try!

I'm definitely not configuring 7 acitvities, especially since there is no way to copy an activity. In other words, this workaround sucks (especially since I actually use activities the way they are supposed to be used.)

It's obviously nice for you that this workaround works for you and that you don't mind having to manually replicate all changes across all desktops, but for the rest of us, this bug is as annoying as ever.
Comment 53 FiNeX 2010-01-03 13:14:59 UTC
How does this workaround affects performance?

Actually I'm using a dual monitor setup (with nvidia twinview) and I'm using six (6) virtual desktops.

Setting "different activities for each desktop" would create twelve (12) activities, how much does it impact negatively on the global performance?
Comment 54 ancow 2010-01-03 13:28:08 UTC
(In reply to comment #53)
> How does this workaround affects performance?

Who said anything about performance? Where?
Comment 55 FiNeX 2010-01-03 13:54:20 UTC
> Who said anything about performance? Where?

I was just thinking about it :-)
Comment 56 ancow 2010-01-03 14:30:24 UTC
Well, I guess that would depend on whether all plasmoids are always active. If you have several activities, you could try comparing CPU and memory usage while only one activity is active and while several are (e.g. by using the zoom out feature). If there is a significant negative impact, the amount of activities is not likely to matter. If there is little or no change, the workaround will cost you.

OTOH, one of the previous comments mentioned that the workaround wasn't feasible on a low-spec machine, so I guess there is a significant impact... ;-)
Comment 57 Paul Arnote 2010-01-03 14:37:25 UTC
(In reply to comment #52)
> (In reply to comment #51)
> > What I did, was creating 4 different plasma activities, configure each one
> > with the same plasmoids and different wallpapers, and then bind each of them
> > to a different virtual desktop, as explained in Comment #45.
> 
> In other words, you're using one activity per desktop...
> 
> > Now, I'm not
> > using activities at all.
> 
> This statement conflicts with your first sentence. You're either using one
> activity per desktop or not using them at all.
> 
> > But if I were to go into the plasma acitivities
> > chooser screen, I'd see 4 different plasma activities with the same contents
> > as every of my virtual desktops. (so plasma activity 1 looks like virtual
> > desktop 1, 2 like 2 and so on...)
> > Worth a try!
> 
> I'm definitely not configuring 7 acitvities, especially since there is no way
> to copy an activity. In other words, this workaround sucks (especially since I
> actually use activities the way they are supposed to be used.)
> 
> It's obviously nice for you that this workaround works for you and that you
> don't mind having to manually replicate all changes across all desktops, but
> for the rest of us, this bug is as annoying as ever.

I also wonder about this. There shouldn't be a "workaround," but rather a CHOICE on what to include in an activity.

I also wonder about the performance and memory "hit" it takes to replicate plasmoids separately across all desktops. As it's currently set up, to have a different wallpaper on every desktop, you must set up separate activities for all desktops. As a result, every desktop is independent of the other, to the point that plasmoids displayed on one desktop "activity" are not displayed on other desktops.

Say I have six virtual desktops, each defined as their own activity, just for the sake of having a different wallpaper on each of those six desktops. Now also say I like having the YAWP or CWP weather plasmoids on my desktop, along with a performance monitor and the trash plasmoid. With the activities/desktops completely independent of one another, I will have to run those three plasmoids on EACH and EVERY desktop, or do without them. Now, why should I have to run the trash, weather, or performance plasmoids SIX separate times, just to have a different wallpaper on each of those six virtual desktops, with all the plasmoids I routinely use?? Not only does it seem costly (in performance and memory usage), but it also seems like it would/will be a configuration nightmare. Rather, wouldn't it make more sense to simply give users the ability to separate wallpaper from the "activity" and to choose whether to have the same wallpaper or different wallpapers across their virtual desktops (much as we had in KDE 3.5.10)?

I like the idea of the "activity," but give individual users the ability to decide what is included in that "activity," as well as what is excluded from an activity. This will allow the maximum choices for the maximum number of users, and foster creativity on how to put "activities" to use ... rather than boxing every user into what one or two people decide that an activity is.
Comment 58 Etienne Hilson 2010-01-03 14:53:31 UTC
This is a good point for me, indeed.
Whatever you name it (virtual desktop, activity, ...), you should just mix them, and permit the user to choose for each part of the "desktop/screen/plasma/..." if it is common for all or linked to each one.

You should be able to choose for each part
- wallpaper
- screen saver
- widgets
- panels
- windows of the apps
- whatever appear in your workspace
if you want each one to be common to each "screen" or if each screen own its own.

For my side, I don't see the logic when somebody tells me that I have to change virtual desktop to change windows, and activity to change wallpaper... O_o
Comment 59 Felix Miata 2010-01-11 00:13:30 UTC
Until I can lock a different wallpaper quickly and intuitively to each desktop, which like in Windows is a piece of cake in 3.5, I won't be leaving 3.5.
Comment 60 claydoh 2010-01-11 00:27:35 UTC
On my hardware, using different containments is not an option as it seriously slows everything down - older Compaq laptop w/ 2.0 p4 and ati 32mb graphics. Most anything else in KDE 4 works very well.
Comment 61 Maciej Warnecki 2010-02-26 21:50:51 UTC
I'm not able to find any way to enable the checkbox mentioned in #45 in KDE 4.4.

I still have 4 activities bound to virtual dekstops, but only because I upgraded from KDE 4.3. So if any new distro gets released with 4.4 by default, one wouldn't be propably able to set independent wallpapers. 

But since it still works, there must be some configuration file magic for it. Just where to look at....?
Comment 62 Andrey 2010-02-27 00:44:24 UTC
To: Maciej Warnecki.

Not sure what 'configuration file magic' means, but I have found that all plasma desktop and panels/widgets settings reside in these 3 files:

~/.kde4/share/config/plasma-desktop-appletsrc
~/.kde4/share/config/plasma-desktoprc
~/.kde4/share/config/plasmarc

At least in openSUSE it works this way: you can delete/move these files, default will be autogenerated. Then you can delete default and move your custom configured back. You can even swap between different layouts if you make a proper (shell) script for that.

Just don't forget to
killall plasma-desktop 
(before moving/replacing/editing your files)
and
plasma-desktop
(after you have finished configuring)

Setting different wallpapers-activities (with dual monitors) is described somewhat more accurately in this thread. It was tested in openSUSE, but I doubt that it is distribution-specific. Begin with the message number 22:
http://forums.opensuse.org/applications/425883-11-2-dual-monitors.html#post2075712

As you can guess, editing these files is A LOT OF FUN, because there is no documentation (or is there?), and these files are not meant to be edited by hand (or are they?). Though, due to lack of proper of proper GUI for editing them, if you want to get (almost) full control of Plasma, you will have to do it. (If I did not find that that trick I would be probably still using KDE 3.5.) 

Or you can just let Plasma randomly move your panels, create new 'activities'. It knows what you want better than you, anyway. Right?

I hope in the future situation will change and user friendly GUI with rich functionality, which will *even* let you set different wallpapers on your desktops, will be eventually designed.
Comment 63 Maciej Warnecki 2010-02-27 09:28:58 UTC
I fully agree with #62, but it is still something for future KDE relesaes.

What I have been told on KDE forums, is that the option to bind activities to virtual desktops is now much better positioned:

http://userbase.kde.org/images.userbase/e/e5/Plasma_howto-activity-link-44.gif
Comment 64 Etienne Hilson 2010-02-27 10:38:56 UTC
Fully agree with #62 too ! Good way to explain what I feel.
Anyway, when I see the difference of gui "ease of use" for the end user (and not for a developer) from 4.4 to 4.5, I am VERY confident about the way they are making kde better and user-friendly.

So, a big thank you to the devs, because lot of people will feel more confident in their preferred desktop environment.

4.5 is now the version where, if I had the choice, I would choose kde4 and not anymore kde3.5.

What a pity they removed the "multi-keys shortcuts", but this is another thread and I guess they will gring that feature back because it was very nice.
Comment 65 Kenny Kruger 2010-05-11 16:04:05 UTC
I believe this issue may now be resolved in KDE 4.4.2.

System Settings / Desktop
 Desktop: Multiple Desktops / Desktops
  Desktops: [X] Different activity for each desktop

Each activity allows for unique settings; including widgets, wallpapers, and other settings such as a Desktop or Folder View.

Once this is complete one must simply click on the Plasma Peanut (default on the right side of the screen), select 'Desktop Activity Settings', and alter your Wallpaper settings. Do this for each Desktop and/or Activity on each Desktop.
Comment 66 ancow 2010-05-11 16:17:57 UTC
(In reply to comment #65)
> I believe this issue may now be resolved in KDE 4.4.2.
> 
> System Settings / Desktop
>  Desktop: Multiple Desktops / Desktops
>   Desktops: [X] Different activity for each desktop

This "feature" has been present for quite a while now and is not a viable alternative to the individual wallpapers feature. See the rest of the discussion for why and even for a suggested fix (three layers instead of the two there are now).
Comment 67 Kenny Kruger 2010-05-11 17:28:23 UTC
Reading comment #41 I understand why using activities to provide different wallpapers then creates an issue that the user wishes the widget set is the same for each activity and thus not really 'needing' the different activities.

Using activities to gain unique wallpapers also requires additional resources of which may seem a bit much for such a simple thing as different wallpapers.

I am starting to see the problem.

I actually do use different activities for each v-desktop just to gain the different wallpapers on each v-desktop, but had not considered the additional resources used for that as my machine handles it -- makes me wonder how much better it may perform.

I don't know enough about KDE4 to give any real helpful solution as to the implementation of this. I do however enjoy different wallpapers per desktop and understand the desire, not need, for that -- and to be able to accomplish it at the cheapest cost to the system.
Comment 68 Jakob Lehmann 2010-05-23 00:53:39 UTC
*** Bug 218453 has been marked as a duplicate of this bug. ***
Comment 69 FiNeX 2010-08-16 12:50:12 UTC
Probably a lot of users would like to have the same widgets on each virtual desktops but with different wallpaper. The current implementation (one containment for each virtual desktop) force to have different widget on the containments.
Comment 70 Casteyde.Christian 2010-08-17 07:41:59 UTC
I don't know if wallpaper is a special widget, but indeed comment #69 got it right. If widgets could have a 'sticky' option, as windows have ith kwin, one could place the wallpaper in a screen size background widget and make it sticky.
That could be cheaper than having activities, and keep the widgets in the activity layer.
Comment 71 FiNeX 2011-01-28 12:46:48 UTC
*** Bug 72836 has been marked as a duplicate of this bug. ***
Comment 72 andydecleyre 2015-02-25 17:54:19 UTC
So this bug report was opened seven years ago, but the status is still "confirmed." That actually seems appropriate because it does not seem possible to achieve this with current plasma, either with or without activities. Please correct me if I'm wrong. Is any developer interested in this issue?
Comment 73 Christoph Feck 2015-03-16 12:29:54 UTC
> a suggested fix (three layers instead of the two there are now).

Making the wallpaper a separate window (as it was in KDE 3) would mean that all plasmoids would also need to be separate windows. Plasma simply does not work this way. The complete shell is a single window. Changing it basically means rewriting Plasma again. So yes, no developer is interested.
Comment 74 andydecleyre 2015-04-14 16:31:09 UTC
Can someone with permissions update the product for this bug from plasma4 to plasma5?
Comment 75 Turbo 2015-04-20 20:56:42 UTC
Hi all.

Very sad news as april 2015. They decided to remove the wallpaper on every desktop feature in Plasma 5 after so many years  :-( :-(.

https://bugs.kde.org/show_bug.cgi?id=341143
Comment 76 loop.rw 2015-08-09 10:28:08 UTC
Can we please all converge all to one thread, either #343246 or #341143  (but change the title to include the widgets).

I link other threads talking about this:
https://bugs.kde.org/show_bug.cgi?id=348493
https://bugs.kde.org/show_bug.cgi?id=349486
https://bugs.kde.org/show_bug.cgi?id=341143
https://bugs.kde.org/show_bug.cgi?id=343246
Comment 77 Marco Martin 2015-11-19 16:05:34 UTC
closed as is from plasma4 that had the feature
Comment 78 Bernd Paysan 2015-11-19 21:06:51 UTC
This feature was in KDE3, and not in early Plasma 4. It was added, as Plasma 4 got more mature (after we filed a bug report - this one), now in Plasma 5 it is dropped again.

Please use this bug tracker as regression, don't just close bugs because you repeatedly drop features each time.

This is a regression from Plasma4, keep it open until this feature is here again.
Comment 79 Andriy Gapon 2015-11-19 22:49:26 UTC
Yeah, and it was also inappropriate to mark this bug as resolved/fixed when the issue has clearly not been fixed. At best it's been "overcome by events" or some such. And I agree with the previous comment that the feature was useful and shouldn't have been dropped.
Comment 80 Ivan Čukić 2015-11-19 22:57:04 UTC
@Bernd and Andriy

This report is about Plasma 4, as can be seen on the top of the page under 'product: plasma4'. So, it *is* resolved-fixed.

If you want the Plasma 5 version of the bug, go to https://bugs.kde.org/show_bug.cgi?id=341143