Bug 150790 - IMAP resources not working
Summary: IMAP resources not working
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR major with 106 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 106647 149823 151831 154802 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-10-13 17:24 UTC by Stéphane Magnenat
Modified: 2008-07-24 17:06 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stéphane Magnenat 2007-10-13 17:24:20 UTC
Version:           3.5.6 (enterprise 0.20070907.709405) (using KDE 3.5.8, Kubuntu (gutsy) 4:3.5.8-0ubuntu1)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.22-14-rt

I just upgraded to Kubuntu Guisty RC, which lead Kontact suit to upgrade to Enterprise edition.
Now the IMAP resources (calendar, contacts, ...) do not work any more: Even if IMAP resources are enabled and "hiding resource folder" is checked, folders are still visible and IMAP resources are not used in Kontact.

Thanks,
Comment 1 Stéphane Magnenat 2007-10-14 10:23:14 UTC
This bug is the same as reported in Ubuntu bug tracker as 139433: https://bugs.launchpad.net/ubuntu/+source/kdepim/+bug/139433

The proposed manual fix, adding missing TheIMAPResourceAccount=<ID> pointing to the same ID as TheIMAPResourceFolderParent works:
[IMAP Resource]
 TheIMAPResourceAccount=<ID>
 TheIMAPResourceEnabled=true
 TheIMAPResourceFolderParent=<ID>

The IMAP config dialog does not update TheIMAPResourceAccount, even if it does update TheIMAPResourceFolderParent.
Comment 2 Elan Ruusamäe 2007-10-19 19:25:50 UTC
i can confirm this, and workaround is to add manually TheIMAPResourceAccount option to [IMAP Resource] section
Comment 3 Reinhold Kainhofer 2007-10-19 19:50:28 UTC
I was also just bitten by this bug!
Workaround: Either the manual fix inthe config file or the following:
After changing the groupware format to Kolab XML in the config dialog (on a dummy account, where I can remove the created folders again later), clicking "Apply" and then switching back to the original groupware format ical, kmail uses the normal groupware folders again.

Cheers,
Reinhold
Comment 4 Oluf Lorenzen 2007-10-22 19:16:34 UTC
> i can confirm this, and workaround is to add manually TheIMAPResourceAccount option to [IMAP Resource] section
same here
Comment 5 Volker Krause 2007-12-04 06:11:33 UTC
*** Bug 151831 has been marked as a duplicate of this bug. ***
Comment 6 Volker Krause 2007-12-04 07:22:36 UTC
I suspect revision 709134 to cause this problem. Can anyone test without it?
Tobias: This was a commit by you which fixes some crash, can you please have a look? For groupware format ical/vcard, the TheIMAPResourceAccount value is supposed to be 0.
Comment 7 Alexander Dorfmeister 2007-12-11 10:20:56 UTC
i can confirm the bug and the workarround on FC6 update last night to
Kontact Version 1.2.5
KMail Version 1.9.7
Comment 8 Charles Samuels 2008-01-08 23:20:18 UTC
*** Bug 106647 has been marked as a duplicate of this bug. ***
Comment 9 Julian Mehnle 2008-01-09 00:07:50 UTC
WTF?  Why mark bug 106647, which is much older and has a lot more votes, as a duplicate of this bug rather than the other way round?  Not a nice gesture for sure.
Comment 10 Charles Samuels 2008-01-09 00:16:37 UTC
Because I made a mistake, and also I expected bugzilla to merge the votes. Sorry.

Charles
Comment 11 Julian Mehnle 2008-01-09 00:17:30 UTC
Here's a more constructive comment:  Now that someone seems to be taking care of this neglected issue, this very bug report could be marked as a duplicate of bug 101482.

Also check out bug 107587 and bug 107894, which may be related.
Comment 12 Charles Samuels 2008-01-09 02:34:18 UTC
Julian, I'm sorry to say that I'm not "taking care" of this issue. I'm no kontact developer... I'm hoping this flurry of communication on it will remind the kontact developers to look at this, though.
Comment 13 Julian Mehnle 2008-01-09 04:19:56 UTC
Charles, bug 101482, which I was referring to, is a "kmail" bug, not a "kontact" one.  I'm not expecting _you_ to take care about it.  Just "someone". ;-)
Comment 14 michael 2008-01-23 15:21:28 UTC
Hi!

Unfortunately the manual fix does not work in my case. The problems was introduced in the last version of the opensuse-pim-packages:

 3.5.7.enterprise.0.20071221.751182-38.2

Allo contacts and calendar entry can be accessed within kmail but are not visible in contacts or korganizer.  

Best regards,

 Michael
Comment 15 Thomas McGuire 2008-01-27 01:40:46 UTC
*** Bug 149823 has been marked as a duplicate of this bug. ***
Comment 16 Massimo Burcheri 2008-02-04 23:00:20 UTC
I can confirm switching groupware format to Kolab XML and back is a quick work-around. That will create some subfolders in INBOX which can be deleted afterwards. imap resource functionality is restored after that switch. You can activate former resources by changing folder properties back to "contacts" "journal" etc. 
I hope this bug is fixed soon.
Comment 17 michael 2008-02-05 17:39:46 UTC
Hi, I can confirm this, switching to Kolab and back does work.

Michael
Comment 18 Thomas McGuire 2008-02-10 19:25:17 UTC
*** Bug 154802 has been marked as a duplicate of this bug. ***
Comment 19 uli9999 2008-02-20 13:46:32 UTC
In 3.5.9, the problem still exists, but switching to Kolab leads to a crash of Kontact.
Comment 20 Thomas Trepl 2008-02-20 17:07:44 UTC
Too bad. Hopefully the workaround we work here.
Comment 21 Thomas McGuire 2008-02-27 22:14:11 UTC
Seems that there are two different issues here: The problem which can be solved with changing TheIMAPResource in the config and some other problem.

See also bug 158448.
Comment 22 Roberto 2008-03-05 14:11:00 UTC
Constantly crashes when enabling imap groupware after upgrading from 3.5.8 to 3.5.9 on debian sid. Here's the back trace:

(no debugging symbols found)
Using host libthread_db library "/lib/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
...#a lot of these...
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb5fc66c0 (LWP 5989)]
[New Thread 0xb3533b90 (LWP 5993)]
[New Thread 0xb3d34b90 (LWP 5992)]
[New Thread 0xb4535b90 (LWP 5991)]
[New Thread 0xb4d36b90 (LWP 5990)]
(no debugging symbols found)
...#a lot of these...
(no debugging symbols found)
[KCrash handler]
#6  0xb5284939 in KMailICalIfaceImpl::readConfig ()
   from /usr/lib/libkmailprivate.so
#7  0xb528a782 in KMailICalIfaceImpl::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#8  0xb7009f71 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#9  0xb700ab8d in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#10 0xb51b5169 in KMKernel::configChanged () from /usr/lib/libkmailprivate.so
#11 0xb51b538a in KMKernel::slotConfigChanged ()
   from /usr/lib/libkmailprivate.so
#12 0xb51b9e9c in KMKernel::qt_invoke () from /usr/lib/libkmailprivate.so
#13 0xb700a00d in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#14 0xb700ab8d in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#15 0xb7d5e819 in KCMultiDialog::configCommitted ()
   from /usr/lib/libkutils.so.1
#16 0xb7d7ae43 in KCMultiDialog::apply () from /usr/lib/libkutils.so.1
#17 0xb7d7aecb in KCMultiDialog::slotOk () from /usr/lib/libkutils.so.1
#18 0xb501b1df in ConfigureDialog::slotOk () from /usr/lib/libkmailprivate.so
#19 0xb69561cb in KDialogBase::qt_invoke () from /usr/lib/libkdeui.so.4
#20 0xb7d7a112 in KCMultiDialog::qt_invoke () from /usr/lib/libkutils.so.1
#21 0xb501962b in ConfigureDialog::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#22 0xb700a00d in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#23 0xb700ab8d in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#24 0xb733ba7c in QButton::clicked () from /usr/lib/libqt-mt.so.3
#25 0xb709b27d in QButton::mouseReleaseEvent () from /usr/lib/libqt-mt.so.3
#26 0xb70425f4 in QWidget::event () from /usr/lib/libqt-mt.so.3
#27 0xb6fac1ca in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#28 0xb6fad0fa in QApplication::notify () from /usr/lib/libqt-mt.so.3
#29 0xb765dec2 in KApplication::notify () from /usr/lib/libkdecore.so.4
#30 0xb6f4ba92 in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#31 0xb6f4ab3d in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#32 0xb6f5b026 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#33 0xb6fc2bc0 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#34 0xb6fc2a56 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#35 0xb6fabd3f in QApplication::exec () from /usr/lib/libqt-mt.so.3
#36 0x0805be82 in ?? ()
#37 0xbfc74818 in ?? ()
#38 0x00000001 in ?? ()
#39 0x00000001 in ?? ()
#40 0x00000000 in ?? ()
Comment 23 Roberto 2008-03-05 14:19:27 UTC
By removing the [IMAP Resource] and [Groupware] parts in kmailrc it doesn't crashes anymore on enabling. But still doesn't work; the folders for resources are not created when missing.
Comment 24 Will Stephenson 2008-07-18 23:05:56 UTC
Isn't this priority #1 for KDAB?
Comment 25 Roberto 2008-07-20 09:58:25 UTC
Maybe most of the developers are now focused on kde4.1
I think this bug will never be corrected.
Comment 26 Till Adam 2008-07-20 13:52:11 UTC
I'll have a look next week.
Comment 27 Daniel Espinoza 2008-07-21 19:41:40 UTC
does anyone know if this was corrected in KDE 4.xx ?
Comment 28 Will Stephenson 2008-07-22 20:38:52 UTC
http://bugs.kde.org/show_bug.cgi?id=165841 is the KDE 4.1 beta bug report
Comment 29 Will Stephenson 2008-07-24 17:06:52 UTC
SVN commit 837390 by wstephens:

Write the id of the account used for the imap groupware resources; this
was apparently removed by accident during a proko2 merge back in
r346441 . The xml format still worked so the bug was not visible to
KDAB.  Fixed by integrating part of the old code that that commit
removed to identify the account from the folder.

(Backported to KDE 3 version of r837366)

BUG:150790


 M  +18 -0     configuredialog.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=837390