Bug 106647 - IMAP resource doesn't work anymore
Summary: IMAP resource doesn't work anymore
Status: RESOLVED DUPLICATE of bug 150790
Alias: None
Product: korganizer
Classification: Unclassified
Component: general (show other bugs)
Version: 3.5
Platform: unspecified Linux
: NOR normal with 65 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-02 01:22 UTC by kdebugs
Modified: 2008-01-08 23:20 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kdebugs 2005-06-02 01:22:08 UTC
Version:           3.4 (using KDE 3.4.1%2C%2520Debian%2520Package%25204%253A3.4.1-1%2520%283.1%29)
Compiler:          gcc%2520version%25203.3.6%2520%28Debian%25201%253A3.3.6-5%29
OS:                Linux%2520%28i686%29%2520release%25202.6.9-1-686

I just upgraded to a debian's 3.4 and I can't access my calendar and todo's stored on my IMAP server.. The events are visible in kmail and it shows the correct icons next to the folder names, but korganizer doesn't show any entries and I get an error if I try to add a new one (Unable to save Event "aaa").
Comment 1 Bo O. Erichsen 2005-07-04 12:10:04 UTC
I've got this problem too.. 
There's a bug report on it here:
http://bugzilla.ubuntu.com/show_bug.cgi?id=7971

so is it generally a problem on debian only?

Comment 2 Julian Mehnle 2005-11-02 18:52:16 UTC
I am experiencing the same problem after upgrading from KDE 3.3 to 3.4.2 (on Debian).  Possibly related bugs: #107587, #107894.
Comment 3 gp 2006-05-06 12:19:48 UTC
My KOrganizer doesn't work with the imap ressource, if it is served on another computer. It works well, if the imap ressource is local. (KOrganizer 3.5; KDE 3.5.2 with debian testing).
Comment 4 gp 2006-05-06 12:21:02 UTC
*** This bug has been confirmed by popular vote. ***
Comment 5 gp 2006-05-08 16:10:35 UTC
The bug disappears, when you use your mailbox in cached imap mode.
Comment 6 Julian Mehnle 2006-05-08 17:22:38 UTC
gp@praetor.de, that's known, however this bug is not about cached IMAP but about regular IMAP.  There are cases when the use of cached IMAP isn't appropriate.
Comment 7 Reinhold Kainhofer 2006-05-08 17:50:21 UTC
Am Montag, 8. Mai 2006 17:22 schrieb Julian Mehnle:
> ------- gp praetor de, that's known, however this bug is not about cached
> IMAP but about regular IMAP.  There are cases when the use of cached IMAP
> isn't appropriate.


The imap resource is not designed to be used with online IMAP, only with 
cached IMAP. The real bug is that it's possible to configure it to use online 
imap.

Cheers,
Reinhold
Comment 8 Julian Mehnle 2006-05-08 17:52:18 UTC
So it was an accident that it worked fine before KDE 3.4 or so?

Interesting approach to "define away" bugs, I must say.
Comment 9 Juha Tuomala 2006-10-18 22:20:11 UTC
This entry is somewhat related to bug #122116.
Comment 10 Reinhold Kainhofer 2006-11-02 18:50:45 UTC
Reassigning all KOrganizer bug reports and wishes to the newly created 
korganizer-devel mailing list.
Comment 11 krienke 2007-07-25 09:08:27 UTC
I am using KDE 3.5.7 and this bug is still there. I also use IMAP (not cached IMAP) and would like to save events in a IMAP folder. The strange thing is, that korganizer does actually store entries in kmails IMAP folder but it seems it cannot read or "understand" those entries. 

Changing to cached imap is not an option since cached imap is quite slow when looking for new mail (I have many folders). Is it really impossible to solve this bug?
Comment 12 Charles Samuels 2008-01-08 21:28:42 UTC
Happens on disconnected IMAP, too

https://bugs.launchpad.net/ubuntu/+source/kdepim/+bug/139433
https://bugs.launchpad.net/ubuntu/+source/kdepim/+bug/14309
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=448528

A workaround appears to be to edit your $KDEHOME/share/config/kmailrc and find something like this:

[IMAP Resource]
HideGroupwareFolders=false
TheIMAPResourceEnabled=true
TheIMAPResourceFolderParent=306242713

And to add the line:
TheIMAPResourceAccount=306242713

where that number is the same as the number on TheIMAPResourceFolderParent (excluding any other text on that line)
Comment 13 Charles Samuels 2008-01-08 23:20:15 UTC

*** This bug has been marked as a duplicate of 150790 ***