Bug 122096 - gets in endless loop if IMAP server does not support selected authentication method
Summary: gets in endless loop if IMAP server does not support selected authentication ...
Status: RESOLVED DUPLICATE of bug 109036
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.1
Platform: unspecified Linux
: NOR normal with 42 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 122149 122733 126676 127286 130052 133843 135507 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-02-16 12:04 UTC by Marc Haber
Modified: 2008-04-13 15:55 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Haber 2006-02-16 12:04:24 UTC
Version:           1.9.1 (using KDE 3.5.1, Debian Package 4:3.5.1-2 (testing/unstable))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.15.4-scyw00225

My Exchange Gurus have reconfigured their servers to require other authentication methods when connecting to it via IMAP. They cannot tell me which methods are supported now.

When I select an authentication method that is not supported, kmail quickly iterates between "The authentication method ... is not supported by the server" and the Authorization Dialog requesting user name and password. it seems impossible to get to a configuration dialog without killing off the Kmail process.

The persistence of Kmail trying to reauthenticate with a method that it knows about being unsupported is a major annoyance.
Comment 1 nemosoft 2006-02-17 18:45:46 UTC
I have the same problem, after I upgraded to KDE 3.5.1. In my case, the server didn't change but KMail doesn't support the same authentication protocol as before. Trying to kill KMail resulted in a zombie process (?!?) It's extremely annoying behaviour.

Eventually I had to remove the [Account ##] entries from the kmailrc file and add them again manually.
Comment 2 Thiago Macieira 2006-02-28 19:46:26 UTC
*** Bug 122733 has been marked as a duplicate of this bug. ***
Comment 3 Sebastian Held 2006-04-20 12:34:43 UTC
maybe related:
using imap, I get "TLS-Start fehlgeschlagen" (eventually because the account has not been setup correctly). Now Kmail asks again for username and password. Hitting OK or Cancel won't break out of this loop.
KDE/Kmail 3.5.2 gentoo build
Comment 4 Carsten Burghardt 2006-05-10 23:04:42 UTC
*** Bug 126676 has been marked as a duplicate of this bug. ***
Comment 5 Ismail Onur Filiz 2006-05-16 03:54:12 UTC
*** Bug 127286 has been marked as a duplicate of this bug. ***
Comment 6 Axel Braun 2006-05-30 20:30:34 UTC
same problem here on 3.5.2/SuSE build: cancelation of the login dialog does not break the loop. Impossible to work with Kmail!
Comment 7 Bram Schoenmakers 2006-09-16 16:52:27 UTC
A similar loop appears when the IMAP server is down.
Comment 8 Bram Schoenmakers 2006-09-16 16:54:55 UTC
*** Bug 122149 has been marked as a duplicate of this bug. ***
Comment 9 Bram Schoenmakers 2006-09-16 17:00:18 UTC
*** Bug 130052 has been marked as a duplicate of this bug. ***
Comment 10 Alexander Stein 2006-09-16 18:28:33 UTC
*** This bug has been confirmed by popular vote. ***
Comment 11 Guido Winkelmann 2006-09-22 18:54:24 UTC
The same problem happens when the authentication method and protocol and everything is supported but the server simply rejects your username-password combination.

I must agree that this is a major annoyance.
Comment 12 Bram Schoenmakers 2006-10-06 18:12:37 UTC
*** Bug 133843 has been marked as a duplicate of this bug. ***
Comment 13 richlv 2006-10-11 12:05:57 UTC
oh damn. turns out, this is a long standing problem...
kmail tries to authenticate upon startup for me, so i can not even get to the configuration.

so, here's a workaround (in 3.5.4) :
open kontact, not kmail. cancel login dialog once, open settings. now, reconfigure your account details (kmail does not allow accessing settings while the dialog window is open).
Comment 14 Bram Schoenmakers 2006-10-12 19:02:45 UTC
*** Bug 135507 has been marked as a duplicate of this bug. ***
Comment 15 min 2006-10-31 02:41:39 UTC
This bug report is the same as http://bugs.kde.org/show_bug.cgi?id=109036. 
 
It's just that this one is about wrong authentication method, and that one is about wrong password. But the problem as such is the same, "Cancel" doesn't cancel. 

109036 might be considered a duplicate.

Additionally, this is a regression of http://bugs.kde.org/show_bug.cgi?id=93199.
Comment 16 Bram Schoenmakers 2006-10-31 09:10:37 UTC

*** This bug has been marked as a duplicate of 109036 ***
Comment 17 Ute Hauth 2007-04-23 00:33:59 UTC
Same loop here kmail 1.9.6, kde 3.5.6 gentoo. Workaround from comment 13 helped me out.
Comment 18 Dark Daskin 2007-06-04 07:10:18 UTC
I have kdepim-3.5.6-4.fc7 and similar bug exists in my KMail. When configuring IMAP mailbox on first start through wizard, by default program selected PLAIN authentication method, and on finish i have this endless loop because this method is unsupported by server.
Comment 19 Frank Reininghaus 2008-04-03 00:08:13 UTC
I might have had this problem today [KMail/1.9.6 (enterprise 0.20070907.709405), Kubuntu 7.10].

When starting either Kontact or KMail, there was an error message about my Google Mail account which I access with IMAP:

Authorization failed, Unable to login. Probably the password is wrong.
The server imap.googlemail.com replied:
System Error (Failure) authentication not supported

Clicking OK (the only option in this box) brought up a dialog asking for username and password. I then entered my password (I'm pretty sure it was correct) and clicked OK, but this only made the "Authorization failed" box appear again. I repeated this a few times without success and finally decided to click "Cancel". This caused KMail/Kontact to hang and use 100% of the CPU (reproducibly), so I had to kill it manually. I managed to get a few backtraces by sending the process the SIGSEV signal, I could attach one if anyone thinks it's useful.

After some time, the problem disappeared. I guess it was a temporary problem with the mail server, but I think KMail should give the user some way to get out of this "Authorization failed" thing (e.g., if he wants to check some other mail accounts that still work).

If this bug is the same thing that I experienced, it is not a duplicate of bug 109036 (in this bug, the dialog box pops up over and over again, but KMail does not hang).
Comment 20 Frank Reininghaus 2008-04-13 15:55:02 UTC
Concerning my comment #19:

I found a way to reproduce this (KMail/Kontact hangs using 100% CPU) even if the IMAP server works all right, but only with the version KMail/1.9.6 (enterprise 0.20070907.709405) that comes with Kubuntu 7.10. The current SVN version (revision 796375) seems to work OK.

Steps to reproduce:

1. Open KMail settings and change the password of a receiving IMAP account (Google Mail in my case) to something wrong. Close the settings dialog. KMail then tries to check mail using the wrong password, opens an Error dialog (click OK) and an Authorization dialog (click Cancel). Close Kontact.

2. Open Kontact. You get an error message about the failed Authorization. Click OK and then Cancel in the Authorization Dialog.

3. Kontact hangs and has to be killed manually.

But as I said, the current SVN version works OK. When I open Kontact and click Cancel in the Authorization dialog prompting me for the correct password, I get the same dialog once more, but clicking Cancel again ends this, and I can use Kontact normally (except for the account with the wrong password).