Bug 116372 - IMAP crash - pure virtual method called
Summary: IMAP crash - pure virtual method called
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR grave with 227 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 132060 132740 135948 136337 138026 141541 141870 142574 142887 144965 146069 159867 161315 161852 162404 185700 231011 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-11-14 20:49 UTC by Tommi Rantala
Modified: 2014-08-25 21:09 UTC (History)
20 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tommi Rantala 2005-11-14 20:49:43 UTC
Version:           1.9 (branches/KDE/3.5/kdepim rev 480394) (using KDE KDE 3.5.0)
Installed from:    Compiled From Sources
Compiler:          gcc 4.0.3 20051006 (prerelease) 
OS:                Linux

Upgraded from KDE 3.4.3 -> 3.5 RC1.

Reproduction:

1. start kmail
2. open IMAP folder root level
3. enter password, kmail connects to server
4. go to INBOX
5. kmail disconnects?
6. some of the messages wont be displayed (because they are not cached?)
7. after clicking back and forth through a few of those messages, kmail crashes



Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 1115088480 (LWP 4167)]
[KCrash handler]
#7  0xffffe410 in ?? ()
#8  0xbfe8782c in ?? ()
#9  0x00000006 in ?? ()
#10 0x00001047 in ?? ()
#11 0x42441411 in raise () from /lib/tls/libc.so.6
#12 0x42442bfb in abort () from /lib/tls/libc.so.6
#13 0x423bbfa2 in __gnu_cxx::__verbose_terminate_handler () from /usr/lib/libstdc++.so.6
#14 0x423b9945 in __cxxabiv1::__terminate () from /usr/lib/libstdc++.so.6
#15 0x423b9982 in std::terminate () from /usr/lib/libstdc++.so.6
#16 0x423ba0a6 in __cxa_pure_virtual () from /usr/lib/libstdc++.so.6
#17 0x402f1581 in KMReaderWin::setMsg (this=0x83d6db8, aMsg=0x861a0d8, force=false) at kmreaderwin.cpp:1163
#18 0x404320d0 in KMMainWidget::slotMsgSelected (this=0x82be200, msg=0x861a0d8) at kmmainwidget.cpp:1869
#19 0x40441192 in KMMainWidget::qt_invoke (this=0x82be200, _id=54, _o=0xbfe87b18) at kmmainwidget.moc:472
#20 0x41d2acd9 in QObject::activate_signal () from /opt/qt/lib/libqt-mt.so.3
#21 0x4029d011 in KMHeaders::selected (this=0x83dad00, t0=0x861a0d8) at kmheaders.moc:250
#22 0x4029d2de in KMHeaders::highlightMessage (this=0x83dad00, lvi=0x8650bb8, markitread=false) at kmheaders.cpp:1995
#23 0x4029d65e in KMHeaders::highlightMessage (this=0x83dad00, i=0x8650bb8) at kmheaders.cpp:2244
#24 0x402aa463 in KMHeaders::qt_invoke (this=0x83dad00, _id=106, _o=0xbfe87c54) at kmheaders.moc:295
#25 0x41d2acd9 in QObject::activate_signal () from /opt/qt/lib/libqt-mt.so.3
#26 0x4207a445 in QListView::currentChanged () from /opt/qt/lib/libqt-mt.so.3
#27 0x41e0e0bd in QListView::setCurrentItem () from /opt/qt/lib/libqt-mt.so.3
#28 0x41e1247e in QListView::contentsMousePressEventEx () from /opt/qt/lib/libqt-mt.so.3
#29 0x41e12ea4 in QListView::contentsMousePressEvent () from /opt/qt/lib/libqt-mt.so.3
#30 0x41628e67 in KListView::contentsMousePressEvent () from /opt/kde/lib/libkdeui.so.4
#31 0x4029d8c4 in KMHeaders::contentsMousePressEvent (this=0x83dad00, e=0xbfe87ff4) at kmheaders.cpp:2156
#32 0x41e448e8 in QScrollView::viewportMousePressEvent () from /opt/qt/lib/libqt-mt.so.3
#33 0x41e41699 in QScrollView::eventFilter () from /opt/qt/lib/libqt-mt.so.3
#34 0x41e0d4f6 in QListView::eventFilter () from /opt/qt/lib/libqt-mt.so.3
#35 0x40298482 in KMHeaders::eventFilter (this=0x83dad00, o=0x842b810, e=0xbfe88564) at kmheaders.cpp:241
#36 0x41d2aa1e in QObject::activate_filters () from /opt/qt/lib/libqt-mt.so.3
#37 0x41d2aa9b in QObject::event () from /opt/qt/lib/libqt-mt.so.3
#38 0x41d6440c in QWidget::event () from /opt/qt/lib/libqt-mt.so.3
#39 0x41ccbb71 in QApplication::internalNotify () from /opt/qt/lib/libqt-mt.so.3
#40 0x41cccc22 in QApplication::notify () from /opt/qt/lib/libqt-mt.so.3
#41 0x4194e50e in KApplication::notify () from /opt/kde/lib/libkdecore.so.4
#42 0x41c674d8 in QETWidget::translateMouseEvent () from /opt/qt/lib/libqt-mt.so.3
#43 0x41c6611f in QApplication::x11ProcessEvent () from /opt/qt/lib/libqt-mt.so.3
#44 0x41c79d6a in QEventLoop::processEvents () from /opt/qt/lib/libqt-mt.so.3
#45 0x41ce26e3 in QEventLoop::enterLoop () from /opt/qt/lib/libqt-mt.so.3
#46 0x41ce25c6 in QEventLoop::exec () from /opt/qt/lib/libqt-mt.so.3
#47 0x41ccb58f in QApplication::exec () from /opt/qt/lib/libqt-mt.so.3
#48 0x0804a97b in main (argc=1, argv=0xbfe88b64) at main.cpp:110



### Opening INBOX:

kmail: processing next mail check for CS
kmail: check mail started - connections for host mail.xxx.xxx now is 1
kmail: processNewMail true,status=1
kmail: KMFolderImap::checkValidity of: /INBOX/
kmail: KMFolderImap::slotCheckValidityResult of: INBOX
kmail: [bool KMHeaders::readSortOrder(bool, bool)]
kmail: [
0: /opt/kde/lib/libkdecore.so.4(_Z11kdBacktracei+0x4b) [0x418bd01b]
1: /opt/kde/lib/libkdecore.so.4(_Z11kdBacktracev+0x2b) [0x418bd38b]
2: /opt/kde/lib/libkmailprivate.so(_ZN9KMHeaders13readSortOrderEbb+0x37) [0x402a3039]
3: /opt/kde/lib/libkmailprivate.so(_ZN9KMHeaders17updateMessageListEbb+0xd7) [0x402a5353]
4: /opt/kde/lib/libkmailprivate.so(_ZN9KMHeaders9setFolderEP8KMFolderb+0x7cd) [0x402a26d1]
5: /opt/kde/lib/libkmailprivate.so(_ZN12KMMainWidget14folderSelectedEP8KMFolderb+0x6bc) [0x4043b10e]
6: /opt/kde/lib/libkmailprivate.so(_ZN12KMMainWidget14folderSelectedEv+0x32) [0x4043b17a]
7: /opt/kde/lib/libkmailprivate.so(_ZN12KMMainWidget9qt_invokeEiP8QUObject+0x15c) [0x40441136]
8: /opt/qt/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEP15QConnectionListP8QUObject+0xcc) [0x41d2ac3c]
9: /opt/kde/lib/libkmailprivate.so(_ZN12KMFolderImap14folderCompleteEPS_b+0xd3) [0x4037c0a9]
10: /opt/kde/lib/libkmailprivate.so(_ZN12KMFolderImap15finishMailCheckENS_9imapStateE+0x62) [0x4037c134]
11: /opt/kde/lib/libkmailprivate.so(_ZN12KMFolderImap20slotListFolderResultEPN3KIO3JobE+0x61a) [0x40384d4e]
12: /opt/kde/lib/libkmailprivate.so(_ZN12KMFolderImap9qt_invokeEiP8QUObject+0x674) [0x4038706a]
13: /opt/qt/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEP15QConnectionListP8QUObject+0x169) [0x41d2acd9]
14: /opt/kde/lib/libkio.so.4(_ZN3KIO3Job6resultEPS0_+0xa2) [0x412f1812]
15: /opt/kde/lib/libkio.so.4(_ZN3KIO3Job10emitResultEv+0x7c) [0x413456ec]
16: /opt/kde/lib/libkio.so.4(_ZN3KIO9SimpleJob12slotFinishedEv+0x3e) [0x4134585e]
17: /opt/kde/lib/libkio.so.4(_ZN3KIO7ListJob12slotFinishedEv+0x4d) [0x41345bed]
18: /opt/kde/lib/libkio.so.4(_ZN3KIO7ListJob9qt_invokeEiP8QUObject+0x6e) [0x4135aebe]
19: /opt/qt/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEP15QConnectionListP8QUObject+0x169) [0x41d2acd9]
20: /opt/qt/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEi+0x80) [0x41d2b180]
21: /opt/kde/lib/libkio.so.4(_ZN3KIO14SlaveInterface8finishedEv+0x2c) [0x412ec47c]
22: /opt/kde/lib/libkio.so.4(_ZN3KIO14SlaveInterface8dispatchEiRK9QMemArrayIcE+0xcec) [0x4135fc6c]
23: /opt/kde/lib/libkio.so.4(_ZN3KIO14SlaveInterface8dispatchEv+0x67) [0x41304ce7]
24: /opt/kde/lib/libkio.so.4(_ZN3KIO5Slave8gotInputEv+0x2b) [0x4130984b]
25: /opt/kde/lib/libkio.so.4(_ZN3KIO5Slave9qt_invokeEiP8QUObject+0x8b) [0x413099fb]
26: /opt/qt/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEP15QConnectionListP8QUObject+0x169) [0x41d2acd9]
27: /opt/qt/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEii+0xc1) [0x41d2b2b1]
28: /opt/qt/lib/libqt-mt.so.3(_ZN15QSocketNotifier9activatedEi+0x30) [0x42067260]
29: /opt/qt/lib/libqt-mt.so.3(_ZN15QSocketNotifier5eventEP6QEvent+0x50) [0x41d49bd0]
30: /opt/qt/lib/libqt-mt.so.3(_ZN12QApplication14internalNotifyEP7QObjectP6QEvent+0xa1) [0x41ccbb71]
31: /opt/qt/lib/libqt-mt.so.3(_ZN12QApplication6notifyEP7QObjectP6QEvent+0xef) [0x41ccc58f]
32: /opt/kde/lib/libkdecore.so.4(_ZN12KApplication6notifyEP7QObjectP6QEvent+0x1ee) [0x4194e50e]
33: /opt/qt/lib/libqt-mt.so.3(_ZN10QEventLoop23activateSocketNotifiersEv+0xdd) [0x41cbfafd]
34: /opt/qt/lib/libqt-mt.so.3(_ZN10QEventLoop13processEventsEj+0x543) [0x41c7a073]
35: /opt/qt/lib/libqt-mt.so.3(_ZN10QEventLoop9enterLoopEv+0xc3) [0x41ce26e3]
36: /opt/qt/lib/libqt-mt.so.3(_ZN10QEventLoop4execEv+0x26) [0x41ce25c6]
37: /opt/qt/lib/libqt-mt.so.3(_ZN12QApplication4execEv+0x1f) [0x41ccb58f]
38: kmail(_ZN12KApplication9saveStateER15QSessionManager+0x3c3) [0x804a97b]
39: /lib/tls/libc.so.6(__libc_start_main+0xdb) [0x4242dd6b]
40: kmail(_ZN7QObject16checkConnectArgsEPKcPKS_S1_+0x59) [0x804a661]
]
kmail:
### Does this mean kmail / server closed the connection?
kmail: connections to server mail.xxx.xxx now 0
kmail: processNextCheck, remaining 0
kmail: account CS finished check
### Here I'm clicking through the messages
kmail: (0, last 0) Varauksen vahvistus Finnkinon internet-palvelusta asiakaspalvelu@finnkino.fi, readyToShow true
kmail: [const QTextCodec* KMReaderWin::overrideCodec() const]  mOverrideEncoding == ''
kmail: [const QTextCodec* KMReaderWin::overrideCodec() const]  mOverrideEncoding == ''
kmail: parseMsg(KMMessage* aMsg == aMsg )
kmail: + Text/Plain
kmail:       Inserting one item into MimePartTree
kmail:                 Content-Type: Text/Plain
kmail: partNode::findType() is looking at Text/Plain
kmail: [static KMail::SpamScores KMail::SpamHeaderAnalyzer::getSpamScores(const KMMessage*)]
kmail: Multiple / No addressees matched email address; Count is 0
kmail: ObjectTreeParser::parseObjectTree( node OK, showOnlyOneMimePart: FALSE )
kmail: [const QTextCodec* KMReaderWin::overrideCodec() const]  mOverrideEncoding == ''
kmail: KMReaderWin  -  finished parsing and displaying of message.
kmail: (0, last 0) Varauksen vahvistus Finnkinon internet-palvelusta asiakaspalvelu@finnkino.fi, readyToShow true
pure virtual method called
terminate called without an active exception
*** KMail got signal 6 (Crashing)
KCrash: Application 'kmail' crashing...





kmail: (0, last 0) Varauksen vahvistus Finnkinon internet-palvelusta asiakaspalvelu@finnkino.fi, readyToShow true
kmail: [const QTextCodec* KMReaderWin::overrideCodec() const]  mOverrideEncoding == ''
kmail: [const QTextCodec* KMReaderWin::overrideCodec() const]  mOverrideEncoding == ''
kmail: parseMsg(KMMessage* aMsg == aMsg )
kmail: + Text/Plain
kmail:       Inserting one item into MimePartTree
kmail:                 Content-Type: Text/Plain
kmail: partNode::findType() is looking at Text/Plain
kmail: [static KMail::SpamScores KMail::SpamHeaderAnalyzer::getSpamScores(const KMMessage*)]
kmail: Multiple / No addressees matched email address; Count is 0
kmail: ObjectTreeParser::parseObjectTree( node OK, showOnlyOneMimePart: FALSE )
kmail: [const QTextCodec* KMReaderWin::overrideCodec() const]  mOverrideEncoding == ''
kmail: KMReaderWin  -  finished parsing and displaying of message.
kmail: (0, last 0) Varauksen vahvistus Finnkinon internet-palvelusta asiakaspalvelu@finnkino.fi, readyToShow true
==4010==
==4010== Invalid read of size 4
==4010==    at 0x1BBDD56B: KMReaderWin::setMsg(KMMessage*, bool) (kmreaderwin.cpp:1163)
==4010==    by 0x1BD1E0CF: KMMainWidget::slotMsgSelected(KMMessage*) (kmmainwidget.cpp:1869)
==4010==    by 0x1BD2D191: KMMainWidget::qt_invoke(int, QUObject*) (kmmainwidget.moc:472)
==4010==    by 0x1D617CD8: QObject::activate_signal(QConnectionList*, QUObject*) (in /opt/qt/lib/libqt-mt.so.3.3.5)
==4010==    by 0x1BB89010: KMHeaders::selected(KMMessage*) (kmheaders.moc:250)
==4010==    by 0x1BB892DD: KMHeaders::highlightMessage(QListViewItem*, bool) (kmheaders.cpp:1995)
==4010==    by 0x1BB8965D: KMHeaders::highlightMessage(QListViewItem*) (kmheaders.cpp:2244)
==4010==    by 0x1BB96462: KMHeaders::qt_invoke(int, QUObject*) (kmheaders.moc:295)
==4010==    by 0x1D617CD8: QObject::activate_signal(QConnectionList*, QUObject*) (in /opt/qt/lib/libqt-mt.so.3.3.5)
==4010==    by 0x1D967444: QListView::currentChanged(QListViewItem*) (in /opt/qt/lib/libqt-mt.so.3.3.5)
==4010==    by 0x1D6FB0BC: QListView::setCurrentItem(QListViewItem*) (in /opt/qt/lib/libqt-mt.so.3.3.5)
==4010==    by 0x1D6FF47D: QListView::contentsMousePressEventEx(QMouseEvent*) (in /opt/qt/lib/libqt-mt.so.3.3.5)
==4010==  Address 0x1F160A74 is 28 bytes inside a block of size 96 free'd
==4010==    at 0x1B905784: operator delete(void*) (in /usr/lib/valgrind/vgpreload_memcheck.so)
==4010==    by 0x1BAFA0F5: KMMessage::~KMMessage() (kmmessage.cpp:194)
==4010==    by 0x1BC41084: KMMsgList::set(unsigned, KMMsgBase*) (kmmsglist.cpp:100)
==4010==    by 0x1BD32ACA: KMFolderIndex::setIndexEntry(int, KMMessage*) (kmfolderindex.cpp:478)
==4010==    by 0x1BBE1F2E: FolderStorage::unGetMsg(int) (folderstorage.cpp:543)
==4010==    by 0x1BBC569C: KMFolder::unGetMsg(int) (kmfolder.cpp:305)
==4010==    by 0x1BB89177: KMHeaders::highlightMessage(QListViewItem*, bool) (kmheaders.cpp:1971)
==4010==    by 0x1BB8965D: KMHeaders::highlightMessage(QListViewItem*) (kmheaders.cpp:2244)
==4010==    by 0x1BB96462: KMHeaders::qt_invoke(int, QUObject*) (kmheaders.moc:295)
==4010==    by 0x1D617CD8: QObject::activate_signal(QConnectionList*, QUObject*) (in /opt/qt/lib/libqt-mt.so.3.3.5)
==4010==    by 0x1D967444: QListView::currentChanged(QListViewItem*) (in /opt/qt/lib/libqt-mt.so.3.3.5)
==4010==    by 0x1D6FB0BC: QListView::setCurrentItem(QListViewItem*) (in /opt/qt/lib/libqt-mt.so.3.3.5)
pure virtual method called
terminate called without an active exception
==4010==
==4010== ERROR SUMMARY: 55 errors from 6 contexts (suppressed: 193 from 6)
==4010== malloc/free: in use at exit: 3711466 bytes in 144495 blocks.
==4010== malloc/free: 1341216 allocs, 1196721 frees, 39809630 bytes allocated.
==4010== For counts of detected errors, rerun with: -v
==4010== searching for pointers to 144495 not-freed blocks.
==4010== checked 7838716 bytes.
==4010==
==4010== LEAK SUMMARY:
==4010==    definitely lost: 24 bytes in 5 blocks.
==4010==      possibly lost: 128 bytes in 3 blocks.
==4010==    still reachable: 3711314 bytes in 144487 blocks.
==4010==         suppressed: 0 bytes in 0 blocks.
==4010== Use --leak-check=full to see details of leaked memory.
Aborted
Comment 1 Stephan Kulow 2005-11-14 21:05:01 UTC
this looks release critical to me.
Comment 2 Andreas Kling 2006-08-21 16:19:59 UTC
*** Bug 132060 has been marked as a duplicate of this bug. ***
Comment 3 Andreas Kling 2006-08-21 16:21:48 UTC
*** Bug 132740 has been marked as a duplicate of this bug. ***
Comment 4 BJ Blanchard 2006-09-27 15:55:42 UTC
Same type of backtrack for kontact 3.5.4 (gentoo) against an IMAP server, and it seems to happen when user is clicking around to different message s rapidly.

This crash is the third most common with kontact that we are experiencing (40% are related to bug 126715, 20% to 134701 and about 14% are related to this - overall 20+ crashes per day for 60 users)


Using host libthread_db library "/lib/tls/libthread_db.so.1".
Core was generated by `kontact'.
Program terminated with signal 6, Aborted.
#0  0xffffe410 in __kernel_vsyscall ()

Thread 5 (process 9250):
#0  0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1  0x49e3b9e6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x4a745aab in QWaitCondition::wait () from /usr/qt/3/lib/libqt-mt.so.3
No symbol table info available.
#3  0xb7f1ae85 in KPIM::ThreadWeaver::Weaver::applyForWork ()
   from /usr/kde/3.5/lib/libkdepim.so.1
No symbol table info available.
#4  0xb7fb0ae4 in typeinfo name for KPIM::ThreadWeaver::Event ()
   from /usr/kde/3.5/lib/libkdepim.so.1
No symbol table info available.

Thread 4 (process 9251):
#0  0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1  0x49e3b9e6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x4a745aab in QWaitCondition::wait () from /usr/qt/3/lib/libqt-mt.so.3
No symbol table info available.
#3  0xb7f1ae85 in KPIM::ThreadWeaver::Weaver::applyForWork ()
   from /usr/kde/3.5/lib/libkdepim.so.1
No symbol table info available.
#4  0x08abdcb0 in ?? ()
No symbol table info available.

Thread 3 (process 9252):
#0  0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1  0x49e3b9e6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x4a745aab in QWaitCondition::wait () from /usr/qt/3/lib/libqt-mt.so.3
No symbol table info available.
#3  0xb7f1ae85 in KPIM::ThreadWeaver::Weaver::applyForWork ()
   from /usr/kde/3.5/lib/libkdepim.so.1
No symbol table info available.
#4  0x08abdcb0 in ?? ()
No symbol table info available.

Thread 2 (process 9253):
#0  0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1  0x49e3b9e6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x4a745aab in QWaitCondition::wait () from /usr/qt/3/lib/libqt-mt.so.3
No symbol table info available.
#3  0xb7f1ae85 in KPIM::ThreadWeaver::Weaver::applyForWork ()
   from /usr/kde/3.5/lib/libkdepim.so.1
No symbol table info available.
#4  0x08abdcb0 in ?? ()
No symbol table info available.

Thread 1 (process 9248):
#0  0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1  0x49c2cd3d in raise () from /lib/tls/libc.so.6
No symbol table info available.
#2  0x49c2e353 in abort () from /lib/tls/libc.so.6
No symbol table info available.
#3  0x4a052dd6 in __gnu_cxx::__verbose_terminate_handler ()
   from /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libstdc++.so.6
No symbol table info available.
#4  0x4a050b8d in __cxxabiv1::__terminate ()
   from /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libstdc++.so.6
No symbol table info available.
#5  0x4a050bc2 in std::terminate ()
   from /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libstdc++.so.6
No symbol table info available.
#6  0x4a05104d in __cxa_pure_virtual ()
   from /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libstdc++.so.6
No symbol table info available.
#7  0xb653d827 in KMReaderWin::setMsg (this=0x88659d8, aMsg=0x8b0dfa8, 
    force=false) at kmreaderwin.cpp:1169
	complete = true
#8  0xb668ce00 in KMMainWidget::slotMsgSelected (this=0x8914ea0, msg=0x8b0dfa8)
    at kmmainwidget.cpp:1895
No locals.
#9  0xb669dfe3 in KMMainWidget::qt_invoke (this=0x8914ea0, _id=54, _o=0xbffdc4b0)
    at qucom_p.h:316
No locals.
#10 0x4a4a218a in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
No symbol table info available.
#11 0xb64e8230 in KMHeaders::selected (this=0xbffdc4d8, t0=0x0)
    at kmheaders.moc:250
	clist = (QConnectionList *) 0x88656a0
	o = {{type = 0x806a55c, payload = {b = false, c = 0 '\0', s = 0, i = 0, 
      l = 0, uc = 0 '\0', us = 0, ui = 0, ul = 0, f = 0, 
      d = 6.2213875145263882e-266, 
      byte = "\000\000\000\000h\fà\b\002\000\000\000\224_~¶", bytearray = {
        data = 0x0, size = 148900968}, ptr = 0x0, voidstar = {ptr = 0x0, 
        owner = 104}, charstar = {ptr = 0x0, owner = 104}, utf8 = {ptr = 0x0, 
        owner = 104}, local8bit = {ptr = 0x0, owner = 104}, iface = 0x0, 
      idisp = 0x0}}, {type = 0x806a1e8, payload = {b = 168, c = -88 '¨', 
      s = -8280, i = 145809320, l = 145809320, uc = 168 '¨', us = 57256, 
      ui = 145809320, ul = 145809320, f = 1.0645196e-33, 
      d = -7.8933007599083107e-47, byte = "¨ß°\b\026×\\¶¨ß°\bÊ\000\000", 
      bytearray = {data = 0x8b0dfa8 "hÌ~¶ð-p\b\223J\001", size = 3059537686}, 
      ptr = 0x8b0dfa8, voidstar = {ptr = 0x8b0dfa8, owner = 22}, charstar = {
        ptr = 0x8b0dfa8 "hÌ~¶ð-p\b\223J\001", owner = 22}, utf8 = {
        ptr = 0x8b0dfa8 "hÌ~¶ð-p\b\223J\001", owner = 22}, local8bit = {
        ptr = 0x8b0dfa8 "hÌ~¶ð-p\b\223J\001", owner = 22}, iface = 0x8b0dfa8, 
      idisp = 0x8b0dfa8}}}
#12 0xb64e83d9 in KMHeaders::highlightMessage (this=0x8917c80, lvi=0x328, 
    markitread=false) at qguardedptr.h:113
	msg = (class KMMessage *) 0x0
#13 0xb64e8848 in KMHeaders::highlightMessage (this=0x0, i=0x0)
    at kmheaders.cpp:2269
No locals.
#14 0xb64f6d51 in KMHeaders::qt_invoke (this=0x8917c80, _id=106, _o=0xbffdc640)
    at qucom_p.h:316
No locals.
#15 0x4a4a218a in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
No symbol table info available.
#16 0x4a7f777f in QListView::currentChanged () from /usr/qt/3/lib/libqt-mt.so.3
No symbol table info available.
#17 0x4a58eb78 in QListView::setCurrentItem () from /usr/qt/3/lib/libqt-mt.so.3
No symbol table info available.
#18 0x4a590f8b in QListView::contentsMousePressEventEx ()
   from /usr/qt/3/lib/libqt-mt.so.3
No symbol table info available.
#19 0x4a591964 in QListView::contentsMousePressEvent ()
   from /usr/qt/3/lib/libqt-mt.so.3
No symbol table info available.
#20 0xb71be6b7 in KListView::contentsMousePressEvent ()
   from /usr/kde/3.5/lib/libkdeui.so.4
No symbol table info available.
#21 0x00000000 in ?? ()
No symbol table info available.
Comment 5 Tommi Tervo 2006-10-26 15:41:40 UTC
*** Bug 136337 has been marked as a duplicate of this bug. ***
Comment 6 Tommi Tervo 2006-10-26 15:43:26 UTC
*** Bug 135948 has been marked as a duplicate of this bug. ***
Comment 7 Robert Penz 2006-10-26 17:56:12 UTC
The bug happens also in KMail for KDE 3.5.5 (packages made for Kubuntu 6.06)
Comment 8 Herbert Fukerider 2006-10-27 14:48:54 UTC
Got new qt-packages from SuSE today: 
qt-32bit-4.1.0-29.7.x86_64.rpm
qt-4.1.0-29.7.x86_64.rpm
At least for x86_64, the problem seems to be fixed.
No more crashes or invisible mail-bodies so far.
Comment 9 BJ Blanchard 2006-11-01 02:30:02 UTC
Same crash occurred after upgrading to 3.5.5 (gentoo).  Frequency seems diminished though.
Comment 10 Tommi Tervo 2007-01-03 09:35:16 UTC
*** Bug 138026 has been marked as a duplicate of this bug. ***
Comment 11 Philipp Wollermann 2007-02-04 19:20:49 UTC
Still occurs in KDE 3.5.6 (Gentoo).
Comment 12 Thomas McGuire 2007-02-11 17:23:38 UTC
*** Bug 141541 has been marked as a duplicate of this bug. ***
Comment 13 Thomas McGuire 2007-02-18 16:22:44 UTC
*** Bug 141870 has been marked as a duplicate of this bug. ***
Comment 14 Bram Schoenmakers 2007-03-06 12:21:16 UTC
*** Bug 142574 has been marked as a duplicate of this bug. ***
Comment 15 Thomas McGuire 2007-03-15 14:59:46 UTC
*** Bug 142887 has been marked as a duplicate of this bug. ***
Comment 16 Tommi Tervo 2007-05-02 17:47:21 UTC
*** Bug 144965 has been marked as a duplicate of this bug. ***
Comment 17 jstalnak 2007-05-04 18:47:25 UTC
I'm forced to discontinue use of Kontact/KMail until this crash issue can be resolved.  I'm not happy with multiple crashes per days -- Kontact crashed overnight, and now thrice in three hours. Is there any information I can provide that can help speed resolution of the problem?
Comment 18 Robert Penz 2007-05-04 19:12:15 UTC
it does not happen if you use cached-imap (at least for me)
Comment 19 jstalnak 2007-05-04 20:14:01 UTC
On Friday 04 May 2007, Robert Penz wrote:
[bugs.kde.org quoted mail]

Robert,

Thanks for your comment.  Where is such a setting?  I see only three places in 
KMail prefs that mention IMAP:

1. Where the mail server host is specified (when the wizard runs).
2. The Store IMAP Password setting (on the same view).
3. The Group IMAP setting.

I looked through the Kontact settings and don't find anything there, either.

Regards.
Comment 20 Will Stephenson 2007-05-04 20:38:22 UTC
AKA the 'disconnected imap' account type.  Create a new account of that type using your existing settings.  This uses the same IMAP protocol as online imap but caches all messages locally for offline reading and syncs changes to message state on every mail check.

jstalnak: the information we need to fix the bug is the version of KMail you are using, from which distribution, and how to reliably reproduce the bug.
Comment 21 jstalnak 2007-05-04 21:21:44 UTC
I entered a bug, #144965, and it was marked as a duplicate of this one, which 
is why I posted to it.

Let's see how things work now -- I've created a new account using the 
cached-imap.

Thanks for the suggestion and the instructions on how to do it.

Guy

On Friday 04 May 2007, Will Stephenson wrote:
[bugs.kde.org quoted mail]
Comment 22 Thomas McGuire 2007-05-28 15:56:58 UTC
*** Bug 146069 has been marked as a duplicate of this bug. ***
Comment 23 Tommi Tervo 2007-10-22 08:51:34 UTC
I just hit this bug today, I deleted a bunch of messages by pressing shift-delete and suddenly one message wouldn't get deleted. It was red and overlined and when I tried to delete again kmail crashed.
Kubuntu 7.10, (normal imap connection to exchange 2003) 

kmail: WARNING: FolderStorage::getMsg, message has no sernum, index: 696

#11 0xb58d8fa2 in std::terminate () from /usr/lib/libstdc++.so.6
#12 0xb58d9865 in __cxa_pure_virtual () from /usr/lib/libstdc++.so.6
#13 0xb7bdf321 in KMReaderWin::setMsg (this=0x829c790, aMsg=0x88d8800, 
    force=false)
    at /build/buildd/kdepim-3.5.7enterprise20070926/./kmail/kmreaderwin.cpp:1207
#14 0xb7d4a262 in KMMainWidget::slotMsgSelected (this=0x821e180, 
    msg=0x88d8800)
    at /build/buildd/kdepim-3.5.7enterprise20070926/./kmail/kmmainwidget.cpp:2126
#15 0xb7d5d2f0 in KMMainWidget::qt_invoke (this=0x821e180, _id=55, 
    _o=0xbfe11744) at ./kmmainwidget.moc:515
#16 0xb5f20893 in QObject::activate_signal (this=0x8246660, clist=0x829a460, 
    o=0xbfe11744) at kernel/qobject.cpp:2356
#17 0xb7b82a4e in KMHeaders::selected (this=0x8246660, t0=0x88d8800)
    at ./kmheaders.moc:258
#18 0xb7b8a593 in KMHeaders::highlightMessage (this=0x8246660, lvi=0x87f9f70, 
    markitread=false)
    at /build/buildd/kdepim-3.5.7enterprise20070926/./kmail/kmheaders.cpp:2088
#19 0xb7b8a97c in KMHeaders::highlightMessage (this=0x8246660, i=0x87f9f70)
    at /build/buildd/kdepim-3.5.7enterprise20070926/./kmail/kmheaders.cpp:2364
#20 0xb7b93306 in KMHeaders::qt_invoke (this=0x8246660, _id=107, 
    _o=0xbfe11888) at ./kmheaders.moc:303


I tried to valgrind kmail but I didn't manage to reproduce the crash.

==30094== Syscall param write(buf) points to uninitialised byte(s)
==30094==    at 0x40007F2: (within /lib/ld-2.6.1.so)
==30094==    by 0x67D3534: (within /lib/tls/i686/cmov/libc-2.6.1.so)
==30094==    by 0x67D386E: _IO_do_write (in /lib/tls/i686/cmov/libc-2.6.1.so)
==30094==    by 0x67D4055: _IO_file_sync (in /lib/tls/i686/cmov/libc-2.6.1.so)
==30094==    by 0x67C8B6F: fflush (in /lib/tls/i686/cmov/libc-2.6.1.so)
==30094==    by 0x4356E90: KMFolderMbox::addMsg(KMMessage*, int*) (kmfoldermbox.cpp:1105)
==30094==    by 0x4362235: KMFolderImap::slotGetMessagesData(KIO::Job*, QMemArray<char> const&) (kmfolderimap.cpp:1608)
==30094==    by 0x4367B9F: KMFolderImap::qt_invoke(int, QUObject*) (kmfolderimap.moc:344)
==30094==    by 0x5E9A892: QObject::activate_signal(QConnectionList*, QUObject*) (qobject.cpp:2356)
==30094==    by 0x532A8BC: KIO::TransferJob::data(KIO::Job*, QMemArray<char> const&) (jobclasses.moc:993)
==30094==    by 0x532A937: KIO::TransferJob::slotData(QMemArray<char> const&) (job.cpp:933)
==30094==    by 0x537F3B8: KIO::TransferJob::qt_invoke(int, QUObject*) (jobclasses.moc:1072)
==30094==    by 0x5E9A892: QObject::activate_signal(QConnectionList*


==30094== Invalid read of size 4
==30094==    at 0x4014C09: (within /lib/ld-2.6.1.so)
==30094==    by 0x400D319: (within /lib/ld-2.6.1.so)
==30094==    by 0x4009826: (within /lib/ld-2.6.1.so)
==30094==    by 0x687A4B4: (within /lib/tls/i686/cmov/libc-2.6.1.so)
==30094==    by 0x687A849: _dl_sym (in /lib/tls/i686/cmov/libc-2.6.1.so)
==30094==    by 0x64C5DE7: (within /lib/tls/i686/cmov/libdl-2.6.1.so)
==30094==    by 0x400D015: (within /lib/ld-2.6.1.so)
==30094==    by 0x64C62BB: (within /lib/tls/i686/cmov/libdl-2.6.1.so)
==30094==    by 0x64C5D72: dlsym (in /lib/tls/i686/cmov/libdl-2.6.1.so)
==30094==    by 0x5A839E8: sys_dl_sym (ltdl.c:646)
==30094==    by 0x5A828D5: lt_dlsym (ltdl.c:2664)
==30094==    by 0x5931CAE: KLibWrapPrivate::KLibWrapPrivate(KLibrary*, lt_dlhandle_struct*) (klibloader.cpp:278)
==30094==    by 0x59C3731: KLibLoader::library(char const*) (klibloader.cpp:443)
==30094==    by 0x476B833: KPIM::PluginLoaderBase::openLibrary(QString const&) const (pluginloaderbase.cpp:151)
==30094==    by 0x476BB08: KPIM::PluginLoaderBase::mainFunc(QString const&, char const*) const (pluginloaderbase.cpp:124)
==30094==    by 0x43F7DCD: KPIM::PluginLoader<KMail::Interface::BodyPartFormatterPlugin, (anonymous namespace)::(anonymous namespace)::BodyPartFormatterPluginLoaderConfig>::createForName(QString const&) const (pluginloader.h:109)
==30094==    by 0x43F6D57: KMail::BodyPartFormatterFactory::createFor(char const*, char const*) const (bodypartformatterfactory.cpp:114)
==30094==    by 0x43F7D46: KMail::BodyPartFormatterFactory::createFor(QCString const&, QCString const&) const (bodypartformatterfactory.cpp:190)
==30094==    by 0x43EC39A: KMail::ObjectTreeParser::parseObjectTree(partNode*) (objecttreeparser.cpp:261)
==30094==    by 0x42C330D: KMReaderWin::parseMsg(KMMessage*) (kmreaderwin.cpp:1586)
==30094==    by 0x42C3B02: KMReaderWin::displayMessage() (kmreaderwin.cpp:1512)
==30094==    by 0x42C3D24: KMReaderWin::updateReaderWin() (kmreaderwin.cpp:1448)
==30094==    by 0x42C641B: KMReaderWin::qt_invoke(int, QUObject*) (kmreaderwin.moc:301)
==30094==    by 0x5E9A892: QObject::activate_signal(QConnectionList*, QUObject*) (qobject.cpp:2356)
Comment 24 Thomas McGuire 2008-03-31 00:56:46 UTC
*** Bug 159867 has been marked as a duplicate of this bug. ***
Comment 25 Bram Schoenmakers 2008-04-27 02:47:58 UTC
*** Bug 161315 has been marked as a duplicate of this bug. ***
Comment 26 Thomas McGuire 2008-05-16 19:34:01 UTC
*** Bug 161852 has been marked as a duplicate of this bug. ***
Comment 27 Jaime Torres 2009-02-27 16:32:24 UTC
*** Bug 185701 has been marked as a duplicate of this bug. ***
Comment 28 Jaime Torres 2009-02-27 16:34:38 UTC
*** Bug 185700 has been marked as a duplicate of this bug. ***
Comment 29 Dario Andres 2010-03-18 13:14:48 UTC
*** Bug 231011 has been marked as a duplicate of this bug. ***
Comment 30 Christophe Giboudeaux 2010-03-28 22:21:39 UTC
*** Bug 162404 has been marked as a duplicate of this bug. ***