Bug 142574 - kmail and spampayes problems with imap accounts
Summary: kmail and spampayes problems with imap accounts
Status: RESOLVED DUPLICATE of bug 116372
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-05 23:55 UTC by S Roa
Modified: 2007-03-06 13:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S Roa 2007-03-05 23:55:06 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    Ubuntu Packages
OS:                Linux

When I use the SpamBayes filters (version 1.0.4-3 kubuntu edgy), sometimes the messages are not shown. The behaviour of kmail is very random, sometimes messages are shown but not its content, or sometimes are shown as if they had an other date of arrival. This does not happen when I use the Spamassassin filters (3.1.4-1ubuntu1). The number of messages shown also changes, but when I delete the messages filtered by SpamBayes the problem goes away and I can use kmail again normally. I think something strange is happening with the headers. Even sometimes kmail crashes:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1241613520 (LWP 7379)]
[New Thread -1281143904 (LWP 7383)]
[New Thread -1272751200 (LWP 7382)]
[New Thread -1264358496 (LWP 7381)]
[New Thread -1255965792 (LWP 7380)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xffffe410 in __kernel_vsyscall ()
#7  0xb77d5770 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb77d6ef3 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb79c6520 in __gnu_cxx::__verbose_terminate_handler ()
   from /usr/lib/libstdc++.so.6
#10 0xb79c3f55 in std::set_unexpected () from /usr/lib/libstdc++.so.6
#11 0xb79c3f92 in std::terminate () from /usr/lib/libstdc++.so.6
#12 0xb79c4675 in __cxa_pure_virtual () from /usr/lib/libstdc++.so.6
#13 0xb55e7ae1 in KMReaderWin::setMsg () from /usr/lib/libkmailprivate.so
#14 0xb573100e in KMMainWidget::slotMsgSelected ()
   from /usr/lib/libkmailprivate.so
#15 0xb5744cb0 in KMMainWidget::qt_invoke () from /usr/lib/libkmailprivate.so
#16 0xb7063957 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#17 0xb559553e in KMHeaders::selected () from /usr/lib/libkmailprivate.so
#18 0xb5597589 in KMHeaders::highlightMessage ()
   from /usr/lib/libkmailprivate.so
#19 0xb559797c in KMHeaders::highlightMessage ()
   from /usr/lib/libkmailprivate.so
#20 0xb55a4e86 in KMHeaders::qt_invoke () from /usr/lib/libkmailprivate.so
#21 0xb7063957 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#22 0xb7407e25 in QListView::currentChanged () from /usr/lib/libqt-mt.so.3
#23 0xb715deaf in QListView::setCurrentItem () from /usr/lib/libqt-mt.so.3
#24 0xb7161ca3 in QListView::contentsMousePressEventEx ()
   from /usr/lib/libqt-mt.so.3
#25 0xb71623a8 in QListView::contentsMousePressEvent ()
   from /usr/lib/libqt-mt.so.3
#26 0xb68831dc in KListView::contentsMousePressEvent ()
   from /usr/lib/libkdeui.so.4
#27 0xb5597ab9 in KMHeaders::contentsMousePressEvent ()
   from /usr/lib/libkmailprivate.so
#28 0xb71990b9 in QScrollView::viewportMousePressEvent ()
   from /usr/lib/libqt-mt.so.3
#29 0xb719a52c in QScrollView::eventFilter () from /usr/lib/libqt-mt.so.3
#30 0xb7162816 in QListView::eventFilter () from /usr/lib/libqt-mt.so.3
#31 0xb5599189 in KMHeaders::eventFilter () from /usr/lib/libkmailprivate.so
#32 0xb7062f04 in QObject::activate_filters () from /usr/lib/libqt-mt.so.3
#33 0xb7062f82 in QObject::event () from /usr/lib/libqt-mt.so.3
#34 0xb709a65b in QWidget::event () from /usr/lib/libqt-mt.so.3
#35 0xb6ffab88 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#36 0xb6ffcd46 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#37 0xb7723db2 in KApplication::notify () from /usr/lib/libkdecore.so.4
#38 0xb6f8d3fd in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#39 0xb6f8c062 in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#40 0xb6f8a14c in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#41 0xb6fa1320 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#42 0xb701525e in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#43 0xb701506e in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#44 0xb6ffc731 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#45 0x0805ad81 in ?? ()
#46 0xbffbb580 in ?? ()
#47 0x00000001 in ?? ()
#48 0x00000001 in ?? ()
#49 0x00000000 in ?? ()
Comment 1 S Roa 2007-03-05 23:56:42 UTC
I forgot to say that it does not happens with POP accounts...
Comment 2 Bram Schoenmakers 2007-03-06 12:21:15 UTC

*** This bug has been marked as a duplicate of 116372 ***
Comment 3 S Roa 2007-03-06 12:49:10 UTC
This bug does not really has to do with the bug 116372
Comment 4 Bram Schoenmakers 2007-03-06 13:24:31 UTC
The backtraces are similar which tells me that your description is just a symptom of a more general problem.