Bug 142887 - kmail crashes after eliminating duplicate messages
Summary: kmail crashes after eliminating duplicate messages
Status: RESOLVED DUPLICATE of bug 116372
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.5
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-12 22:08 UTC by Jan Hrabe
Modified: 2007-03-15 14:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Hrabe 2007-03-12 22:08:54 UTC
Version:           1.9.5 (using KDE 3.5.5, Gentoo)
Compiler:          Target: i686-pc-linux-gnu
OS:                Linux (i686) release 2.6.19-gentoo-r5

With an IMAP account, when the remote folder is cleaned up by CTRL+* (delete duplicated messages), the kmail often crashes after attempting to read a message from that folder or to copy some messages from it to local storage.  Also, some messages in that folder may show empty bodies even though there should be some content in them (as confirmed using independent webmail application on the same IMAP folder).

Thanks,
Jan
Comment 1 Bram Schoenmakers 2007-03-12 22:15:05 UTC
Please provide a detailed backtrace.
Comment 2 Jan Hrabe 2007-03-14 22:41:09 UTC
> gdb kmail
GNU gdb 6.6
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(gdb) set args --nofork
(gdb) run
Starting program: /usr/kde/3.5/bin/kmail --nofork
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208961360 (LWP 7115)]
[New Thread -1210270832 (LWP 7118)]
[New Thread -1218663536 (LWP 7119)]
[New Thread -1227056240 (LWP 7120)]
[New Thread -1235448944 (LWP 7121)]
WeaverThreadLogger: thread (ID: 2) suspended.
WeaverThreadLogger: thread (ID: 1) suspended.
WeaverThreadLogger: thread (ID: 4) suspended.
WeaverThreadLogger: thread (ID: 3) suspended.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x83cc9a0 ): KAccel object already contains an action name "move_message_to_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x83cc9a0 ): KAccel object already contains an action name "copy_message_to_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x83cc9a0 ): KAccel object already contains an action name "jump_to_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x83cc9a0 ): KAccel object already contains an action name "remove_duplicate_messages"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x83cc9a0 ): KAccel object already contains an action name "cancel"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x83cc9a0 ): KAccel object already contains an action name "inc_current_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x83cc9a0 ): KAccel object already contains an action name "dec_current_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x83cc9a0 ): KAccel object already contains an action name "select_current_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x83cc9a0 ): KAccel object already contains an action name "inc_current_message"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x83cc9a0 ): KAccel object already contains an action name "dec_current_message"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x83cc9a0 ): KAccel object already contains an action name "select_current_message"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x83cc9a0 ): KAccel object already contains an action name "delete"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x83cc9a0 ): KAccel object already contains an action name "edit"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x83cc9a0 ): KAccel object already contains an action name "display_message"
pure virtual method called
terminate called without an active exception

Program received signal SIGABRT, Aborted.
[Switching to Thread -1208961360 (LWP 7115)]
0xb7f35410 in __kernel_vsyscall ()
(gdb) bt
#0  0xb7f35410 in __kernel_vsyscall ()
#1  0x4775e269 in raise () from /lib/libc.so.6
#2  0x4775f761 in abort () from /lib/libc.so.6
#3  0x47addab0 in __gnu_cxx::__verbose_terminate_handler ()
   from /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libstdc++.so.6
#4  0x47adb7e5 in ?? ()
   from /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libstdc++.so.6
#5  0x47adb816 in std::terminate ()
   from /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libstdc++.so.6
#6  0x47adbe45 in __cxa_pure_virtual ()
   from /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libstdc++.so.6
#7  0x453b5b87 in KMReaderWin::setMsg ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#8  0x47852ff4 in ?? () from /lib/libc.so.6
#9  0x01004120 in ?? ()
#10 0x085b8b38 in ?? ()
#11 0xbfa8c188 in ?? ()
#12 0x00000010 in ?? ()
#13 0x085b8b38 in ?? ()
#14 0x087c8498 in ?? ()
#15 0x4565b5a0 in ?? () from /usr/kde/3.5/lib/libkmailprivate.so
#16 0x083c1438 in ?? ()
#17 0xbfa8c264 in ?? ()
#18 0x085e5ad0 in ?? ()
#19 0x454f2208 in KMMainWidget::slotMsgSelected ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#20 0x4783e6b4 in ?? () from /lib/libc.so.6
#21 0xbfa8c270 in ?? ()
#22 0x08651730 in ?? ()
#23 0x4b5ed1ea in QGDict::unlink_common () from /usr/qt/3/lib/libqt-mt.so.3
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
(gdb) cont
Continuing.
*** KMail got signal 6 (Crashing)
KCrash: Application 'kmail' crashing...
KCrash cannot reach kdeinit, launching directly.

Program exited with code 0375.
(gdb) quit
Comment 3 Thomas McGuire 2007-03-14 22:50:13 UTC
I wonder if it has something to do with bug #116372.
Comment 4 Jan Hrabe 2007-03-15 05:50:41 UTC
I think you might be right because I noticed apparently empty message bodies
in the folder after attempting to eliminate the duplicate messages in it.  Checking with squirelmail showed that the message bodies on the server were OK, only kmail was ignoring them.  I've found today that renaming the folder brings the message bodies back.
Comment 5 Thomas McGuire 2007-03-15 14:59:44 UTC
I'll close this as a duplicate of bug 116372 for now. If bug 116372 gets fixed but this problem still persists, then please reopen this bug report.

*** This bug has been marked as a duplicate of 116372 ***