Bug 135948 - selecting message in list results in crash (imap account)
Summary: selecting message in list results in crash (imap account)
Status: RESOLVED DUPLICATE of bug 116372
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.9.5
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-19 10:19 UTC by Philipp Wollermann
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrace on crash (4.02 KB, text/plain)
2006-10-19 10:20 UTC, Philipp Wollermann
Details
The mail which triggers the crash frequently (1.28 KB, message/rfc822)
2006-10-19 10:22 UTC, Philipp Wollermann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Wollermann 2006-10-19 10:19:45 UTC
Version:           1.9.5 (using KDE 3.5.5, Kubuntu (edgy) 4:3.5.5-0ubuntu2)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.18.1-custom

When I cycle through (not necessarily unread) mails in my IMAP Inbox, kmail sometimes does not show the mails in the preview pane. If I keep selecting mails from the list, kmail will suddenly crash. Bug seems similar to "resolved" bug 94184. A specific mail seems to trigger this bug much more frequently, if it is the first mail, kmail wants to show when I open the folder. I'll attach that one.

I'll attach two backtraces too. IMAP Server is a dovecot 1.0rc6.

The mails show up with no problem in Thunderbird, however I see some headers in the mail body. Maybe kmail can't cope with certain broken mails? (Please note, that kmail doesn't crash *everytime* I try open this mail, maybe about 90% of the time)
Comment 1 Philipp Wollermann 2006-10-19 10:20:06 UTC
Created attachment 18189 [details]
Backtrace on crash
Comment 2 Philipp Wollermann 2006-10-19 10:22:53 UTC
Created attachment 18190 [details]
The mail which triggers the crash frequently
Comment 3 Philip Rodrigues 2006-10-19 18:43:24 UTC
Please paste the first ~10 calls from backtraces, as it allows the "search for similar crashes" feature to work. Thanks!

#19 0x4dcf8121 in KMReaderWin::setMsg (this=0x832aac8, aMsg=0x84eb478, 
    force=false) at /build/buildd/kdepim-3.5.5/./kmail/kmreaderwin.cpp:1176
#20 0x4de4164e in KMMainWidget::slotMsgSelected (this=0x80ab6c0, 
    msg=0x84eb478) at /build/buildd/kdepim-3.5.5/./kmail/kmmainwidget.cpp:1911
#21 0x4de552f0 in KMMainWidget::qt_invoke (this=0x80ab6c0, _id=55, 
    _o=0xbffda874) at ./kmmainwidget.moc:481
#22 0x4aaf2d5f in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#23 0x4dca5b7e in KMHeaders::selected (this=0x82f2060, t0=0x84eb478)
    at ./kmheaders.moc:250
#24 0x4dca7bc9 in KMHeaders::highlightMessage (this=0x82f2060, lvi=0x84c8490, 
    markitread=false) at /build/buildd/kdepim-3.5.5/./kmail/kmheaders.cpp:2020
#25 0x4dca7fbc in KMHeaders::highlightMessage (this=0x82f2060, i=0x84c8490)
    at /build/buildd/kdepim-3.5.5/./kmail/kmheaders.cpp:2269
#26 0x4dcb54c6 in KMHeaders::qt_invoke (this=0x82f2060, _id=107, 
    _o=0xbffda9b8) at ./kmheaders.moc:295
#27 0x4aaf2d5f in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#28 0x4ae9722d in QListView::currentChanged () from /usr/lib/libqt-mt.so.3
#29 0x4abed2b7 in QListView::setCurrentItem () from /usr/lib/libqt-mt.so.3
#30 0x4abf10ab in QListView::contentsMousePressEventEx ()
   from /usr/lib/libqt-mt.so.3
#31 0x4abf17b0 in QListView::contentsMousePressEvent ()
   from /usr/lib/libqt-mt.so.3
#32 0x4ca8725c in KListView::contentsMousePressEvent (this=0x82f2060, 
    e=0xbffdad0c) at /build/buildd/kdelibs-3.5.5/./kdeui/klistview.cpp:805
#33 0x4dca80f9 in KMHeaders::contentsMousePressEvent (this=0x82f2060, 
    e=0xbffdad0c) at /build/buildd/kdepim-3.5.5/./kmail/kmheaders.cpp:2181
#34 0x4ac284c1 in QScrollView::viewportMousePressEvent ()
   from /usr/lib/libqt-mt.so.3
#35 0x4ac29934 in QScrollView::eventFilter () from /usr/lib/libqt-mt.so.3
#36 0x4abf1c1e in QListView::eventFilter () from /usr/lib/libqt-mt.so.3
#37 0x4dca97c9 in KMHeaders::eventFilter (this=0x82f2060, o=0x82f3790, 
    e=0xbffdb2e0) at /build/buildd/kdepim-3.5.5/./kmail/kmheaders.cpp:241
Comment 4 Philipp Wollermann 2006-10-19 19:09:00 UTC
Okay, I'll do that in my next reports :) I'm not so sure anymore if really this mail is triggering the bug. To reproduce I have to do the following:

- Click through my message list, until I find a message which won't display in the preview window. The specific message seems to vary each time I try. When I've found a message where this happens, I know the crash will happen soon.
- This specific message is sometimes displayed with headers but no body, sometimes not at all (just a blank white preview-window). It's never shown completely. KMail is not loading anything at the moment.
- I keep on clicking through my message list, the other mails are shown completely in the preview window. I keep clicking on the not-working mail too a few times. Repeat a few times and it crashes.
Comment 5 Robert Penz 2006-10-20 17:28:03 UTC
I've the same problem with the same kubuntu packages connecting to an courier mail server running on debian sarg. I hat not such problems before the upgrade
Comment 6 Tommi Tervo 2006-10-26 15:43:24 UTC

*** This bug has been marked as a duplicate of 116372 ***