Bug 116341 - xinerama setup: Its not possible to place icons on screen 2 if you chose "Align to Grid"
Summary: xinerama setup: Its not possible to place icons on screen 2 if you chose "Ali...
Status: CLOSED DUPLICATE of bug 122001
Alias: None
Product: kdesktop
Classification: Miscellaneous
Component: icons (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal with 125 votes (vote)
Target Milestone: ---
Assignee: Benoit Walter
URL:
Keywords:
: 117463 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-11-14 13:51 UTC by Marc Schiffbauer
Modified: 2009-01-03 00:05 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
This file should be called by autostart (989 bytes, application/x-shellscript)
2006-02-12 19:59 UTC, Johannes Eberleh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Schiffbauer 2005-11-14 13:51:41 UTC
Version:            (using KDE KDE 3.5.0)
Installed from:    Ubuntu Packages
OS:                Linux

Icon positioning has been much improved for KDE 3.5, cool!

But one thing I noticed:

Set Icons to "Align to Grid" via RMB on the Desktop.
All Icons placed on screen 2 (or maybe aother screens if one has more than two screens) are moved to screen 1 and its not possible to move them to screen 2 then until I disable "Align to grid" again.

Cheers
-Marc
Comment 1 Kevin Stone 2005-11-17 18:56:53 UTC
I've also experienced this running KDE 3.5.0 RC1 on gentoo.  My desktop icons were all on screen 2, but when I loaded up a newly installed kde 3.5, it moved them all over to screen 1 and wouldn't let me drag them back until I unchecked align to grid.  This wasn't a problem in kde 3.4.
Comment 2 Thorsten Holtkaemper 2005-11-29 22:30:54 UTC
I can confirm this bug, It's also present in the current SuSE RPMs for KDE 3.5.0 (i.e. kdebase3-3.5.0-16). Also enabling/disabling align to grid sometimes changes the icon arrangement and/or the line wrapping of the icon text.
Comment 3 Brian C. Milco 2005-12-01 04:28:45 UTC
I've experienced this too, in KDE 3.5.0 RC1 (and KDE 3.5.0 Final) for Gentoo. Very annoying in an otherwise excellent product, especially since it worked in 3.4.3
Comment 4 Michael Zenke 2005-12-01 07:08:43 UTC
I can confirm this bug. I was uusing kde 3.4.3 with my Desktop-Icons placed on the second Screen. After upgrading to kde 3.5.0 my Icons moved to the first screen. If I uncheck align to grid then I can move the icons back on screen 2, but afer a relogin the icons move back on screen 1
Comment 5 Eros Candelaresi 2005-12-02 14:34:25 UTC
Exactly the same here. Using the Kubuntu packages, KDE 3.5.0. Upgraded from 3.4.3 where everything was fine. 
Comment 6 Phillip Sparks 2005-12-03 00:30:13 UTC
I have found the same problem.  I also have found another problem that seems to be caused by "Align to Grid", #117550 (http://bugs.kde.org/show_bug.cgi?id=117550).
Comment 7 Todor Tzankov 2005-12-03 11:38:18 UTC
I can also confirm that bug - Gentoo with KDE 3.5.0 final.
Comment 8 Jeremy 2005-12-07 05:56:21 UTC
Confirmed (in 3.5.0 Alioth debian packages).
The "align to grid" option overrides the "lock in place" option.
When "align to grid" is disabled in my setup, icons do maintain their positions on screen 2 after relogging in, whether or not "lock in place" is enabled
Comment 9 Stefan Kopic 2005-12-10 14:36:03 UTC
*** This bug has been confirmed by popular vote. ***
Comment 10 Gunter Ohrner 2005-12-11 12:37:58 UTC
Ok, confirmed (surprise, surprise...) using experimental KDE 3.5 packages for Debian SID.
This bug was not present in KDE 3.4.3 I had installed before. Disabling the "align icons to grid" works around this bug so I'm at least able to put the icons back to different monitors, tough not automatically aligned, of course... :-/
Comment 11 Michael Zenke 2006-02-02 13:05:13 UTC
This bug is still "included" in KDE 3.5.1 (Used Gentoo ebuilds)
Comment 12 Eros Candelaresi 2006-02-02 13:06:58 UTC
The same for the (K)ubuntu packages.
Comment 13 Johannes Eberleh 2006-02-05 18:23:16 UTC
I can also confirm this bug - unsupported KDE 3.5.0-29 package for SuSE 10.0.
I am also using xinerama with 2 monitors - same behaviour...
Comment 14 Dmitriy 2006-02-09 00:23:16 UTC
Same thing.  Mandriva 2006, KDE 3.5.1 from thac&ze rpms.
1024x768 (screen2, left) 1600x1200 (screen1, right)
icons can't be moved to the screen2 while "Align to Grid" selected.
If not selected icons can be moved, but after KDE restarts they are moved to screen1 and icons in screen1 shifted to the right also.
Seems like it scales 2624 width of 2 screens to 1600 of screen1 and place icons accordingly.
Comment 15 Johannes Eberleh 2006-02-12 19:59:46 UTC
Created attachment 14661 [details]
This file should be called by autostart

Okay - after playing some time with the dcop routines from kdesktop and
watching the source code from kdesktop and kicker I was able to write a
workaround for this bug.
This bug seems to be caused by a wrong desktop geometry that kicker gives to
kdesktop by the dcop call "desktopIconsAreaChanged".
Now my knowledge in C and the kde-source code is not sufficient to provide a
patch, so I wrote a simple bash script which gets the actual (correct) desktop
geometry from kwin, and sets it by using the same dcop call
"desktopIconsAreaChanged" from kdesktop KDesktopIface. Add this script to
autostart to call it on every system boot.
Comment 16 Rudolf Kollien 2006-02-28 11:30:12 UTC
Can confirm this bug for SuSE RPMs for 9.3 KDE 3.5.1 Level "a".
It's very galling, as i use the second (mostly "window empty" screen) for the fast access to many apps via desktop icons placed there.
Comment 17 Michael Zenke 2006-04-15 00:21:20 UTC
Bug is still present in KDE 3.5.2 (Gentoo Portage)
Comment 18 Michael Zenke 2006-06-12 17:16:10 UTC
and still in 3.5.3...
Comment 19 David Faure 2006-06-23 10:53:57 UTC

*** This bug has been marked as a duplicate of 122001 ***
Comment 20 Michael Zenke 2006-07-12 14:30:35 UTC
With the patch from 122001 Icons still move to Xinerama Screen 1 when KDE starts.
Comment 21 Andrew Ash 2006-08-05 02:56:21 UTC
Still experiencing this bug in Kubuntu, 3.5.4
Comment 22 Michael Prager 2006-08-07 10:29:11 UTC
I can confirm that this bug is _NOT RESOLVED_ in 3.5.4. Running Gentoo here.
Comment 23 Stefan Kiesler 2006-11-16 10:17:15 UTC
And NOT RESOLVED in 3.5.5 / Gentoo.
Comment 24 Thorsten Holtkaemper 2006-12-13 11:08:44 UTC
Also here on SUSE 10.1 with KDE 3.5.5 "release 45.1" this bug is still present.
Comment 25 Thorsten Holtkaemper 2006-12-13 11:29:16 UTC
Same problem seems to be addressed in Bug 132787.
Comment 26 FiNeX 2008-03-08 16:22:15 UTC
*** Bug 117463 has been marked as a duplicate of this bug. ***
Comment 27 FiNeX 2009-01-02 20:31:46 UTC
Bug closed. Kdesktop is no more mantained.