Bug 117550 - xinerama setup: New icons move existing icons when "Align to Grid" is set
Summary: xinerama setup: New icons move existing icons when "Align to Grid" is set
Status: CLOSED DUPLICATE of bug 122001
Alias: None
Product: kdesktop
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-03 00:28 UTC by Phillip Sparks
Modified: 2009-01-02 20:31 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Phillip Sparks 2005-12-03 00:28:32 UTC
Version:            (using KDE KDE 3.5.0)
Installed from:    Gentoo Packages
Compiler:          gcc (GCC) 3.4.4 (Gentoo 3.4.4-r1, ssp-3.4.4-1.0, pie-8.7.8) CBUILD="i686-pc-linux-gnu", CFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer -fforce-addr -momit-leaf-frame-pointer -ftracer", CXXFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer -fforce-addr -momit-leaf-frame-pointer -ftracer -fvisibility-inlines-hidden", LDFLAGS="-Wl,-Ol -Wl,--enable-new-dtags -Wl,--sort-common"
OS:                Linux

After setting "Align to Grid" from the menu, new icons placed on the desktop often move other icons to the side or down.  I ran a series of tests from a term touching test files onto the desktop, I recorded 16 touches in http://www.web-milk.co.uk/icon_placement.txt  I generated files test1 - test16, the numbers on the above text file represent each of the files and their position after each touch.

I also used a loop to generate 60 test$x files and they grouped themselves in the top left corner in no obvious pattern.  I turned off "Align to Grid" and re-ran the loop (after deleting the test files) and they (correctly) positioned themselves from left to right (wrapping at the right edge) across both screens.

I find Align to Grid useful and I hope this can be resolved soon!
Comment 1 Sebastian Kügler 2005-12-12 22:07:53 UTC
I can confirm this bug. Since the upgrade from 3.4.3 to 3.5 I cannot place icons on the secondary screen of my xinerama setup anymore when having "Align to grid" enabled.
Comment 2 David Faure 2006-06-23 10:49:53 UTC

*** This bug has been marked as a duplicate of 122001 ***
Comment 3 Stefan Gehn 2006-12-03 17:12:37 UTC
This is NOT a duplicate of 122001. "Align to grid" not working at all and "Align to grid" forcing icons onto the first xinerama-screen are two completely different problems!
Comment 4 FiNeX 2009-01-02 20:31:51 UTC
Bug closed. Kdesktop is no more mantained.