Bug 122001 - desktop icons align to grid broken
Summary: desktop icons align to grid broken
Status: CLOSED UNMAINTAINED
Alias: None
Product: kdesktop
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal with 131 votes (vote)
Target Milestone: ---
Assignee: Dirk Mueller
URL:
Keywords:
: 116341 117550 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-02-15 04:56 UTC by David Sprehn
Modified: 2009-01-02 20:32 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Sprehn 2006-02-15 04:56:23 UTC
Version:            (using KDE KDE 3.5.1)
Installed from:    Fedora RPMs
OS:                Linux

This seems to be a regression...the problem was fixed in 3.5 but broken again in 3.5.1.  On my desktop, the "align to grid" option has no affect on icons whatsoever.  They don't align, nor do they adjust when I drag them around.  Please fix this, I like my desktop tidy!

Thanks,
--David
Comment 1 Ernesto Benestante 2006-02-19 14:06:55 UTC
This happens to me too (using KDE 3.5.1 on debian/unstable). Even if "Align to Grid" is checked, each time I login they appear quite "unaligned". They are more o less in the place they should be, but not aligned at all.

A momentary workaround is: 
1- open the Configure Desktop dialog and go to the Behaviour tab.
2- uncheck "Show icons on desktop".
3- Click Apply.
4- Check again "Show icons on desktop".
5- Click Apply.

and your icons will be correctly aligned... until you logout.

Comment 2 Rodrigo S de Castro 2006-02-20 12:15:56 UTC
The same problem here (KDE 3.5.1 on debian/unstable). Alignment doesn't work at all, unless you use the workaround proposed by Ernesto for the current session.
Comment 3 Eric M. Smith 2006-03-29 22:11:25 UTC
Similar problem here (FC5), but with a dual head system (ATI card and Drivers from livna) running Xinerama.  Icons on Desktop 1 (the notebook's 1280x800 display) align properly and snap back in place when moved.  Icons on Desktop 2 (separate 1280x1024 monitor) don't align or snap back when moved.  Only when Ernesto's workaround is used do they align.
Comment 4 Michael Prager 2006-04-07 13:07:44 UTC
I can confirm the problem. Using dual head, the align to grid option doesn't work for desktop2. Running kde 3.5.2 on gentoo linux here.
Comment 5 Antonio 2006-04-10 13:33:28 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 Ricardo Correia 2006-04-24 20:39:35 UTC
Confirmed in single head kde 3.5.2 on gentoo linux.
Comment 7 Neil Derraugh 2006-05-11 18:59:37 UTC
Ditto for 3.5.2 on gentoo again, single-head.  Ernesto's fix works too.
Comment 8 Alexandre Courtois 2006-05-15 00:11:07 UTC
Same problem with 3.5.2 under ArchLinux.
Comment 9 Mark Wehner 2006-05-17 09:49:01 UTC
The bug seems in some way related to the config option 
UseXineramaScreen in ~/kde/share/config/kickerrc.
If I set this to 0 the symbols are perfectly after restarting kde,
but the option it changed back to -1, which messes up the order for
the next restart.
Comment 10 Gilboa Davara 2006-05-20 20:21:09 UTC
Same here.
Problem only appears when xinerama is enabled.

FC5/KDE 3.5.2/x86_64 based on kde-redhat's SRPMs.
Comment 11 Gilboa Davara 2006-05-21 11:40:33 UTC
I've been able to reproduce this on Xinearama-less (single-head) KDE 3.5.2 machine.

Ernesto (#2) solution seems to work just fine.
Comment 12 Alexander 2006-06-03 15:21:52 UTC
Same problem with kde 3.5.2, debian testing: when I'm checking option Alihn to grid it takes no effect to desktop.
Comment 13 Alexander 2006-06-21 13:37:39 UTC
Still have this problem after upgrading to 3.5.3
Comment 14 Dirk Mueller 2006-06-23 02:14:37 UTC
SVN commit 554047 by mueller:

fix align-to-grid option which regressed due to the startup performance
patches. 
BUG: 122001
BUG: 127672
BUG: 114766
BUG: 117952


 M  +9 -0      desktop.cc  


--- branches/KDE/3.5/kdebase/kdesktop/desktop.cc #554046:554047
@@ -735,6 +735,15 @@
     // hurra! kicker is alive
     if ( m_waitForKicker ) m_waitForKicker->stop();
 
+    // -2: all screens
+    // -1: primary screen
+    // else: screen number
+
+    if (screen <= -2)
+       screen = kdesktop_screen_number;
+    else if (screen == -1)
+       screen = kapp->desktop()->primaryScreen();
+
     if ( (screen == kdesktop_screen_number) && m_pIconView )
         m_pIconView->updateWorkArea(area);
 }
Comment 15 David Sprehn 2006-06-23 07:39:53 UTC
Thank you very much for fixing this problem!!!  :-)

Dirk Mueller wrote:

[bugs.kde.org quoted mail]
Comment 16 Alexander 2006-06-23 10:31:19 UTC
Thanks, working fine! 
Comment 17 David Faure 2006-06-23 10:49:55 UTC
*** Bug 117550 has been marked as a duplicate of this bug. ***
Comment 18 David Faure 2006-06-23 10:54:06 UTC
*** Bug 116341 has been marked as a duplicate of this bug. ***
Comment 19 Clive Messer 2006-06-23 11:42:23 UTC
Verified that this resolves the issue for me on a twinview setup with Xinerama. Thankyou.
Comment 20 Davide 2006-06-28 12:43:12 UTC
I still have the same problem, even after patching sources.
I'm running TwinView on Slackware current.
Comment 21 Davide 2006-06-28 12:44:57 UTC
I'm running KDE 3.5.3
Comment 22 Chris Nicola 2006-07-28 21:54:56 UTC
Still finding this problem on Kubuntu Dapper

kdesktop --version
Qt: 3.3.6
KDE: 3.5.3
KDesktop: 3.5.3
Comment 23 Alexander 2006-08-22 12:34:44 UTC
Hm, sometimes, when I'm inserting DVD in the drive, the line "XineramaScreen=-1" is appearing in file ~/.kde/share/config/kickerrc and function "Align to Grid" stops working. If I delete this line, it begins to work again. Why it is so?
Kde 3.5.3, debian testing.
Comment 24 Alexander 2006-08-22 12:36:57 UTC
I forget to say that I have only one display.
Comment 25 David Sprehn 2006-08-23 17:27:39 UTC
Thank you very much Alexander!  You seem to have located the problem.  I found the same line (XineramaScreen=-1), and after deleting it and issuing "dcop kicker kicker restart" the icons behave again!  Incidentally, I also have only one screen and am not running xinerama.  KDE Developers: this clue might make the problem easier to fix.
Comment 26 Stefan Kiesler 2006-11-16 10:34:35 UTC
Is this supposed to be fixed in 3.5.5? If so, I suggest reopening this bug.
I just installed 3.5.5 in hope that this annoying "align to grid" bug has been fixed, but I still experience problems in my xinerama setup even after wiping out my ~/.kde directory.
I let the wizard create a clean configuration, but icons could only be placed and aligned on xinerama screen 1 (which is my right screen at 1024x768; my left screen is 1280x1024). When I disable "align to grid", I can move icons to screen 2, but as soon as I enable "align to grid", they jump back to screen 1.
Sometimes enabling "align to grid" doesn't even work on screen 1. Moving the taskbar from screen 2 back to the default screen 1 also forces the icons back to screen 1 and makes "align to grid" work again (for screen 1 only).

Pleeeeeaaaaase fix this. KDE is wonderful, but this one's just so annoying...
Comment 27 Jo Schulze 2007-01-11 13:53:18 UTC
This isn't fixed/broken again in kde 3.5.5 (Twinview, X86_64, openSUSE 10.1)
$ kdesktop --version
Qt: 3.3.7
KDE: 3.5.5 "release .2"
KDesktop: 3.5.5

Comment 28 Jo Schulze 2007-01-12 21:09:23 UTC
This is definitly related to twinview (more than 1 X11 screen per display device) since the same sw release does work perfectly well when only one screen is configured.
Comment 29 peppelorum 2007-02-01 21:04:13 UTC
Seems like this is quite not fixed;-)
So I vote for a reopening of this one.

Using debian testing/sid and twinview.
peppe@hoth ~: kdesktop --version
Qt: 3.3.7
KDE: 3.5.5
KDesktop: 3.5.5
Comment 30 David Faure 2007-02-02 14:39:52 UTC
Reopening as requested
Comment 31 Emilio Scalise 2007-04-15 12:47:35 UTC
I can confirm this on debian etch 4.0 with kde 3.5.5 and Kubuntu Edgy with kde 3.5.6 and nvidia twinview.

Comment 32 Marc Schiffbauer 2007-04-15 17:00:23 UTC
Lets hope for KDE4 as noone seems to be interested in fixing this mess in the 3.5 branch.
Comment 33 Martin Koller 2007-05-05 20:25:43 UTC
I'm running here on Suse-9.3 with current KDE compiled from source (> 3.5.6) and here it works. I run my X server in Xinerama mode with 2 screens (left=1:1400x1050 and right=2:1280x1024) and can enable/disable aligning to grid without problems. Even moving kicker from one screen to the other does not force any Icons jump to the other screen.
Comment 34 Emilio Scalise 2007-05-05 20:36:10 UTC
The problem is that if you enable align to grid you can't place icons on one of the two screens.. Try that..
Comment 35 Stefan Kiesler 2007-08-15 18:10:44 UTC
Seems to be fixed in KDE 3.5.7, at least it's now working on my Gentoo system...
Comment 36 FiNeX 2008-12-10 02:07:15 UTC
Kdesktop is no more mantained. Fortunatly this bug seems not to be valid for KDE 4. Please reopen if this bug is not a kdesktop one (and it is not solved) or it can be reproduced on KDE 4.
Comment 37 FiNeX 2009-01-02 20:32:18 UTC
Bug closed. Kdesktop is no more mantained.