Bug 79924

Summary: No Sound Notifications, but Sound System is Working
Product: kdelibs Reporter: Georg Wittenburg <georg.wittenburg>
Component: knotifyAssignee: Carsten Pfeiffer <pfeiffer>
Status: RESOLVED DUPLICATE    
Severity: normal CC: andreas.bergen, davidpjames, decibelshelp, gj.eldering, kde, Mathias.Homann, rui.m.malheiro
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Debian testing   
OS: Linux   
Latest Commit: Version Fixed In:

Description Georg Wittenburg 2004-04-19 00:18:18 UTC
Version:            (using KDE KDE 3.2.2)
Installed from:    Debian testing/unstable Packages

Sound is working fine in the "Sound System" KCM, when I hit "Test Sound" (using the ALSA output device with 48000Hz and 16 bits to keep the dmix plugin happy). When I switch over to the "System Notifications" KCM and click on the play button, I get no sound. Of course, when using KDE I get no sound from any system notification.

A work-around is to use "artsplay" as external player, which is working fine.
Comment 1 David P James 2004-04-25 20:59:20 UTC
I had this problem following an upgrade to 3.2.1 - try either creating a new user or moving your .kde out of the way. That solved it for me. I then moved back the various config files for the my apps into the new .kde.
Comment 2 Georg Wittenburg 2004-04-30 02:32:44 UTC
This would imply that there is a problem with knotifyrc, right? If it helps, mine looks like this:

[Misc]
External player=artsplay
LastConfiguredApp=KDE System Notifications
Use external player=true
Volume=100

[StartProgress]
Arts Init=false
KNotify Init=true
Use Arts=false

Removing the external player in the KCM doesn't work (there's another bug report related to this out there). To reproduce the current bug however, change "Use external player" to "false".
Comment 3 Jason Ahrens 2004-05-04 19:13:50 UTC
I had the same problem after upgrading. I removed knotifyrc and *.eventsrc and sound started working properly again.
Comment 4 Georg Wittenburg 2004-05-10 16:46:01 UTC
This solved the problem for me, too, after restarting KDE.

I'll leave the bug open for now, 'cause this is more a workaround than a solution to the underlying problem. It's really up to the maintainer to make up his mind whether this is worth fixing.

Thanks for your help, folks! :)
Comment 5 Jason Salaz 2004-05-13 04:10:12 UTC
If you change the ArtsInit and UseArts to true, you will be able to get your sound back without erasing the files.  This issue appears also after disabling the Sound sever, applying the changes, and then reenabling it, and saving the changes.  It appears that the file is not updated when you reenable the sound server, so both settings will stay false.

Might want to check the code in the enable sound system, and make sure that it gets updated properly.
Comment 6 Jason Salaz 2004-05-13 13:20:47 UTC
I've went ahead and looked over knotify.cpp, and I don't really see any problems, but maybe that's because I'm not really fluent in C++.  But one thing I found was intersting was your handling of the ARts server crashing, and how the procedure seems to set UseArts and ArtsInit to false by default, if the server crashes.  Also, at what point is the Apply button mentioned in the file?  I see that you have a procedure to 'sync' knotifyrc, but not an actual save for it.

Is this called from amother file?

Just wondering...

-Jason
Comment 7 Michael Denio 2004-08-26 22:31:13 UTC
I have the same problem but I'm not using alsa.  I'm using threaded OSS.
Comment 8 Allan Sandfeld 2004-08-27 00:48:56 UTC
I have the same problem, but deleting knotifyrc does not solve the issue.
Comment 9 David 2004-09-28 02:59:47 UTC
Have noticed about 3 bugs in kde bugzilla on this and other places around the net for quite awhile. Ran into the issue myself on kde-3.2 and 3.3.

Had to edit knotifyrc manually. 

With trying to make Linux more Desktop friendly, not having sound (some users don't think they have sound when the system notifications aren't working is why saying this) and using the gui (kcontrol) to fix it to no avail, is an issue. 
Comment 10 H.H. 2004-10-06 00:45:44 UTC
I have the same problem
Comment 11 Zoltan Dudas 2004-12-08 16:00:29 UTC
Hi all,
I also have the same problem.
Is there any solution since October ?

Dod
Comment 12 Rudolf Kollien 2004-12-13 21:35:24 UTC
I now have the problem after updating my KDE. 

SuSE 9.2, Kernel 2.6.8-24.5-default, using alsa. Since my update of 10. December 2004 to 3.3.2 level "a", arts-1.3.2-3 i don't hear any system notification sound. Any other arts related apps (as xmms with arts plugin) play sound. 

Again: This issue come up AGAIN after the "10.Dec.2004-Update" of only the arts-RPMs(!!!!!). This happend on SuSE 9.1 AND on SuSE 9.2 with the new arts RPMs. So i can say the knotifyrc is ok. Maybe this is an arts-related problem, my be this is a SuSE problem. But only system notifications don't work anymore. All other apps using arts are ok. 
Comment 13 Allan Sandfeld 2004-12-17 00:23:46 UTC
*** Bug 95271 has been marked as a duplicate of this bug. ***
Comment 14 Mathias Homann 2004-12-17 00:46:06 UTC
same here. also, konfiguring an external player app (artsplay) did not help.
Comment 15 Mike Burkhardt 2004-12-17 21:46:44 UTC
Same here. (Suse Linux 9.2) An external player does not work for me eihter. This all happened after updating my KDE to 3.3.2
If you type in kdeinit knotify (command line) it will work for the moment but not after you have restarted your computer.
Comment 16 Mathias Homann 2004-12-17 22:07:39 UTC
for me (SuSE 9.1, kde 3.3.2 "a" as suse labels it) not even the kdeinit knotify workaround helps.
Comment 17 Thiago Macieira 2004-12-17 22:20:29 UTC
I've had this same problem just now with KNotify. Rebuilding it after updating the CVS helped.

It seems some bug crept into HEAD and may have been backported to 3.3.2. 3.4 Alpha 1 may be affected as well.
Comment 18 Thiago Macieira 2004-12-18 01:13:52 UTC
*** Bug 95374 has been marked as a duplicate of this bug. ***
Comment 19 Thiago Macieira 2004-12-24 17:50:49 UTC
*** Bug 95772 has been marked as a duplicate of this bug. ***
Comment 20 Gerrit Jan 2004-12-24 18:08:26 UTC
I have try to add knotifyrc, but no result on suse 9.2
Comment 21 Guenter Gehl 2004-12-30 12:07:47 UTC
same situation as at Rudolf, but with Suse9.1 and upgrading kde to 3.2.2 level "a".
restarting knotify with "kdeinit knotify" helps partially, but then knotify crashes when shutting down kde
Comment 22 Stephan Binner 2005-01-02 14:01:50 UTC

*** This bug has been marked as a duplicate of 69830 ***
Comment 23 Guenter Gehl 2005-01-03 20:20:49 UTC
Sorry, but I'm afraid it's not a duplicate of 69830.
my knotifyrc contains:
 [StartProgress]
  Arts Init=true
  KNotify Init=true
  Use Arts=true

starting up kde file .xsession-errors collects the following error messages. I'm not so familar with kde internals, but may be here is the problem. 

kbuildsycoca running...
DCOP Cleaning up dead connections.
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x8257260 ): KAccelobject already contains an action name "del"
...



Comment 24 John Griffiths 2005-01-13 17:31:26 UTC
Add my SuSE 9.2 sound failure to the group after upgrading to kde 3.3.2.

The bug status is closed. It should be changed to open since there are several reports of the failure again. 
Comment 25 Gerrit Jan 2005-01-16 10:27:28 UTC
Update to KDE 3.3.91 (beta1) on SuSE 9.2, with update's off alsa & arts, have no succes. (apt-get) 
Soundcard is oke, but no systemsound! 
Comment 26 zen8486 2005-01-17 18:04:42 UTC
Adding my desire to see this bug re-opened.  Have SuSE 9.1 Pro and this bug manifested when updating KDE to 3.3.2 "a" in early December 2004.
Comment 27 AJ Sommer 2005-01-26 00:09:49 UTC
This bug is not a KDE problem... Its actually a problem with the arts-RPMs build for SuSE!

The problem is that arts aparently uses some gnome-libraries and the guy building the SuSE-arts-RPMs seems to have a different version of gnome installed than the one, that comes with SuSE 9.1 (in my case). Arts then returns an error because of an undefined reference to g_assert_warning.

I just compiled the arts sources (1.3.2) and everything works fine. :-)
Comment 28 David 2005-01-26 02:04:07 UTC
Happens when you compile from source also sometimes. Haven't had it for
awhile because been using the same KDE that fixed and haven't upgraded
KDE for awhile. Comment #9 was compiled from source: Gentoo.
Comment 29 Allan Sandfeld 2005-01-26 11:27:14 UTC
Also some new >=3.3 cases might be related to #97856
Comment 30 Rui Malheiro 2005-02-02 23:26:59 UTC
knotify has no sound after startup using kde-3.3.91_20050201 and arts-1.3.91_20050201 on SuSE 9.2, updated using apt-get from suse-people. Restarting knotify (with "kdeinit knotify") works around the problem.

This bug should be reopened as it is *not* a duplicate of bug #69830. If it's a problem with SuSE's libraries, it's strange it only happens during startup, no errors on restart.
Comment 31 Stephan Binner 2005-02-03 08:30:49 UTC
> This bug should be reopened

No, 94918 exists.
Comment 32 Rui Malheiro 2005-02-03 13:22:06 UTC
You're right. Actualy this bug's comments cover two different problems and the original one seems to be about bug #69830. Sorry for the noise.

I'll just head to bug #94918 which covers the problem with knotify and arts >1.3.2.
Comment 33 Gerrit Jan 2005-03-05 11:20:16 UTC
Afters update to KDE 3.4.0-1 still no systemsounds !!!!!
Use SuSELinux 9.2
When restore the KDE from the SuSE 9.2 DVD it's working well.
Comment 34 Gerrit Jan 2005-03-16 13:43:41 UTC
Still no systemsound ???
Just update to KDE 3.4.0-12.
This is the stable release,now on ftp.
Comment 35 Gerrit Jan 2005-03-22 15:18:13 UTC
Look here bug #94918 for a fix!