Bug 405570

Summary: Notifications are often cut off
Product: plasmashell Reporter: Christian Muehlhaeuser <muesli>
Component: NotificationsAssignee: Kai Uwe Broulik <kde>
Status: RESOLVED FIXED    
Severity: normal CC: bugseforuns, filipfila.kde, nate, plasma-bugs
Priority: NOR    
Version: 5.15.3   
Target Milestone: 1.0   
Platform: Archlinux Packages   
OS: Linux   
Latest Commit: Version Fixed In: 5.16.0
Attachments: notification from discover on neon dev unstable

Description Christian Muehlhaeuser 2019-03-17 17:50:07 UTC
SUMMARY

Notifications are often shown with only the caption visible, the rest is being cut off vertically.

STEPS TO REPRODUCE
1. Unknown, it works 90% of the time, but every other notification is cut off.

KDE Frameworks Version: 5.56.0
Qt Version: 5.12.2
Comment 1 Nate Graham 2019-03-17 23:42:23 UTC
Please attach a screenshot.
Comment 2 Christian Muehlhaeuser 2019-03-18 11:56:25 UTC
I'm afraid it's impossible for me to capture a screenshot of the issue. This would require me to keep spectacle running 24/7, and as mentioned in its bug reports, that brings my entire system to a halt after a couple of minutes.

Is there a way to change how long notifications will be shown, so I can start spectacle only when such a notification is shown?
Comment 3 Nate Graham 2019-03-18 13:57:41 UTC
Hmm, maybe Kai knows? Either way, hopefully the upcoming notifications rewrite will solve this. :)
Comment 4 Patrick Silva 2019-03-18 15:33:40 UTC
Created attachment 118887 [details]
notification from discover on neon dev unstable

notification from Discover is broken on neon dev unstable.

Operating System: KDE neon Developer Edition
KDE Plasma Version: 5.15.80
KDE Frameworks Version: 5.57.0
Qt Version: 5.12.0
Comment 5 Nate Graham 2019-03-18 15:34:47 UTC
Thanks Patrick, that's very helpful.
Comment 6 Christian Muehlhaeuser 2019-03-18 16:41:30 UTC
Patrick Silva: nice catch! That's pretty much what it looks like here, as well (for example for some notifications triggered by Firefox)
Comment 7 Nate Graham 2019-03-27 19:45:50 UTC
*** Bug 402399 has been marked as a duplicate of this bug. ***
Comment 8 Kai Uwe Broulik 2019-05-09 09:33:08 UTC
Git commit 3c52fc3bc05e0f351d4998ad54edae1a4e21a043 by Kai Uwe Broulik.
Committed on 09/05/2019 at 09:29.
Pushed by broulik into branch 'master'.

Merge branch 'broulik/libnotificationmanager'

This includes:
libnotificationmanager https://phabricator.kde.org/D20265
New notification plasmoid: https://phabricator.kde.org/D20266
as well as dataengine compat: https://phabricator.kde.org/D20490 and https://phabricator.kde.org/D20491
Related: bug 222470, bug 402144, bug 391646, bug 401819, bug 400811, bug 392669, bug 390143, bug 390864, bug 374099, bug 360990, bug 346458, bug 398926, bug 390152, bug 342355, bug 402391, bug 399697, bug 400871, bug 398580
FIXED-IN: 5.16.0


https://commits.kde.org/plasma-workspace/3c52fc3bc05e0f351d4998ad54edae1a4e21a043