Bug 402399 - Notification placement is wrong sometimes
Summary: Notification placement is wrong sometimes
Status: RESOLVED DUPLICATE of bug 405570
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Notifications (show other bugs)
Version: 5.14.4
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Kai Uwe Broulik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-21 00:39 UTC by Filip Fila
Modified: 2019-03-27 19:45 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Bad notification placement (71.50 KB, image/png)
2018-12-21 00:39 UTC, Filip Fila
Details
plasma 5.15.3 on Arch linux (27.14 KB, image/png)
2019-03-27 14:34 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Fila 2018-12-21 00:39:10 UTC
Created attachment 117037 [details]
Bad notification placement

SUMMARY
Notifications are sometimes spawned in the wrong position, resulting in a) a portion of the notification being cut off and b) an empty blurred region

STEPS TO REPRODUCE
No clear-cut way to reproduce it that I know of, my apologies, it seems to happen randomly from time to time. 

OBSERVED RESULT
Wrong notification position.

EXPECTED RESULT
Proper notification position.

SOFTWARE/OS VERSIONS 
Linux/KDE Plasma: Manjaro 
KDE Plasma Version: 5.14.4
KDE Frameworks Version: 5.52.0
Qt Version: 5.11.2

ADDITIONAL INFORMATION
Visual proof is attached.
Comment 1 David Edmundson 2018-12-21 00:40:24 UTC
Which plasma theme?
Comment 2 Krešimir Čohar 2018-12-21 00:43:09 UTC
I get the same problem when I open up Spotify or some other media player and switch tracks really fast, it eventually shows up.

And I get it regardless of the theme I'm using (mostly Breath though, by Manjaro)
Comment 3 Krešimir Čohar 2018-12-21 00:47:46 UTC
P.S. Just to clarity I don't get it just when I'm skipping tracks, it's just the only surefire way of reproducing it that I know of (and even with all the skipping, it takes a long time for it to show up). But it happens with all kinds of other notifications too.
Comment 4 Krešimir Čohar 2018-12-21 00:55:57 UTC
(In reply to Rooty from comment #3)
> P.S. Just to clarity I don't get it just when I'm skipping tracks, it's just
> the only surefire way of reproducing it that I know of (and even with all
> the skipping, it takes a long time for it to show up). But it happens with
> all kinds of other notifications too.

clarify* 

Oh, and this happens with the built-in notification widget and with custom ones from the KDE store
Comment 5 Filip Fila 2018-12-21 01:04:00 UTC
(In reply to David Edmundson from comment #1)
> Which plasma theme?

Yes, we're not sure if it's theme specific. In the screenshot I uploaded the theme was Arc-Color (part of the "Arc KDE" package).

With that theme I (rarely) also got a cut off wi-fi notification when I logged in:
https://i.ibb.co/FbvGZ0Q/Whats-App-Image-2018-12-21-at-01-57-13.jpg

I've also dug up Rooty's screenshots with his Breath (or maybe Breeze AlphaBlack, he's not sure) theme:
https://i.ibb.co/7KqTTMD/Whats-App-Image-2018-12-07-at-16-48-34.jpg
https://i.ibb.co/MDtL4hH/Whats-App-Image-2018-12-07-at-03-03-26.jpg

I'm going to test with stock Breeze to see if it occurs with it.
Comment 6 Filip Fila 2018-12-21 11:56:46 UTC
Caught the bugger with Breeze, albeit weirdly manifested: https://i.ibb.co/smKMDMn/Screenshot-20181221-125438.png
Comment 7 Patrick Silva 2019-03-26 22:14:04 UTC
bug 388601 is related/duplicate
Comment 8 Filip Fila 2019-03-26 22:49:27 UTC
(In reply to Patrick Silva from comment #7)
> bug 388601 is related/duplicate

Perhaps there is a similar or same underlying cause, but for now we cannot treat it a as duplicate. This bug here was reproduced with 1x scaling.

Notifications will most likely get a total redesign in 5.16 anyway so we will then have to reevaluate the statuses of our bug reports.
Comment 9 Patrick Silva 2019-03-27 14:34:03 UTC
Created attachment 119082 [details]
plasma 5.15.3 on Arch linux

It happened a few minutes ago on my system without fractional display scaling.

Operating System: Arch Linux 
KDE Plasma Version: 5.15.3
KDE Frameworks Version: 5.56.0
Qt Version: 5.12.2
Comment 10 Nate Graham 2019-03-27 19:45:50 UTC

*** This bug has been marked as a duplicate of bug 405570 ***