Bug 320220

Summary: okular crashes when opening any pdf
Product: [Applications] okular Reporter: klmueller23
Component: generalAssignee: Okular developers <okular-devel>
Severity: crash CC: aacid
Priority: NOR    
Version: 0.16.2   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description klmueller23 2013-05-24 15:00:35 UTC
Application: okular (0.16.2)
KDE Platform Version: 4.10.2 "release 1"
Qt Version: 4.8.4
Operating System: Linux 3.7.10-1.4-desktop x86_64
Distribution: "openSUSE 12.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
okular consistently crashes no matter what I did before starting. It only crashes when you directly try to open a pdf (e.g from command line or browser) but will work when started alone and then open the pdf or when started from dolphin file manager. Tried it with many different pdfs and it does not depend on the pdf file.

The crash can be reproduced every time.

-- Backtrace:
Application: Okular (okular), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f980235c3d5 in raise () from /lib64/libc.so.6
#7  0x00007f980235d858 in abort () from /lib64/libc.so.6
#8  0x00007f9802ccec54 in qt_message_output (msgType=<optimized out>, buf=<optimized out>) at global/qglobal.cpp:2323
#9  0x00007f9804415a06 in QDebug::~QDebug (this=0x7fff99eb5d60, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:85
#10 0x00007f98044f29d7 in KApplicationPrivate::init (this=0xd454d0, GUIenabled=GUIenabled@entry=true) at /usr/src/debug/kdelibs-4.10.2/kdeui/kernel/kapplication.cpp:516
#11 0x00007f98044f39c8 in KApplication::KApplication (this=0x7fff99eb6270, GUIenabled=true) at /usr/src/debug/kdelibs-4.10.2/kdeui/kernel/kapplication.cpp:352
#12 0x0000000000408903 in main (argc=<optimized out>, argv=0x7fff99eb63a8) at /usr/src/debug/okular-4.10.2/shell/main.cpp:56

Possible duplicates by query: bug 318467, bug 314342, bug 306037, bug 301897.

Reported using DrKonqi
Comment 1 klmueller23 2013-05-24 15:05:14 UTC
I tried it again and it crashes even without opening an pdf. Calling okular from the bash in xterm crashes it.
Comment 2 Albert Astals Cid 2013-05-24 15:08:12 UTC
And the message you get in the terminal is?
Comment 3 Jekyll Wu 2013-05-24 20:59:49 UTC
The backtrace implies your dbus session is not running.
Comment 4 Christoph Feck 2013-06-15 22:08:40 UTC

*** This bug has been marked as a duplicate of bug 270442 ***