Bug 297468

Summary: Kmail crashed after viewing 20+emails and switching to the next
Product: [Applications] kontact Reporter: Chris <crglasoe>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Chris 2012-04-04 13:14:16 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.1 (4.8.1) "release 483"
Qt Version: 4.8.0
Operating System: Linux 3.1.9-1.4-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
I had almost given up on Kontact/Kmail because it simply was not working.  Too many issue to list.  I decided to give it one more try.  Although I have progressed further than any other time in the last 3 months it is still not ready for prime time.  I am not a developer and I don't want to disparage their efforts.  I do want to say though that this seems to be a project that should not have been released to the public.  Simple task such as moving from one email to the next should not  cause a crash.  I will come back and try Kontact/Kmail again at some point in the future because there are many aspects of the package that are better than anything else available.  But in the mean time I will continue to use TB.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f959a39f760 (LWP 9221))]

Thread 9 (Thread 0x7f957bdcb700 (LWP 9224)):
#0  0x00007f959222ee6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9596bbcc12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f9596bbcc49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f959222af05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f95978ae10d in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f957b4ca700 (LWP 9225)):
#0  0x00007f95978a4ff3 in poll () from /lib64/libc.so.6
#1  0x00007f9591d1ba98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9591d1bf59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f959801b526 in QEventDispatcherGlib::processEvents (this=0x7f95740008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f9597feb272 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9597feb4c7 in QEventLoop::exec (this=0x7f957b4c9e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9597eec137 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f9597eef15b in QThreadPrivate::start (arg=0x644110) at thread/qthread_unix.cpp:298
#8  0x00007f959222af05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f95978ae10d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f9526a84700 (LWP 10257)):
#0  0x00007f959222f1eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9597eef5cf in wait (time=30000, this=0x156c9c0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x156c938, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9597ee29df in QThreadPoolThread::run (this=0x157e570) at concurrent/qthreadpool.cpp:141
#4  0x00007f9597eef15b in QThreadPrivate::start (arg=0x157e570) at thread/qthread_unix.cpp:298
#5  0x00007f959222af05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f95978ae10d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f95275bf700 (LWP 10259)):
#0  0x00007f959222f1eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9597eef5cf in wait (time=30000, this=0x1c75da0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1df3418, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9597ee29df in QThreadPoolThread::run (this=0x1df6a20) at concurrent/qthreadpool.cpp:141
#4  0x00007f9597eef15b in QThreadPrivate::start (arg=0x1df6a20) at thread/qthread_unix.cpp:298
#5  0x00007f959222af05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f95978ae10d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f9516ba2700 (LWP 10266)):
#0  0x00007f959222f1eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9597eef5cf in wait (time=30000, this=0x1838dc0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1918078, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9597ee29df in QThreadPoolThread::run (this=0x7f9520022c60) at concurrent/qthreadpool.cpp:141
#4  0x00007f9597eef15b in QThreadPrivate::start (arg=0x7f9520022c60) at thread/qthread_unix.cpp:298
#5  0x00007f959222af05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f95978ae10d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f952e1a1700 (LWP 10284)):
#0  0x00007f959222f1eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9597eef5cf in wait (time=30000, this=0x1838dc0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1918078, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9597ee29df in QThreadPoolThread::run (this=0x7f9504014df0) at concurrent/qthreadpool.cpp:141
#4  0x00007f9597eef15b in QThreadPrivate::start (arg=0x7f9504014df0) at thread/qthread_unix.cpp:298
#5  0x00007f959222af05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f95978ae10d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f9517f51700 (LWP 10286)):
#0  0x00007f959222f1eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9597eef5cf in wait (time=30000, this=0x1838dc0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1918078, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9597ee29df in QThreadPoolThread::run (this=0x1839000) at concurrent/qthreadpool.cpp:141
#4  0x00007f9597eef15b in QThreadPrivate::start (arg=0x1839000) at thread/qthread_unix.cpp:298
#5  0x00007f959222af05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f95978ae10d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f95163a1700 (LWP 10288)):
#0  0x00007f959222f1eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9597eef5cf in wait (time=30000, this=0x1838dc0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1918078, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9597ee29df in QThreadPoolThread::run (this=0x7f9520006370) at concurrent/qthreadpool.cpp:141
#4  0x00007f9597eef15b in QThreadPrivate::start (arg=0x7f9520006370) at thread/qthread_unix.cpp:298
#5  0x00007f959222af05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f95978ae10d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f959a39f760 (LWP 9221)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x547c000, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f95931f4fc9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x547c000, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f95980054f6 in QObject::event (this=0x547c000, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f95989fdd84 in notify_helper (e=0x7f951c007b00, receiver=0x547c000, this=0x639230) at kernel/qapplication.cpp:4550
#10 QApplicationPrivate::notify_helper (this=0x639230, receiver=0x547c000, e=0x7f951c007b00) at kernel/qapplication.cpp:4522
#11 0x00007f9598a02c03 in QApplication::notify (this=0x7fff6e038140, receiver=0x547c000, e=0x7f951c007b00) at kernel/qapplication.cpp:4411
#12 0x00007f9599741656 in KApplication::notify (this=0x7fff6e038140, receiver=0x547c000, event=0x7f951c007b00) at /usr/src/debug/kdelibs-4.8.1/kdeui/kernel/kapplication.cpp:311
#13 0x00007f9597fec48c in QCoreApplication::notifyInternal (this=0x7fff6e038140, receiver=0x547c000, event=0x7f951c007b00) at kernel/qcoreapplication.cpp:876
#14 0x00007f9597fefd2a in sendEvent (event=0x7f951c007b00, receiver=0x547c000) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60da60) at kernel/qcoreapplication.cpp:1500
#16 0x00007f959801b093 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f9591d1b58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f9591d1bd88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f9591d1bf59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f959801b4bf in QEventDispatcherGlib::processEvents (this=0x60d320, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f9598aa0dee in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f9597feb272 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f9597feb4c7 in QEventLoop::exec (this=0x7fff6e0380d0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f9597ff0025 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403919 in ?? ()
#27 0x00007f95977f423d in __libc_start_main () from /lib64/libc.so.6
#28 0x0000000000403e51 in _start ()

Possible duplicates by query: bug 297174, bug 297059, bug 296901, bug 296658, bug 296624.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-04-04 20:16:42 UTC

*** This bug has been marked as a duplicate of bug 286307 ***