Bug 294767

Summary: Muon chrashed on start
Product: kde Reporter: morgan <morgan.hugo>
Component: generalAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: adaptee
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description morgan 2012-02-24 19:23:43 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: sa se lançe tranquillement mais au bout d'un moment l'ordinateur est lent puis le logiciel plante.

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb771b930 (LWP 3180))]

Thread 2 (Thread 0xb568ab70 (LWP 3184)):
#0  0x006c2d12 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x0041e7d5 in do_gettime (frac=0xb568a020, sec=0xb568a018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x004f14b6 in QTimerInfoList::updateCurrentTime (this=0x911978c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x004f180a in QTimerInfoList::timerWait (this=0x911978c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x004f0053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb568a12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x004f00ed in timerSourcePrepare (source=0x9119758, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0395288c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x03953637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x03953c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x004f0b37 in QEventDispatcherGlib::processEvents (this=0x9110c38, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x004c11dd in QEventLoop::processEvents (this=0xb568a2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x004c1421 in QEventLoop::exec (this=0xb568a2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x003c490b in QThread::exec (this=0x91160b0) at thread/qthread.cpp:498
#14 0x004a1e2d in QInotifyFileSystemWatcherEngine::run (this=0x91160b0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x003c77b3 in QThreadPrivate::start (arg=0x91160b0) at thread/qthread_unix.cpp:331
#16 0x006dfd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x01ff60ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb771b930 (LWP 3180)):
[KCrash Handler]
#7  0x0041be11 in QtPrivate::QStringList_contains (that=0xbfd50054, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd50054) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8fc5490) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8fc5490, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd50274) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x004c8b7d in metacall (argv=0xbfd50274, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8fc5490) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8fc5490, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfd50274) at kernel/qmetaobject.cpp:232
#13 0x004d7a6a in QMetaObject::activate (sender=0x8fc66d8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8fc66d8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8fc66d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd503b8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x004c8b7d in metacall (argv=0xbfd503b8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8fc66d8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8fc66d8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfd503b8) at kernel/qmetaobject.cpp:232
#18 0x004d7a6a in QMetaObject::activate (sender=0x8fc5490, m=0x80950c0, local_signal_index=0, argv=0xbfd503b8) at kernel/qobject.cpp:3278
#19 0x00bd37c5 in MuonMainWindow::backendReady (this=0x8fc5490, _t1=0x90233b0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00bd3933 in MuonMainWindow::initObject (this=0x8fc5490) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8fc5490) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8fc5490, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd504e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x004c8b7d in metacall (argv=0xbfd504e4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8fc5490) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8fc5490, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfd504e4) at kernel/qmetaobject.cpp:232
#25 0x004d7a6a in QMetaObject::activate (sender=0x9012bf8, m=0x5f8238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x004df375 in QSingleShotTimer::timeout (this=0x9012bf8) at .moc/release-shared/qtimer.moc:82
#27 0x004df42c in QSingleShotTimer::timerEvent (this=0x9012bf8) at kernel/qtimer.cpp:308
#28 0x004da994 in QObject::event (this=0x9012bf8, e=0xbfd508dc) at kernel/qobject.cpp:1181
#29 0x059c9d84 in notify_helper (e=0xbfd508dc, receiver=0x9012bf8, this=0x8eb46b8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8eb46b8, receiver=0x9012bf8, e=0xbfd508dc) at kernel/qapplication.cpp:4458
#31 0x059cf133 in QApplication::notify (this=0xbfd508dc, receiver=0x9012bf8, e=0xbfd508dc) at kernel/qapplication.cpp:3886
#32 0x0104f971 in KApplication::notify (this=0xbfd50bf0, receiver=0x9012bf8, event=0xbfd508dc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x004c219e in QCoreApplication::notifyInternal (this=0xbfd50bf0, receiver=0x9012bf8, event=0xbfd508dc) at kernel/qcoreapplication.cpp:787
#34 0x004f2c10 in sendEvent (event=0xbfd508dc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8eaffa4) at kernel/qeventdispatcher_unix.cpp:603
#36 0x004f0122 in timerSourceDispatch (source=0x8eaff70) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0395325f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x03953990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x03953c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x004f0ada in QEventDispatcherGlib::processEvents (this=0x8e92238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x05a81e7a in QGuiEventDispatcherGlib::processEvents (this=0x8e92238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x004c11dd in QEventLoop::processEvents (this=0xbfd50b54, flags=...) at kernel/qeventloop.cpp:149
#43 0x004c1421 in QEventLoop::exec (this=0xbfd50b54, flags=...) at kernel/qeventloop.cpp:201
#44 0x004c619d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x059c7924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294731, bug 294696, bug 294662, bug 294621, bug 294605.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-24 19:54:25 UTC

*** This bug has been marked as a duplicate of bug 291262 ***