Bug 291525

Summary: Muon crashed
Product: kde Reporter: Dominik <dominik.bieber>
Component: generalAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: adaptee
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Dominik 2012-01-14 16:28:47 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: I have opened Firefox and Kopete. In Firefox a Forum was opened

- Unusual behavior I noticed: I started Muon and the window appears. It was empty. Some seconds later it crashed

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77a0930 (LWP 2115))]

Thread 2 (Thread 0xb558cb70 (LWP 2118)):
#0  0x006dbd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00a7a7d5 in do_gettime (frac=0xb558c020, sec=0xb558c018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00b4d4b6 in QTimerInfoList::updateCurrentTime (this=0x896d5ac) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00b4d80a in QTimerInfoList::timerWait (this=0x896d5ac, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00b4c053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb558c12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00b4c0ed in timerSourcePrepare (source=0x896d578, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x04a7288c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x04a73637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x04a73c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00b4cb37 in QEventDispatcherGlib::processEvents (this=0x8965128, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00b1d1dd in QEventLoop::processEvents (this=0xb558c2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00b1d421 in QEventLoop::exec (this=0xb558c2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00a2090b in QThread::exec (this=0x896af30) at thread/qthread.cpp:498
#14 0x00afde2d in QInotifyFileSystemWatcherEngine::run (this=0x896af30) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00a237b3 in QThreadPrivate::start (arg=0x896af30) at thread/qthread_unix.cpp:331
#16 0x007ddd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x009070ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77a0930 (LWP 2115)):
[KCrash Handler]
#7  0x00a77e11 in QtPrivate::QStringList_contains (that=0xbfc03144, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc03144) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8818b30) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8818b30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc03364) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00b24b7d in metacall (argv=0xbfc03364, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8818b30) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8818b30, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfc03364) at kernel/qmetaobject.cpp:232
#13 0x00b33a6a in QMetaObject::activate (sender=0x8886660, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8886660) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8886660, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc034a8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00b24b7d in metacall (argv=0xbfc034a8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8886660) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8886660, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfc034a8) at kernel/qmetaobject.cpp:232
#18 0x00b33a6a in QMetaObject::activate (sender=0x8818b30, m=0x80950c0, local_signal_index=0, argv=0xbfc034a8) at kernel/qobject.cpp:3278
#19 0x005e67c5 in MuonMainWindow::backendReady (this=0x8818b30, _t1=0x887db18) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x005e6933 in MuonMainWindow::initObject (this=0x8818b30) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8818b30) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8818b30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc035d4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00b24b7d in metacall (argv=0xbfc035d4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8818b30) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8818b30, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfc035d4) at kernel/qmetaobject.cpp:232
#25 0x00b33a6a in QMetaObject::activate (sender=0x887fce8, m=0xc54238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00b3b375 in QSingleShotTimer::timeout (this=0x887fce8) at .moc/release-shared/qtimer.moc:82
#27 0x00b3b42c in QSingleShotTimer::timerEvent (this=0x887fce8) at kernel/qtimer.cpp:308
#28 0x00b36994 in QObject::event (this=0x887fce8, e=0xbfc039cc) at kernel/qobject.cpp:1181
#29 0x06b6dd54 in notify_helper (e=0xbfc039cc, receiver=0x887fce8, this=0x871d3a0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x871d3a0, receiver=0x887fce8, e=0xbfc039cc) at kernel/qapplication.cpp:4458
#31 0x06b73103 in QApplication::notify (this=0xbfc039cc, receiver=0x887fce8, e=0xbfc039cc) at kernel/qapplication.cpp:3886
#32 0x010b9681 in KApplication::notify (this=0xbfc03ce0, receiver=0x887fce8, event=0xbfc039cc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00b1e19e in QCoreApplication::notifyInternal (this=0xbfc03ce0, receiver=0x887fce8, event=0xbfc039cc) at kernel/qcoreapplication.cpp:787
#34 0x00b4ec10 in sendEvent (event=0xbfc039cc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8724744) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00b4c122 in timerSourceDispatch (source=0x8724710) at kernel/qeventdispatcher_glib.cpp:184
#37 0x04a7325f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x04a73990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x04a73c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00b4cada in QEventDispatcherGlib::processEvents (this=0x8700238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x06c25e3a in QGuiEventDispatcherGlib::processEvents (this=0x8700238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00b1d1dd in QEventLoop::processEvents (this=0xbfc03c44, flags=...) at kernel/qeventloop.cpp:149
#43 0x00b1d421 in QEventLoop::exec (this=0xbfc03c44, flags=...) at kernel/qeventloop.cpp:201
#44 0x00b2219d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x06b6b8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291522, bug 291520, bug 291513, bug 291509, bug 291492.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-15 02:48:07 UTC

*** This bug has been marked as a duplicate of bug 291262 ***