Bug 291489

Summary: Software Center Crashes
Product: kde Reporter: Ryan Wilkinson <rjwilkinson83>
Component: generalAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: mrantmet, spiridusu_paul, spotlessalmond, thijs22nospam
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: New crash information added by DrKonqi
New crash information added by DrKonqi
New crash information added by DrKonqi

Description Ryan Wilkinson 2012-01-14 01:34:17 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: I had no other applications running in the background just tried to launch the muon program and it crashed

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7765930 (LWP 1658))]

Thread 2 (Thread 0xb5936b70 (LWP 1662)):
#0  0x00f41416 in __kernel_vsyscall ()
#1  0x00e4c40e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x0177434b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01765896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01765c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00777b37 in QEventDispatcherGlib::processEvents (this=0x9605028, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x007481dd in QEventLoop::processEvents (this=0xb59362b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00748421 in QEventLoop::exec (this=0xb59362b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0064b90b in QThread::exec (this=0x954dd50) at thread/qthread.cpp:498
#9  0x00728e2d in QInotifyFileSystemWatcherEngine::run (this=0x954dd50) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0064e7b3 in QThreadPrivate::start (arg=0x954dd50) at thread/qthread_unix.cpp:331
#11 0x00927d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00e5b0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7765930 (LWP 1658)):
[KCrash Handler]
#7  0x006a2e11 in QtPrivate::QStringList_contains (that=0xbfec62a4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfec62a4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x94bdd88) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x94bdd88, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfec64c4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0074fb7d in metacall (argv=0xbfec64c4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x94bdd88) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x94bdd88, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfec64c4) at kernel/qmetaobject.cpp:232
#13 0x0075ea6a in QMetaObject::activate (sender=0x951efd0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x951efd0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x951efd0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfec6608) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0074fb7d in metacall (argv=0xbfec6608, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x951efd0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x951efd0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfec6608) at kernel/qmetaobject.cpp:232
#18 0x0075ea6a in QMetaObject::activate (sender=0x94bdd88, m=0x80950c0, local_signal_index=0, argv=0xbfec6608) at kernel/qobject.cpp:3278
#19 0x00d557c5 in MuonMainWindow::backendReady (this=0x94bdd88, _t1=0x94c0e08) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00d55933 in MuonMainWindow::initObject (this=0x94bdd88) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x94bdd88) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x94bdd88, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfec6734) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0074fb7d in metacall (argv=0xbfec6734, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x94bdd88) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x94bdd88, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfec6734) at kernel/qmetaobject.cpp:232
#25 0x0075ea6a in QMetaObject::activate (sender=0x9525e88, m=0x87f238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00766375 in QSingleShotTimer::timeout (this=0x9525e88) at .moc/release-shared/qtimer.moc:82
#27 0x0076642c in QSingleShotTimer::timerEvent (this=0x9525e88) at kernel/qtimer.cpp:308
#28 0x00761994 in QObject::event (this=0x9525e88, e=0xbfec6b2c) at kernel/qobject.cpp:1181
#29 0x04561d54 in notify_helper (e=0xbfec6b2c, receiver=0x9525e88, this=0x93ff758) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x93ff758, receiver=0x9525e88, e=0xbfec6b2c) at kernel/qapplication.cpp:4458
#31 0x04567103 in QApplication::notify (this=0xbfec6b2c, receiver=0x9525e88, e=0xbfec6b2c) at kernel/qapplication.cpp:3886
#32 0x01199681 in KApplication::notify (this=0xbfec6e40, receiver=0x9525e88, event=0xbfec6b2c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0074919e in QCoreApplication::notifyInternal (this=0xbfec6e40, receiver=0x9525e88, event=0xbfec6b2c) at kernel/qcoreapplication.cpp:787
#34 0x00779c10 in sendEvent (event=0xbfec6b2c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x93fccc4) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00777122 in timerSourceDispatch (source=0x93fcc90) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0176525f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01765990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01765c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00777ada in QEventDispatcherGlib::processEvents (this=0x93dd238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x04619e3a in QGuiEventDispatcherGlib::processEvents (this=0x93dd238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x007481dd in QEventLoop::processEvents (this=0xbfec6da4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00748421 in QEventLoop::exec (this=0xbfec6da4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0074d19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0455f8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291486, bug 291485, bug 291482, bug 291477, bug 291473.

Reported using DrKonqi
Comment 1 spiridusu_paul 2012-01-14 02:08:39 UTC
Created attachment 67800 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

Software center crushes everytime i try to lounch it.
I get this: Executable: muon-installer PID: 2325 Signal: Segmentation fault (11)

-- Backtrace (Reduced):
#7  0xb7286e11 in QtPrivate::QStringList_contains (that=0xbfe6cc54, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe6cc54) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9f9aa88) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9f9aa88, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe6ce74) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb7333b7d in metacall (argv=0xbfe6ce74, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9f9aa88) at kernel/qmetaobject.cpp:237
Comment 2 spotlessalmond 2012-01-14 04:25:38 UTC
Created attachment 67805 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed: nothing else running in background, consistently crashes each time I try to open the program. I ran it through terminal and got this: KCrash: Application 'muon-installer' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/spotless/.kde/socket-spotless-Inspiron-530s/kdeinit4__0

-- Backtrace (Reduced):
#7  0xb7202e11 in QtPrivate::QStringList_contains (that=0xbff82e14, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbff82e14) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x98126d8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x98126d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff83034) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb72afb7d in metacall (argv=0xbff83034, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x98126d8) at kernel/qmetaobject.cpp:237
Comment 3 Thijs 2012-01-14 09:01:47 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 4 Anton 2012-01-14 12:36:01 UTC
Created attachment 67816 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed:

1. Restart the PC (it was running for a long time)
2. run muon package manager - successful
3. Select some updates then discard it and closed the muon 
4. open muon-installer via GUI - it's crashed when starting

Then I tried to run it from xterm by muon-installer and sudo muon-installer - the same result in voth cases. Here is a output from xterm:

Error: "/var/tmp/kdecache-exeler" is owned by uid 1000 instead of uid 0.
exeler@exeler-HP-Mini-110-3000:~/.kde/socket-exeler-HP-Mini-110-3000$ Error: "/tmp/kde-exeler" is owned by uid 1000 instead of uid 0.
Error: "/tmp/kde-exeler" is owned by uid 1000 instead of uid 0.
Error: "/tmp/ksocket-exeler" is owned by uid 1000 instead of uid 0.
kdeinit4: Shutting down running client.
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
Error: "/tmp/ksocket-exeler" is owned by uid 1000 instead of uid 0.
Error: "/tmp/kde-exeler" is owned by uid 1000 instead of uid 0.
Error: "/var/tmp/kdecache-exeler" is owned by uid 1000 instead of uid 0.
kbuildsycoca4 running...
Error: "/var/tmp/kdecache-exeler" is owned by uid 1000 instead of uid 0.
kbuildsycoca4(2983) KConfigGroup::readXdgListEntry: List entry Categories in "/usr/share/applications/im-switch.desktop" is not compliant with XDG standard (missing trailing semicolon). 
kbuildsycoca4(2983) KConfigGroup::readXdgListEntry: List entry Categories in "/usr/share/applications/kde4/bluedevil-network-dun.desktop" is not compliant with XDG standard (missing trailing semicolon). 
kbuildsycoca4(2983) KConfigGroup::readXdgListEntry: List entry Categories in "/usr/share/applications/kde4/bluedevil-network-panu.desktop" is not compliant with XDG standard (missing trailing semicolon). 
Error: "/var/tmp/kdecache-exeler" is owned by uid 1000 instead of uid 0.
Error: "/tmp/ksocket-exeler" is owned by uid 1000 instead of uid 0.
Failed to read classid file: Object not found
KCrash: Application 'muon-installer' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/exeler/.kde/socket-exeler-HP-Mini-110-3000/kdeinit4__0
Error: "/var/tmp/kdecache-exeler" is owned by uid 1000 instead of uid 0.
QSocketNotifier: Invalid socket 13 and type 'Read', disabling...

-- Backtrace (Reduced):
#7  0x00d51e11 in QtPrivate::QStringList_contains (that=0xbfe9db54, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe9db54) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x89c74d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x89c74d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe9dd74) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00dfeb7d in metacall (argv=0xbfe9dd74, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x89c74d0) at kernel/qmetaobject.cpp:237