Bug 288362

Summary: Crash while reading email
Product: [Applications] kontact Reporter: Alan House <alan.house>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Alan House 2011-12-06 22:15:05 UTC
Application: kontact (4.7.3)
KDE Platform Version: 4.7.3 (4.7.3) (Compiled from sources)
Qt Version: 4.8.0
Operating System: Linux 3.1.2-1.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:
Have not had a crash in a while, then got another one while going back and forth between messages that where previously read.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f702c9c3840 (LWP 14369))]

Thread 5 (Thread 0x7f702258d700 (LWP 14370)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x0000003c8eb973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x3c8f590f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x0000003c8eb974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003387607d90 in start_thread (arg=0x7f702258d700) at pthread_create.c:309
#4  0x0000003386aeed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7f7021c8c700 (LWP 14371)):
#0  0x0000003386ae6373 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003389644f88 in g_main_context_poll (n_fds=1, fds=0x7f701c0013e0, priority=<optimized out>, timeout=2431, context=0x7f701c0009a0) at gmain.c:3386
#2  g_main_context_iterate (context=0x7f701c0009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068
#3  0x000000338964544c in g_main_context_iteration (context=0x7f701c0009a0, may_block=1) at gmain.c:3136
#4  0x000000338e7a6896 in QEventDispatcherGlib::processEvents (this=0x7f701c0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x000000338e776c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x000000338e776ed7 in QEventLoop::exec (this=0x7f7021c8bd40, flags=...) at kernel/qeventloop.cpp:204
#7  0x000000338e678ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x000000338e67bb1b in QThreadPrivate::start (arg=0x20a5ff0) at thread/qthread_unix.cpp:298
#9  0x0000003387607d90 in start_thread (arg=0x7f7021c8c700) at pthread_create.c:309
#10 0x0000003386aeed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f6fc7fff700 (LWP 10326)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000338e67bf8f in wait (time=30000, this=0x7f6fd0005ed0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f6fd0005e78, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000338e66f55f in QThreadPoolThread::run (this=0x7f6fd000a120) at concurrent/qthreadpool.cpp:141
#4  0x000000338e67bb1b in QThreadPrivate::start (arg=0x7f6fd000a120) at thread/qthread_unix.cpp:298
#5  0x0000003387607d90 in start_thread (arg=0x7f6fc7fff700) at pthread_create.c:309
#6  0x0000003386aeed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f6fc5532700 (LWP 10327)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000338e67bf8f in wait (time=30000, this=0x7f6fd0005ed0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f6fd0005e78, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000338e66f55f in QThreadPoolThread::run (this=0x7f6fd0006120) at concurrent/qthreadpool.cpp:141
#4  0x000000338e67bb1b in QThreadPrivate::start (arg=0x7f6fd0006120) at thread/qthread_unix.cpp:298
#5  0x0000003387607d90 in start_thread (arg=0x7f6fc5532700) at pthread_create.c:309
#6  0x0000003386aeed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f702c9c3840 (LWP 14369)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x7111810, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00000033926f4ef9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x7111810, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x000000338e7909e6 in QObject::event (this=0x7111810, e=<optimized out>) at kernel/qobject.cpp:1194
#9  0x0000003c85fc96f4 in notify_helper (e=0x7f6fcc008a50, receiver=0x7111810, this=0x1ed0ad0) at kernel/qapplication.cpp:4518
#10 QApplicationPrivate::notify_helper (this=0x1ed0ad0, receiver=0x7111810, e=0x7f6fcc008a50) at kernel/qapplication.cpp:4490
#11 0x0000003c85fce573 in QApplication::notify (this=0x7fff93291780, receiver=0x7111810, e=0x7f6fcc008a50) at kernel/qapplication.cpp:4379
#12 0x0000003c87250396 in KApplication::notify (this=0x7fff93291780, receiver=0x7111810, event=0x7f6fcc008a50) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#13 0x000000338e777b4c in QCoreApplication::notifyInternal (this=0x7fff93291780, receiver=0x7111810, event=0x7f6fcc008a50) at kernel/qcoreapplication.cpp:876
#14 0x000000338e77b5da in sendEvent (event=0x7f6fcc008a50, receiver=0x7111810) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1ea7050) at kernel/qcoreapplication.cpp:1500
#16 0x000000338e7a6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x1edb0f0) at kernel/qeventdispatcher_glib.cpp:279
#18 0x0000003389644a7d in g_main_dispatch (context=0x1edb000) at gmain.c:2425
#19 g_main_context_dispatch (context=0x1edb000) at gmain.c:2995
#20 0x0000003389645278 in g_main_context_iterate (context=0x1edb000, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#21 0x000000338964544c in g_main_context_iteration (context=0x1edb000, may_block=1) at gmain.c:3136
#22 0x000000338e7a682f in QEventDispatcherGlib::processEvents (this=0x1ea8510, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x0000003c8606c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#24 0x000000338e776c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x000000338e776ed7 in QEventLoop::exec (this=0x7fff93291710, flags=...) at kernel/qeventloop.cpp:204
#26 0x000000338e77b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x00000000004037b9 in main (argc=1, argv=0x7fff93291da8) at /usr/src/debug/kdepim-4.7.3/kontact/src/main.cpp:218

Possible duplicates by query: bug 288324, bug 288070, bug 288015, bug 287929, bug 287926.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-12-07 10:21:13 UTC

*** This bug has been marked as a duplicate of bug 286307 ***