Bug 275202

Summary: Kwin crashes exiting fullscreen mode.
Product: [Plasma] kwin Reporter: barbanegra555
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description barbanegra555 2011-06-08 13:35:57 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
Using firefox and watching (not only) youtube videos in fullscreen causes a crash of kwin on exit.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8a07da47a0 (LWP 1738))]

Thread 3 (Thread 0x7f89ec61b700 (LWP 1743)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f89ec61aad0 in ?? ()
#2  0x00007fff875ff7b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7f89ebe1a700 (LWP 1744)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8a064592a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f8a06772180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f8a064592d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f8a06780254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f89fdfb4d8c in start_thread (arg=0x7f89ebe1a700) at pthread_create.c:304
#4  0x00007f8a075fa04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8a07da47a0 (LWP 1738)):
[KCrash Handler]
#6  0x00007f89ef38f0a0 in intel_region_buffer () from /usr/lib/dri/i965_dri.so
#7  0x00007f89ef3826c2 in intelClearWithBlit () from /usr/lib/dri/i965_dri.so
#8  0x00007f89ef384d2a in ?? () from /usr/lib/dri/i965_dri.so
#9  0x00007f8a07970ce7 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#10 0x00007f8a0796888f in KWin::Scene::paintGenericScreen (this=0x23226e0, orig_mask=40) at ../../kwin/scene.cpp:188
#11 0x00007f8a07965c7a in KWin::Scene::finalPaintScreen (this=0x23226e0, mask=40, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:178
#12 0x00007f8a07983f19 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#13 0x00007f89ee3ce5a6 in KWin::StartupFeedbackEffect::paintScreen (this=0x356e340, mask=40, region=<value optimized out>, data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#15 0x00007f8a05a43a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=40, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#17 0x00007f89ee37544d in KWin::LogoutEffect::paintScreen (this=0x3848a80, mask=40, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#18 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#19 0x00007f89ee39057b in KWin::ShadowEffect::paintScreen (this=0x35b6ca0, mask=40, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#20 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#21 0x00007f89ee3a2e68 in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=40, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#22 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#23 0x00007f89ee379fbd in KWin::PresentWindowsEffect::paintScreen (this=0x37e5a90, mask=8, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#25 0x00007f8a05a43a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#27 0x00007f8a05a43a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#29 0x00007f8a05a43a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#31 0x00007f8a05a43a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#33 0x00007f89ee361365 in KWin::DesktopGridEffect::paintScreen (this=0x37d4910, mask=8, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#34 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#35 0x00007f89ee396b8f in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#36 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#37 0x00007f89ee35abad in KWin::BoxSwitchEffect::paintScreen (this=0x3875460, mask=8, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#38 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#39 0x00007f89ee3b1256 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#40 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#41 0x00007f8a05a43a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#43 0x00007f8a05a43a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#45 0x00007f8a05a43a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#47 0x00007f89ee3a9d86 in KWin::CoverSwitchEffect::paintScreen (this=0x37e4bc0, mask=8, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#48 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#49 0x00007f8a05a43a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#50 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#51 0x00007f8a05a43a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#53 0x00007f89ee3a039b in KWin::ZoomEffect::paintScreen (this=0x37d6340, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#54 0x00007f8a07983fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3456cd0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#55 0x00007f8a079680af in KWin::Scene::paintScreen (this=0x23226e0, mask=0x7fff875ea8ac, region=0x7fff875ea970) at ../../kwin/scene.cpp:137
#56 0x00007f8a0797bef3 in KWin::SceneOpenGL::paint (this=0x23226e0, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#57 0x00007f8a07963396 in KWin::Workspace::performCompositing (this=0x264ee60) at ../../kwin/composite.cpp:448
#58 0x00007f8a039bc1c9 in QObject::event (this=0x264ee60, e=<value optimized out>) at kernel/qobject.cpp:1190
#59 0x00007f8a02d699e4 in QApplicationPrivate::notify_helper (this=0x21f1410, receiver=0x264ee60, e=0x7fff875eb100) at kernel/qapplication.cpp:4462
#60 0x00007f8a02d6e3aa in QApplication::notify (this=<value optimized out>, receiver=0x264ee60, e=0x7fff875eb100) at kernel/qapplication.cpp:4341
#61 0x00007f8a070f5866 in KApplication::notify (this=0x7fff875eb500, receiver=0x264ee60, event=0x7fff875eb100) at ../../kdeui/kernel/kapplication.cpp:311
#62 0x00007f8a039a849c in QCoreApplication::notifyInternal (this=0x7fff875eb500, receiver=0x264ee60, event=0x7fff875eb100) at kernel/qcoreapplication.cpp:731
#63 0x00007f8a039d5f12 in sendEvent (this=0x21f2040) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#64 QTimerInfoList::activateTimers (this=0x21f2040) at kernel/qeventdispatcher_unix.cpp:604
#65 0x00007f8a039d605b in QEventDispatcherUNIX::processEvents (this=0x2196340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#66 0x00007f8a02e11c0c in QEventDispatcherX11::processEvents (this=0x2196340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#67 0x00007f8a039a7882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#68 0x00007f8a039a7abc in QEventLoop::exec (this=0x7fff875eb440, flags=...) at kernel/qeventloop.cpp:201
#69 0x00007f8a039abecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#70 0x00007f8a079011ec in kdemain (argc=<value optimized out>, argv=0x7fff875ebb98) at ../../kwin/main.cpp:542
#71 0x00007f8a07532eff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fff875ebb98, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff875ebb88) at libc-start.c:226
#72 0x0000000000400669 in _start ()

This bug may be a duplicate of or related to bug 252817.

Possible duplicates by query: bug 275176, bug 274967, bug 273989, bug 273601, bug 273553.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-06-08 15:24:26 UTC
driver bug

*** This bug has been marked as a duplicate of bug 252817 ***