Bug 271505

Summary: Crash of KPackageKit when examining More Info panel
Product: kpackagekit Reporter: John Oyster <johnqed>
Component: generalAssignee: Steven M. Parrish <smparrish>
Status: RESOLVED DUPLICATE    
Severity: crash CC: adaptee, dantti12
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description John Oyster 2011-04-22 19:39:00 UTC
Application: kpackagekitsmarticon (0.6.2)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
Problem:
The issue occured when I was examing software packages under the Science and Engineering section. Once I had clicked on a package the More Information panel was displaced. I had attempted to click the Apply button when the crash occured. I have not been able to reproduce this behavior.

It should be noted that I am using Kubuntu10.10 in a VMWare 7 environment on a Windows 7 64-bit machine.

Steps when occured:
1. Start KPackageKit
2. Filter on Science and Engineering
3. Click on random packages and scroll to other packages while More Information panel is displayed.
4. After a while click the Apply button
OBSERVE: Fatal

-- Backtrace:
Application: KPackageKit (kpackagekitsmarticon), signal: Segmentation fault
[KCrash Handler]
#7  0x010de232 in QWidget::releaseShortcut (this=0xa0e51b0, id=-11) at kernel/qwidget.cpp:11043
#8  0x01513910 in QLabelPrivate::clearContents (this=0xa0e8ef8) at widgets/qlabel.cpp:1363
#9  0x015144a8 in QLabel::~QLabel (this=0xa0e51b0, __in_chrg=<value optimized out>) at widgets/qlabel.cpp:262
#10 0x00e3f816 in QObjectPrivate::deleteChildren (this=0xa0e4f90) at kernel/qobject.cpp:1957
#11 0x010f08fc in QWidget::~QWidget (this=0xa0e8220, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#12 0x0065fa3d in ~DebconfElement (this=0xa0e8220, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfElement.h:26
#13 DebconfKde::DebconfNote::~DebconfNote (this=0xa0e8220, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfNote.cpp:32
#14 0x00e3f816 in QObjectPrivate::deleteChildren (this=0xa0e4bf8) at kernel/qobject.cpp:1957
#15 0x010efcbc in QWidget::~QWidget (this=0xa0e0400, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#16 0x00e3f816 in QObjectPrivate::deleteChildren (this=0xa0bfd88) at kernel/qobject.cpp:1957
#17 0x010efcbc in QWidget::~QWidget (this=0xa026610, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#18 0x00e3f816 in QObjectPrivate::deleteChildren (this=0xa0b65a8) at kernel/qobject.cpp:1957
#19 0x010f08fc in QWidget::~QWidget (this=0xa099648, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#20 0x0150ca61 in QFrame::~QFrame (this=0xa099648, __in_chrg=<value optimized out>) at widgets/qframe.cpp:242
#21 0x015ab854 in QAbstractScrollArea::~QAbstractScrollArea (this=0xa099648, __in_chrg=<value optimized out>) at widgets/qabstractscrollarea.cpp:526
#22 0x015b0095 in QScrollArea::~QScrollArea (this=0xa099648, __in_chrg=<value optimized out>) at widgets/qscrollarea.cpp:176
#23 0x00e3f816 in QObjectPrivate::deleteChildren (this=0xa0c0448) at kernel/qobject.cpp:1957
#24 0x010f08fc in QWidget::~QWidget (this=0xa018540, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#25 0x006663b5 in DebconfKde::DebconfGui::~DebconfGui (this=0xa018540, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfGui.h:62
#26 0x0805938c in _start ()

This bug may be a duplicate of or related to bug 255935.

Possible duplicates by query: bug 267867, bug 267264, bug 266744, bug 262832, bug 259460.

Reported using DrKonqi
Comment 1 Jekyll Wu 2011-12-01 04:26:30 UTC

*** This bug has been marked as a duplicate of bug 255935 ***