Bug 193756

Summary: some icon plasmoid does not adjusts its sizes to panel size
Product: plasma4 Reporter: Rafał Malinowski <rafal.przemyslaw.malinowski>
Component: widget-miscAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED FIXED    
Severity: normal CC: aseigo, asraniel, bugs.kde, bugzilla, fabio.albieri, gentoo.integer, gokcen.eraslan, hephooey_dev, johnius, kde, kdebugs.99.urgwurz, nightowl, pclaves, simon.boulet.ing+kde, thelwyn, vmatare+kdebug
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Screnshot of panel with invalid applet sizing.
screenshot KDE 4.4.1
Almost good looking panel with 22 size icons
Bad looking panel with icons enlarged to 256
Task manager icon scaling
screenshot of panel with icons in different size, KDE 4.5

Description Rafał Malinowski 2009-05-23 12:35:50 UTC
Version:            (using KDE 4.2.85)
OS:                Linux
Installed from:    SuSE RPMs

I have a panel with lots of icon plasmoids. When I enlarge this panel some of the plasmoids are getting bigger, and some of them are staying at small size. I am attaching screenshot of this behaviour.
Comment 1 Rafał Malinowski 2009-05-23 12:37:15 UTC
Created attachment 33942 [details]
Screnshot of panel with invalid applet sizing.
Comment 2 Beat Wolf 2009-12-08 18:41:41 UTC
*** Bug 201347 has been marked as a duplicate of this bug. ***
Comment 3 Beat Wolf 2009-12-08 18:41:41 UTC
*** Bug 214323 has been marked as a duplicate of this bug. ***
Comment 4 Beat Wolf 2009-12-11 19:55:32 UTC
*** Bug 206507 has been marked as a duplicate of this bug. ***
Comment 5 Kolia 2010-01-02 21:33:26 UTC
I can reproduce it with KDE 4.4 SVN 1068732 | Qt 4.6.0

Is this a panel problem or a per-plasmoid issue?
If so, should we fill a bug report for each plasmoid whose icon resizes badly in the panel?
Comment 6 johnius 2010-02-16 02:18:50 UTC
I have this same problem in KDE 4.4.  The biggest culprits are the K Launcher and the Device Notifier.  The LCD Widget is having trouble as well.  I've switched them all out and back, with no luck.
Comment 7 Tanja Schulte 2010-03-30 18:16:24 UTC
Created attachment 42385 [details]
screenshot KDE 4.4.1

This is how the panel icons behave when I try to enlarge the panel. They now seem to be even small than it was possible with KDE 4.3 where they at least resized to 48x48. Please add an option to either manually set the size of the panel icons (I'd prefer something from 64x64 to 80x80) or make them adjust in height to the height of the panel.
Comment 8 johnius 2010-03-31 02:06:51 UTC
*** This bug has been confirmed by popular vote. ***
Comment 9 Fabio Albieri 2010-03-31 23:59:16 UTC
Same exact problem on Kubuntu 10.4
Comment 10 Janet 2010-04-21 01:13:57 UTC
It affects all application launchers, all panel "drawers" (lancelot components, folderviews, quick access widget, all three menu types), the trash widget, show desktop, show dashboard... Just the pager, the taskmanager buttons and the clock  increase their size according to the panel height.

And in KDE 4.4.2 the situation really is worse than in KDE 4.3: The icons cannot reach the size they had in KDE 4.3 anymore and at some point of increasing the height of the panel the icons even shrink though the panel gets higher. That's when the system tray switches from one row to two rows. No fun for people with not so good eyes.
Comment 11 Marco Martin 2010-05-22 11:49:34 UTC
*** Bug 226039 has been marked as a duplicate of this bug. ***
Comment 12 Janet 2010-05-22 13:20:12 UTC
*** Bug 236870 has been marked as a duplicate of this bug. ***
Comment 13 Beat Wolf 2010-06-08 10:50:55 UTC
Some patches went into kde 4.5, could you please test this again? It now honors the system settings about the maximum panel icon size.
Comment 14 Vadim A. Misbakh-Soloviov (mva) 2010-06-08 14:43:01 UTC
Yep, KDE: 4.4.81 (KDE 4.4.81 (KDE 4.5 >= 20100527))
Working fine, but still has strange thing: if panel icon size is 22, for example, then icon get it's size only if panel height >48px. If panel size is <=48px, then icon has same size, that panel.
Comment 15 Rafał Malinowski 2010-06-11 00:27:08 UTC
Created attachment 47879 [details]
Almost good looking panel with 22 size icons

This is panel with similar setup as in my first screenshot.
Now it looks almost OK, clock has different size because it is not an icon, but the pastebin panel is quite too big.
Comment 16 Rafał Malinowski 2010-06-11 00:28:28 UTC
Created attachment 47880 [details]
Bad looking panel with icons enlarged to 256

After I've enlarged panel icons to 256 (in system settings) some of the icons expanded to panel width, but other didn't (top ones).

So I don't think the bug is fixed now, but it is definitely better than before.
Comment 17 Maciej Mrozowski 2010-07-03 13:29:38 UTC
Created attachment 48558 [details]
Task manager icon scaling

The same issue, 4.4.5 here. Task manager icons, horizontal panel layout.
Comment 18 Tanja Schulte 2010-07-10 17:53:24 UTC
For me the most important point is that I need a panel with big starter icons and a big menu button like it was possible in KDE3. I need at least icons of size 64 but prefer bigger ones. And by now this is not possible with KDE4 which IMHO is a usability and UI bug concerning accessibility.

As a workaround I could totally get rid of the panel and only put large icons on the desktop but I have to to it for every activity because contrary to the real panel those launchers are not available on every activity. Also it is not possible to hide such a pseudo panel.

I only can repeat: please be so kind to show courtesy to the people with bad eyes and allow launchers and menu button in the panel to be larger (64, 80, 96, 128 pixel).
Comment 19 Victor Mataré 2010-07-10 18:02:34 UTC
Yep, and it also doesn't look good. So, erm... puh-leeeaaaaze?
Comment 20 Beat Wolf 2010-07-10 19:50:02 UTC
as i said, in 4.5 you can set in the system settings the maximum size of the icons in the panel, that solves the problem.
Comment 21 Janet 2010-08-12 19:15:27 UTC
Indeed it does work in 4.5 for the launcher icons after I have set the panel icons' max size to 128 - thanks a lot! - but it does not work for the trash widget icon, the quickaccess widget icon, the show desktop widget icon, the dashboard widgt icon...  they stay in tiny size 32x32 :(.
Comment 22 Peter Paulsen 2010-08-13 15:00:26 UTC
@#20: It is now way better in 4.5 than in the previous versions because the launchers and the menu icon are increasable but it still is only partially solved as Janet stated. Can you please reopen the report as not fixed?

Or is there some trick to get also increased trash icon and quickaccess icons?
Comment 23 Tanja Schulte 2010-08-20 16:17:43 UTC
Created attachment 50781 [details]
screenshot of panel with icons in different size, KDE 4.5

I confirm: this is not fully fixed in KDE 4.5, see attached screenshot. But thanks a lot for making the situation a lot better. Is it possible to do so also for the trash and widgets like the quickaccess widget? Or do the authors of those widgets have to do that?
Comment 24 Peter Paulsen 2010-08-30 15:55:28 UTC
Obviously the applets that are not application launchers or real menus are not treated as panel icons per se and therefore are not covered by the icon size option in systemsettings.

Can you please tell me if that is a different bug that needs to be reported separately? Or if it is somehow up to the authors of the widgets to enable their widgets to respect that option? So that we can bug them? :)

I have a lot of quickaccess widget icons in my panel as I use them as extra menus. So I now have a 64x64 kickoff menu icon, tiny 32x32 quickaccess folder icons, tiny trash icon and 64x64 konqueror launcher icon. Looks weird and it is still very troublesome to distinguish the tiny folder icons.
Comment 25 Rafał Malinowski 2010-08-30 17:21:37 UTC
For me it is still the same bug.
Comment 26 Janet 2010-09-05 15:59:30 UTC
According to http://forum.kde.org/viewtopic.php?f=17&t=90090&p=169419#p169419

Bug 250278 trash widget
Bug 250279 dashboard widget
Bug 250280 show desktop widget

More?

How to file a bug against the quickaccess widget? IMHO it is not in the default KDE widget set except in Kubuntu? Wild guess: it is this one: http://kde-look.org/content/show.php/QuickAccess+(maintenance+fork)?content=101968
Comment 27 Janet 2010-09-05 16:27:52 UTC
Maybe this one is related too: Bug 244557
Comment 28 Beat Wolf 2010-09-06 10:43:08 UTC
the bug is fixed.
what is not fixed are the individual applets. each applet needs a separate bugreport now.
Comment 29 Aaron J. Seigo 2010-09-07 06:18:42 UTC
"How to file a bug against the quickaccess widget?"

with the author of the quickaccess widget.
Comment 30 Janet 2010-09-11 07:40:27 UTC
In case anybody who uses the quickaccess widget is interested: I took a look at the trash widget solution and managed to apply the same fix to the quickaccess widget. I have uploaded the diffs to the Lauchpad bug report: https://bugs.launchpad.net/ubuntu/+source/plasma-widget-quickaccess/+bug/630879