Bug 226039 - [4.4 regression] Icons don't scale to big panel size and use 32x32px instead.
Summary: [4.4 regression] Icons don't scale to big panel size and use 32x32px instead.
Status: RESOLVED DUPLICATE of bug 193756
Alias: None
Product: plasma4
Classification: Unclassified
Component: containment-panel (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR normal with 148 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 226372 226903 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-02-09 17:13 UTC by Philipp Claves
Modified: 2010-07-07 19:16 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Panel Screenshot (46.21 KB, image/png)
2010-02-09 17:17 UTC, Philipp Claves
Details
Screenshot of a horizontal panel, with the icons not scaled correctly (40.53 KB, image/png)
2010-02-11 14:28 UTC, Thomas Schwarzgruber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Claves 2010-02-09 17:13:46 UTC
Version:            (using KDE 4.4.0)
OS:                Linux
Installed from:    Archlinux Packages

Icons placed in a vertical Panel don't adapt to the width of a vertical panel any more. This worked fine in kde 4.3.x, now they have a fixed size of 32x32 pixels.

On a horizontal panel the icons are sized correctly.
Comment 1 Philipp Claves 2010-02-09 17:17:15 UTC
Created attachment 40620 [details]
Panel Screenshot
Comment 2 Thomas Schwarzgruber 2010-02-11 14:27:19 UTC
I can see this problem on the horizontal panel as well: I have here a horizontal panel which does not span the whole width (perhaps that's connected to the problem...) and the icons don't scale to vertical size of panel. Will apply screenshot of an exaggerated high panel to make it clear....

Another thing is that I use a dual head setup -- no clue if it is linked to that or not.

My packages of kde sc 4.4 are from openSuse Factory.
Comment 3 Thomas Schwarzgruber 2010-02-11 14:28:43 UTC
Created attachment 40679 [details]
Screenshot of a horizontal panel, with the icons not scaled correctly
Comment 4 Philipp Claves 2010-02-11 16:03:54 UTC
Thomas you are right this is not limited to a vertical panel. In fact, its not related to it at all. 

I played around with the panels a bit more and found that the icons jump back to 32x32 if the relevant panel size exceeds a fixed threshold. This is either a very unintuitive "feature", or a feature with a bug.
Comment 5 Christian Hartmann 2010-02-11 19:50:29 UTC
Perhaps there is something wrong with the packaging? Because I get very fuzzy icons in Dolphin. And the package oxygen-icon-theme-scalable is only around 200 kB in size whereas oxygen-icon-theme is 8 MB.

I'm using openSUSE 11.2 with KDE SC 4.4 final release.
Comment 6 Thomas Schwarzgruber 2010-02-11 20:23:12 UTC
I don't think thats the problem Christian, have a look at the oxygen-icon-theme-scalable package for 4.3.5 in opensuse .. it's also around 200K in size (http://download.opensuse.org/repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2/noarch/).

Additionally to that Phillip uses Archlinux packages...
Comment 7 Christian Hartmann 2010-02-11 20:32:20 UTC
Yeah, but the other package, oxygen-icon-theme is much smaller for 4.4 (around 8 MB) compared with 4.3.x (around 21 MB).

And if this is already in the sources, it won't matter which distribution you use.
Comment 8 Thomas Schwarzgruber 2010-02-11 22:01:29 UTC
There is the new package oxygen-icon-theme-large which has 13.4 MB (it seems the old icon-theme package is now splitted into two packages), and as this package is new, it was not installed when I updated the packages.

However I installed that package now and it didn't change anything for me in that regard.
Comment 9 Christian Hartmann 2010-02-12 00:25:14 UTC
Installing the package oxygen-icon-theme-large solved my issue. So good luck with yours!
Comment 10 Rafael Leal 2010-02-13 12:48:38 UTC
The same issue here, using openSUSE:KDE:Factory. I have the oxygen-icon-theme-large installed - now Dolphin works as it should, but the panels don't. The icons scale, blurred, up to a certain point, and after that fall back to 32x32.
Comment 11 Dario Andres 2010-02-16 14:36:51 UTC
*** Bug 226903 has been marked as a duplicate of this bug. ***
Comment 12 Dario Andres 2010-02-16 14:38:33 UTC
*** Bug 226372 has been marked as a duplicate of this bug. ***
Comment 13 Rafael Leal 2010-02-16 14:58:39 UTC
*** This bug has been confirmed by popular vote. ***
Comment 14 Knut Johansson 2010-04-09 12:55:43 UTC
Still present in 4.4.2+, compiled from SVN.

With small panel sizes the icons scale ok, but when setting panel bigger than abut 55 pixels it switches to icon size of 32x32 pixels.
Comment 15 Theodore Lytras 2010-05-04 23:49:55 UTC
I confirm this bug. 
It is most annoying - everything just got much smaller!
Running KDE 4.4.3 on Debian Sid.
Comment 16 Marco Martin 2010-05-22 11:49:34 UTC
this has always been here as the duplicate shows and is the intended behaviour, so not going away

*** This bug has been marked as a duplicate of bug 193756 ***
Comment 17 Janet 2010-05-22 13:18:24 UTC
@ Comment #16: This behaviour has not always been here, this came in with KDE 4.4 and is, from a user's point of view, illogical and a bad usability bug, expecially for people with bad eyes who need big panels with big icons. We had to adapt from icon sizes of 72 and more possible with KDE 3 to small max. 48x48 with KDE 4 and now even have to suffer more with tiny 32x32 panel icons in KDE 4.4. See also Bug 236870, which I now also will mark as a duplicate.
Comment 18 Theodore Lytras 2010-05-23 09:49:12 UTC
Please someone change the "resolved" status for this bug. It is definitely not resolved. I aggree with Janet; some KDE users do need bigger icons, and I cannot see any logic in forcing a maximum size of 32x32 to anyone.
Comment 19 boris64 2010-07-07 13:58:08 UTC
I totally agree with Comment #16.

My desktop (using a fullhd-resolution) really looks awful
with those small icons. Maybe the person who "invented" this 
"feature" is using KDE on a netbook or cell phone(?). Whatever,
please revert icon size behaviour back to what it was on <kde-4.4.

PS: Somebody please reopen this bug!
You guys just can't ignore 250+ votes, can you?
Comment 20 Szokovacs Robert 2010-07-07 14:17:11 UTC
It's a duplicate bug, so it won't be reopened, I guess. Looks like the votes didn't migrate to the other bug, unfortunately.
Comment 21 Janet 2010-07-07 19:16:26 UTC
I guess the best we users can do is to vote for and discuss this on Bug 193756.