Bug 190588

Summary: File properties dialog doesn't have metadata tab
Product: [Frameworks and Libraries] kdelibs Reporter: Marek Laane <qiilaq69>
Component: generalAssignee: Peter Penz <peter.penz19>
Status: RESOLVED FIXED    
Severity: normal CC: apfelmausmail, b.brachaczek, bob, casteyde.christian, doc.evans, dplater, faure, frank78ac, goahead, greg.freemyer, jypel39, kde-2011.08, linux, nadavkav, nightowl, peter.penz19, pfeiffer, pino, pioe, smaug42, sven.burmeister, usrrgt, wizzardx, wstephenson
Priority: NOR Keywords: regression
Version: unspecified   
Target Milestone: ---   
Platform: Mandriva RPMs   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description Marek Laane 2009-04-25 03:51:01 UTC
Version:            (using KDE 4.2.2)
OS:                Linux
Installed from:    Mandriva RPMs

In KDE3, when right clicking on the file and choosing Properties, there was in most cases four tabs, one of them named Metadata which provided some information about file. Now that tab and such information is gone. As KDE translator, I very much regret this - there was nice possibility to see e.g. how much untranslated or fuzzy string some file has, without the need to start KBabel (now Lokalize); same for pictures etc.
Comment 1 Frank Reininghaus 2009-06-06 15:05:12 UTC
*** Bug 195327 has been marked as a duplicate of this bug. ***
Comment 2 Frank Reininghaus 2009-06-06 15:06:46 UTC
*** Bug 173820 has been marked as a duplicate of this bug. ***
Comment 3 Frank Reininghaus 2009-06-06 15:07:38 UTC
*** Bug 185885 has been marked as a duplicate of this bug. ***
Comment 4 Frank Reininghaus 2009-06-06 15:08:56 UTC
*** Bug 175808 has been marked as a duplicate of this bug. ***
Comment 6 Frank Reininghaus 2009-06-10 17:11:35 UTC
*** Bug 195873 has been marked as a duplicate of this bug. ***
Comment 7 greg.freemyer 2009-06-10 21:49:03 UTC
That's 5 duplicates by my count, and I'm the only one to have voted for this master bug.  So if you voted for one of the closed ones you vote was lost and you need to vote for this one.
Comment 8 Pino Toscano 2009-07-28 14:46:55 UTC
*** Bug 201773 has been marked as a duplicate of this bug. ***
Comment 9 Tanja Schulte 2009-08-02 18:28:40 UTC
And this information should be available without the need to activate Nepomuk/Strigi.
Comment 10 jyp 2009-08-22 02:25:05 UTC
I currently work on thousands of photos that were commented using the _meta info_tab in kde3. This is vital to my work.
Thanks for your help.
jyp
Comment 11 Daniel Bauer 2009-08-26 16:24:00 UTC
I very often use the meta-data feature to check photo files I receive from third parties. Its much faster than opening a photo app just to check if there is, and if, to have a look at the meta data. I hope this feature will be there when I finally upgrade to a newer OS version this automn...
Comment 12 CDC 2009-08-26 16:32:39 UTC
Second on comment #9.  This info really should not be dependent upon Nepomuk/Strigi.
Comment 13 Per Inge Oestmoen 2009-09-15 11:36:31 UTC
I am a photographer, and also a writer. I do not understand why the meta data function has been left out from Konqueror 4. The meta data information, from the lens used to the camera used to shutter and aperture values, are crucially important for photography. Also, for all other sorts of files meta data are very valuable. I want this to be able in Konqueror and preferably Dolphin too. KDE ought to be the configurable, function-rich alternative!
Comment 14 Kilavagora 2009-10-11 18:08:06 UTC
One of the features I still missing in KDE4. And again, it should be available without Napomuk/Strigi
Comment 15 Frank Reininghaus 2009-11-15 17:38:29 UTC
*** Bug 214629 has been marked as a duplicate of this bug. ***
Comment 16 Frank Reininghaus 2009-12-01 23:19:00 UTC
*** Bug 208206 has been marked as a duplicate of this bug. ***
Comment 17 Per Inge Oestmoen 2010-01-24 13:14:28 UTC
Still missing functionality! 

KDE 4 is a nice development in most areas, but there is a very important functionality missing which was there in KDE3, as already mentioned. 

In KDE 3, when right clicking on the file and choosing Properties, one of the tabs was named Metadata - by clicking this one one could get a long list of information about the file. This function needs to be added as soon as possible. Read the other comments for clarification.
Comment 18 Robert Smits 2010-01-28 21:28:45 UTC
This is really necessary for me.
Comment 19 usrrgt 2010-01-29 01:36:12 UTC
I can't believe that this feauture and "system:/" kio-slave are missing in KDE 4.4 again!
KDE4's wireless network management sucks too.

KDE is losing the north, implementing eye-candy features instead of the necessities required for use.
Definitely KDE is no longer a desktop environment seriously in which you can trust. Priority must be given to serious matters rather than the beautiful.

KDE is dead in the three version.
GNOME has no competition. KDE 4 forced to me to use it, as for the most users.
Comment 20 Peter Penz 2010-01-30 12:18:59 UTC
@Pino: I hope it is OK for you that I've reassigned this issue to me. I plan to fix this in combination with bug 193592 for KDE SC 4.5.
Comment 21 Carsten Pfeiffer 2010-02-01 21:04:28 UTC
FWIW, long time ago I hacked kmetaprops.cpp so that all the KFileMetaInfo information from strigi were displayed again. Unfortunately, strigi's ontologies lacked textual descriptions for all the meta infos, so instead of e.g. a label "Image Width" it would show a long fully qualified ID of the meta info from the ontology.

I didn't find any time to investigate this further.
Comment 22 Peter Penz 2010-05-01 18:19:05 UTC
Fixed for KDE SC 4.5
Comment 23 Dotan Cohen 2010-05-01 18:45:37 UTC
Thank you Peter! Should I mark as FIXED?
Comment 24 Peter Penz 2010-05-01 20:11:46 UTC
@Dotan: Sorry, I forgot to mark it as FIXEd - done now :-)