Bug 88556 - selecting many folders simultaneously and recursiveness
Summary: selecting many folders simultaneously and recursiveness
Status: RESOLVED WAITINGFORINFO
Alias: None
Product: kmail
Classification: Applications
Component: folder list (show other bugs)
Version: 1.7
Platform: Compiled Sources Linux
: NOR wishlist with 65 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 37198 82683 133266 142949 149826 152691 175267 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-08-31 22:21 UTC by Piotr Szymański
Modified: 2012-08-19 00:49 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Szymański 2004-08-31 22:21:20 UTC
Version:           1.7 (using KDE KDE 3.3.0)
Installed from:    Compiled From Sources
Compiler:          gcc version 3.4.2 20040820 (prerelease) (PLD Linux)
 
OS:                Linux

Hi,
What i want is to be able to select many fodlers at once from the folder list even from different mail accounts (pop3/imap). 
This would result in:
- the thread window shows mails from all folders
- changes from the properties dialogue would apply to all the selected folders, the same goes for all actions other actions possible on those folders (deleting and stuff) ofcourse when folder would be undeleatable (ex. because no permission on imap) the only the user would be prompted (skip, cancel etc.

Also a possibility for recursive option changing in kmail would be nice -> i change one setting of the top folder and click Change in subfolders and it does.
Comment 1 Piotr Szymański 2004-08-31 22:21:59 UTC
This of course is a wishlist.
Comment 2 Thomas McGuire 2007-03-14 14:30:17 UTC
*** Bug 142949 has been marked as a duplicate of this bug. ***
Comment 3 Thomas McGuire 2007-03-19 14:53:19 UTC
*** Bug 37198 has been marked as a duplicate of this bug. ***
Comment 4 Thomas McGuire 2007-03-19 14:54:11 UTC
*** Bug 82683 has been marked as a duplicate of this bug. ***
Comment 5 Thomas McGuire 2007-03-19 14:54:44 UTC
*** Bug 133266 has been marked as a duplicate of this bug. ***
Comment 6 Paul Millar 2007-03-19 16:53:22 UTC
I've written a short hacky perl script for doing bulk disabling of mail-checking (see #82683).  Its available from 
 http://www.astro.gla.ac.uk/users/paulm/Scripts/bulkNoCheckMail.pl 

Use at your own risk!
 
You may need to edit it slightly depending on which folders you want to change. 
 
 HTH 
 
 Paul. 
Comment 7 Thomas McGuire 2007-06-25 13:04:34 UTC
See also bug 81716.
Comment 8 Thomas McGuire 2007-09-20 19:42:18 UTC
*** Bug 149826 has been marked as a duplicate of this bug. ***
Comment 9 Thomas McGuire 2007-11-22 17:17:15 UTC
*** Bug 152691 has been marked as a duplicate of this bug. ***
Comment 10 Thomas McGuire 2008-11-16 17:31:57 UTC
*** Bug 175267 has been marked as a duplicate of this bug. ***
Comment 11 Myriam Schweingruber 2012-08-18 08:32:00 UTC
Thank you for your feature request. Kmail1 is currently unmaintained so we are closing all wishes. Please feel free to reopen a feature request for Kmail2 if it has not already been implemented.
Thank you for your understanding.
Comment 12 Luigi Toscano 2012-08-19 00:49:50 UTC
Instead of creating a new feature request, please confirm here if the wishlist is still valid for kmail2.