Bug 78591 - using titlebar for tab labels
Summary: using titlebar for tab labels
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: 1.3
Platform: unspecified Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
: 93112 102867 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-03-28 05:21 UTC by Luke Worth
Modified: 2005-04-09 11:06 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luke Worth 2004-03-28 05:21:28 UTC
Version:           1.3 (using KDE 3.2.0, Gentoo)
Compiler:          gcc version 3.3.2 20031218 (Gentoo Linux 3.3.2-r5, propolice-3.3-7)
OS:          Linux (i686) release 2.6.3-love6

it would be nice to have the titlebar text used in the tab labels. (or at least the first few characters)
i mean, like if the window title is 'hello' have the tab for that window say 'hello'
Comment 1 Sashmit Bhaduri 2004-03-28 17:56:10 UTC
You can do this with DCOP and bash/zsh, but I agree, there should be an option to do this by default. That would be rad. 
Comment 2 Stephan Binner 2004-03-28 18:03:51 UTC
And what puts "hello" in the window title? Just change the escape sequences to those who change the tab title. :-)
Comment 3 Luke Worth 2004-03-29 00:10:56 UTC
If i'm emerge'ing something, the program emerge displays sort of what stage of the install it's up to in the title bar. If i have a few tabs open, one doing an emerge and others with other stuff happening, i have to keep checking back to the other tab to see how far it has got. if it displayed titlebar text in the tab i could glance at the tab and see instantly.
Comment 4 Kurt Hindenburg 2005-04-01 00:39:23 UTC
*** Bug 93112 has been marked as a duplicate of this bug. ***
Comment 5 Kurt Hindenburg 2005-04-01 00:39:36 UTC
*** Bug 102867 has been marked as a duplicate of this bug. ***
Comment 6 Kurt Hindenburg 2005-04-01 00:40:56 UTC
I'll look at this shortly and see what I can do about it.
Comment 7 Kurt Hindenburg 2005-04-02 20:57:07 UTC
CVS commit by hindenburg: 

Allow user to set Tab title equal to Window title.

FEATURE: 78591
GUI


  M +3 -0      kcontrol/konsole/kcmkonsole.cpp   1.54
  M +120 -82   kcontrol/konsole/kcmkonsoledialog.ui   1.29
  M +9 -1      konsole/konsole/konsole.cpp   1.529
  M +1 -0      konsole/konsole/konsole.h   1.205
Comment 8 A KDE User 2005-04-03 02:45:52 UTC
Awesome! Thanks for such a quick resolution!
Comment 9 Kurt Hindenburg 2005-04-03 22:09:52 UTC
I don't use it as I don't care for it.  If anyone can test it and comment on it it would be appreciated.
Comment 10 Kurt Hindenburg 2005-04-09 11:06:20 UTC
*** Bug 103542 has been marked as a duplicate of this bug. ***