Bug 102867 - Konsole window title as tab captions
Summary: Konsole window title as tab captions
Status: RESOLVED DUPLICATE of bug 78591
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-30 17:38 UTC by A KDE User
Modified: 2005-04-01 00:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description A KDE User 2005-03-30 17:38:02 UTC
Version:            (using KDE KDE 3.3.2)
Installed from:    Gentoo Packages

Using KDE in a production environment with a LOT (>100) of Linux server nodes, it would be extremely helpful for me to have the title of the Konsole window as the caption of the tabs. I am usually have at least ten Konsoles opened, each with at least 8 tabs opened, for where I perform tasks on various Linux nodes.

While the window title is set for the current session as "user@machine", the default behavior of the tab captions to display "Shell No. X" does not help much to spot on which machine I am logged in on each tab. This is why unfortunately Gnome-terminal is preferred by my colleagues and sometimes by me. I guess it won't be that hard to link the tab caption to have the same content as the window title when I am in the session corresponding to that tab.

So it would be nice to be able to see: "user@machine1", "root@machine2" etc automatically for each tab, as an option.

Thank you
Comment 1 Kurt Hindenburg 2005-03-30 20:35:25 UTC
I think it is possible to do what you want now.  There are a couple of 'tips' for this...

Anyway, try this: export PS1="% \[\e]30;\u@\h\w\a\]"

This will make the tabs and window title user@host <current directory>
You can of course change this to suit your needs.

I likely need to explain these options better in the Handbook.

..that you can let Konsole set the current directory as the window title?
For Bash, put 'export PS1=$PS1"\[\e]0;\H:\w\a\]"' in your ~/.bashrc .

...that you can let Konsole set the current directory as the session name?
For Bash, put 'export PS1=$PS1"\[\e]30;\H:\w\a\]"' in your ~/.bashrc .

export PS1="\[\033[0;32m\](\[\033[1;34m\]\u\[\033[1;32m\]@\[\033[1;34m\]\h\[\033[0;32m\])-(\[\033[0;36m\]$(date +%H:%M)\[\033[0;32m\])-(\[\033[0;36m\]\w\[\033[0;32m\])\[\033[0;36m\]>\[\033[0;37m\] \[\e]30;\u@\h \w\a\]"
Comment 2 A KDE User 2005-03-31 17:13:30 UTC
Is not only about "user@machine". In Gnome-terminal, I can see right now these labels for tabs when I am looking at the current tab list:
"emerge (5 of 10) net/openssh-3.9_p1-r2 Compile", "Processes on machine04" (a top running), "user@machine04". 

In Konsole, I would see only "Shell 1", "Shell 2", "Shell 3" and I have to go into each shell to see in title bar "Processes on machine04", etc. And this is not too helpful on my dual head system with lot of Konsoles opened, each of them with many tabs.

So with Gnome-terminal I do not have to load my brain with useless info like "In Shell #1 and I have an emerge running on machine04" and I do not have to keep track what I am doing in each tab in each Konsole.
Comment 3 Kurt Hindenburg 2005-04-01 00:39:35 UTC

*** This bug has been marked as a duplicate of 78591 ***