Bug 93112 - wish: tab titles could show window title (behaviour identical to gnome-terminal)
Summary: wish: tab titles could show window title (behaviour identical to gnome-terminal)
Status: RESOLVED DUPLICATE of bug 78591
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: 1.4.1
Platform: RedHat RPMs Linux
: NOR wishlist with 40 votes (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-11 18:55 UTC by Carles Cufi
Modified: 2005-04-01 00:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Updates Tab with Info Displayed in Window Title (849 bytes, text/plain)
2005-01-04 22:54 UTC, Robert Hogan
Details
Updates Tab with Info Displayed in Window Title (Second Attempt) (1.09 KB, patch)
2005-01-04 23:38 UTC, Robert Hogan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carles Cufi 2004-11-11 18:55:35 UTC
Version:           1.4.1 (using KDE KDE 3.3.1)
Installed from:    RedHat RPMs
OS:                Linux

I find the tab title default settings for gnome-terminal very nice, because when editing multiple files using VIM, each in 1 tab, if you're using the :set title option you see the name of the file in every tab. This is not the case with konsole, which I use now for being MUCH faster than gnome-terminal. In fact, gnome-terminal shows in the tab title what the window title would show when you click on a specific tab. I personally find that very useful.
Comment 1 Adrian von Bidder 2004-11-12 11:11:55 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 Antiphon 2004-11-12 18:58:06 UTC
While we all know Konsole has the ability to change its tab title, it would be very nice if it were possible for it do so in a compatible way. As it is now, I need to have seperate .profile commands for both rxvt/gnome-terminal and konsole.

It would be much easier if Konsole just followed the same procedure as the other terminal emulators.
Comment 3 Robert Hogan 2005-01-04 22:54:01 UTC
Created attachment 8922 [details]
Updates Tab with Info Displayed in Window Title

This patch does what you're looking for. It may not be the best way to do it
(and Lord knows it probably isn't), but it worked for me on 3.3.1. 

(The patch is against CVS.  I was not able to compile it though :
'setTabBarHidden undeclared'? The patch compiles and works against my working
installation so I don't believe the compile problem is patch-related. If you're
compiling your own konsole from zipped sources or whatever it should be fairly
easy to slot in..)
Comment 4 Robert Hogan 2005-01-04 23:38:03 UTC
Created attachment 8924 [details]
Updates Tab with Info Displayed in Window Title
(Second Attempt)

Previous patch was incorrect. Sorry for any inconvenience caused. This new
patch seems to work as expected..
Comment 5 Kurt Hindenburg 2005-04-01 00:39:20 UTC

*** This bug has been marked as a duplicate of 78591 ***