Bug 58580 - Konqueror sidebar settings not stored in profile
Summary: Konqueror sidebar settings not stored in profile
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: sidebar (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist with 65 votes (vote)
Target Milestone: ---
Assignee: Joseph Wenninger
URL:
Keywords:
: 23556 58620 62679 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-05-16 20:33 UTC by John Moore
Modified: 2004-11-12 17:53 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Sidebar saved by profile (122.60 KB, patch)
2004-10-26 19:38 UTC, Andre Moreira Magalhaes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Moore 2003-05-16 20:33:50 UTC
Version:           unknown (using KDE 3.1.1)
Compiler:          gcc version 2.95.3 20010315 (release)
OS:          Linux (i686) release 2.4.20

Is there any reason to have the file $KDEHOME/share/config/konqsidebartng.rc?
I'd like to define a konqueror view profile $KDEHOME/share/apps/konqueror/profiles/Documents that remembers at least the sidebar line:
OpenViews=mydocuments.desktop
Comment 1 Vedran Ljubovic 2003-11-17 11:17:50 UTC
*** Bug 62679 has been marked as a duplicate of this bug. ***
Comment 2 Alex Radu 2004-01-15 08:34:50 UTC
Any chance of this getting added for 3.2. It seems like a small chance this late in the cycle =(
Comment 3 Alex Radu 2004-03-21 20:38:56 UTC
Checkout the duplicated #62679 and #58620 for further clarification.

"It doesn't remember sidebar tabs. For example, if I add a new sidebar tab, such as a link to my pictures folder or a media player it will not remember it in the view profile, it will remember it globally for all profiles. Same thing happens if I want to remove a sidebar tab such as a the media player from one of my profiles, such as the web browsing profile. It removes it globally. 
 
 All sidebar options should be saved in the View Profile. This feature must really be fixed especially since KDE 3.2 will let me have RSS feeds and I definitely don't want to have 10 website RSS feeds and a sidebar media player + all the normal stuff cluttering all my views. I would want the RSS feeds + history, network, and bookmarks but not the rest in my web browsing mode."

This is a serious limitation to Konqueror's view profile and a big usability problem. KDE needs to further make the web browser and file managers feel like they are meant for that task when you are using it. Having 12 tabs because you can not individualize tabs for each view really limits this. The profile feature is the key to making Konqueror a more comfortable beast for file browsing and web browsing over virtually any protocol.

IMPORTANT: From Waldo Bastian:
"Konqueror now passes profile saving/loading info to the views. This makes it possible for the sidebar to implement the desired behavior. This is not yet implemented though. "

He made this comment on #58260, would this fix what I'm talking about?
Comment 4 Michael Jahn 2004-09-07 20:03:21 UTC
*** Bug 58620 has been marked as a duplicate of this bug. ***
Comment 5 Andre Moreira Magalhaes 2004-10-26 19:38:33 UTC
Created attachment 8045 [details]
Sidebar saved by profile

This patch add the ability to save your sidebar configuration by profile and
adds a new sidebar look. Another cool patches can be found in
http://www.kde-apps.org/content/show.php?content=16962
Comment 6 Andre Moreira Magalhaes 2004-10-28 22:52:45 UTC
CVS commit by andrunko: 

BUG: 58580
Fixed this bug: "Konqueror sidebar settings not stored in profile."


  A            sidebar/konqsidebartng.upd   1.1
  A            sidebar/move_konqsidebartng_entries.sh   1.1
  M +5 -0      konq_mainwindow.cc   1.1366
  M +2 -0      konq_mainwindow.h   1.441
  M +0 -1      profile_filemanagement.desktop   1.167
  M +0 -1      profile_filepreview.desktop   1.123
  M +3 -0      sidebar/Makefile.am   1.27
  M +1 -1      sidebar/konqsidebar.cpp   1.28
  M +5 -0      sidebar/konqsidebartng.rc   1.5
  M +28 -42    sidebar/sidebar_widget.cpp   1.135
  M +6 -4      sidebar/sidebar_widget.h   1.56



Comment 7 Alex Radu 2004-10-29 02:19:42 UTC
YESSS!!!!! THANK YOU!!! :-D
Comment 8 Maksim Orlovich 2004-11-12 17:53:40 UTC
*** Bug 23556 has been marked as a duplicate of this bug. ***