Bug 58620 - sidebar status not saving
Summary: sidebar status not saving
Status: RESOLVED DUPLICATE of bug 58580
Alias: None
Product: konqueror
Classification: Applications
Component: sidebar (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Joseph Wenninger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-17 22:06 UTC by Daniel Silva
Modified: 2004-09-07 20:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Silva 2003-05-17 22:06:54 UTC
Version:            (using KDE KDE 3.1.1)
Installed from:    Debian testing/unstable Packages
OS:          Linux

When saving a view profile, only the view settings and file view location are saved, but the directory tree in the sidebar is not.

For example, create ~/photos, then browse to ~/photos/, save the view profile, then reopen Konqueror with that view profile, and the directory tree still shows ~/ instead of ~/photos, though the files listed are from ~/photos and the address bar says ~/photos.

Also, if you create a new sidebar item for a directory, to restrict browsing to ~/photos and save your profile with that bar selected, then open some other view profile and select some other bar, then exit again (without saving), then reopen your first view you saved, it does not show the new bar, but the last one active when konqueror last exited.
Comment 1 Waldo Bastian 2003-06-10 23:14:12 UTC
Konqueror now passes profile saving/loading info to the views. This makes it posible 
for the sidebar to implement the desired behavior. This is not yet implemented 
though. 
Comment 2 Vedran Ljubovic 2003-11-15 21:53:20 UTC
What exactly is the difference between this bug and #58580?
Comment 3 Alex Radu 2004-03-21 20:24:42 UTC
I don't know but #58580 is more general, I think it would solve both if #58580 was implemented.
Comment 4 Michael Jahn 2004-09-07 20:03:20 UTC

*** This bug has been marked as a duplicate of 58580 ***