Bug 62679 - View Profile should remember snavigation panel(sidebar) tabs
Summary: View Profile should remember snavigation panel(sidebar) tabs
Status: RESOLVED DUPLICATE of bug 58580
Alias: None
Product: konqueror
Classification: Applications
Component: sidebar (show other bugs)
Version: 3.1.3
Platform: OpenSUSE NetBSD
: NOR wishlist with 35 votes (vote)
Target Milestone: ---
Assignee: Joseph Wenninger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-08-14 21:18 UTC by Alex Radu
Modified: 2003-11-17 11:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Radu 2003-08-14 21:18:42 UTC
Version:           3.1.3 (using KDE KDE 3.1.3)
Installed from:    SuSE RPMs
OS:          NetBSD

It doesn't remember sidebar tabs. For example, if I add a new sidebar tab, such as a link to my pictures folder or a media player it will not remember it in the view profile, it will remember it globally for all profiles. Same thing happens if I want to remove a sidebar tab such as a the media player from one of my profiles, such as the web browsing profile. It removes it globally. 
 
All sidebar options should be saved in the View Profile. This feature must really be fixed especially since KDE 3.2 will let me have RSS feeds and I definitely don't want to have 10 website RSS feeds anda sidebar media palyer + all the normal stuff cluttering all my views. I would want the RSS feeds + history, network, and bookmarks but not the rest in my web browsing mode.
Comment 1 Vedran Ljubovic 2003-11-15 21:30:22 UTC
This seems to be a duplicate of bug #58580, but please confirm.
Comment 2 Alex Radu 2003-11-16 01:47:25 UTC
I am not sure, but I think mine is different. I am complaining that profiles can not remember sidebar tabs, the way I customize my sidebar, which tabs are there , which aren't etc. changes for all profiles and can not be saved.

For example let's say I added a few new items to the sidebar and I want those items only available in the file manager profile, so now I save the view after I have added that stuff. I want another set of different tabs, let's say a music player that I do not want in the filemanager view in the web browsing view. Konqueror does not let me do this, the set of tabs that I have are the same for all profiles and this greately limits the powers of view profile and the sidebar. I would like to be able to adapt the sidebar to different views so that it is most useful, for example I don't want my RSS feed tabs to be available in my file manager profile, only in my web browsing profile, currently I can not do this.

I hope you understand, if not please tell me so I can be more clear. 

I also think that this is a pretty serious limitation that most likely is not very hard to remove, so I am hoping that it won't be in 3.2, after all KDE 3.2 will be released in February. This is in fact a bug, because View Profile doe snot remember all things about your view and it is supposed to.
Comment 3 Vedran Ljubovic 2003-11-16 13:02:24 UTC
Well I think #58580 is asking exactly that. All the sidebar settings are stored in konqsidebartng.rc. If this file is moved to a directory that stores profiles, than sidebar would have different configuration for each profile. Specifically, you would be able to set for each profile:
- whether sidebar is visible or hidden
- what tabs it contains
- "extra buttons"
- left or right

But we need someone with more information to confirm this.
Also take a look at bug #58620. This to me looks like the same thing again, but I could be wrong?
Comment 4 Alex Radu 2003-11-16 19:22:13 UTC
Yup, I guess it all comes down to saving the sidebar information together. This is a duplicate of that bug.

However, I think the other one is not a duplicate. I think that such information as he mentioned is not saved at all. Because if I made a change to the sidebar the information would still be saved, but instead of per profile, it would be saved globally and the sidebar would be that way for all profiles. In his case, the information about which directory he is in is not saved at all.

BTW: Do you want me to close this?
Comment 5 Matt Rogers 2003-11-16 21:06:30 UTC
yes, please, since view profiles do remember navigation panel (sidebar) settings. Ok, well, at least it remembers which one you have one at the time you saved the view profile (which you have to do manually).
Comment 6 Alex Radu 2003-11-16 22:01:53 UTC
I don' understand what you mean, view profile fails to remember anything more than if the sidebar was open or not and you can't have different profiles with different tabs in the navigation panel. If I wanted one profile with the media player tab and one without it I can't have that because whenever I change something in the sidebar it is not just for that profile, it is global, it changes in all profiles

I am not closing this because the bug is not valid as I think you are suggesing, from my test on KDE 3.1.4 this bug is still valid and from what I heard it is also valid in 3.2. I am closing this because it seems to be a duplicate.

Someone please mark this as a duplicate, all I have is "resolved" and that is in accurate.
Comment 7 Vedran Ljubovic 2003-11-17 11:17:46 UTC

*** This bug has been marked as a duplicate of 58580 ***