Bug 458598 - Kwin crashes in KWin::Workspace::clientArea() after waking from sleep with KDE Snap Assist KWin script active
Summary: Kwin crashes in KWin::Workspace::clientArea() after waking from sleep with KD...
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 5.25.4
Platform: Neon Linux
: HI crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
: 458547 458568 458585 458652 458707 458938 458990 459097 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-09-01 12:13 UTC by aronkvh
Modified: 2022-10-01 10:25 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.26


Attachments
New crash information added by DrKonqi (10.47 KB, text/plain)
2022-09-07 20:31 UTC, aronkvh
Details
New crash information added by DrKonqi (13.90 KB, text/plain)
2022-09-11 17:31 UTC, aronkvh
Details
attachment-23010-0.html (2.38 KB, text/html)
2022-09-26 12:54 UTC, Reggie
Details
New crash information added by DrKonqi (11.98 KB, text/plain)
2022-09-30 12:36 UTC, aronkvh
Details
New crash information added by DrKonqi (12.73 KB, text/plain)
2022-10-01 10:25 UTC, aronkvh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aronkvh 2022-09-01 12:13:40 UTC
Application: kwin_x11 (5.25.4)

Qt Version: 5.15.5
Frameworks Version: 5.97.0
Operating System: Linux 5.15.0-46-generic x86_64
Windowing System: X11
Distribution: KDE neon User - 5.25
DrKonqi: 5.25.4 [KCrashBackend]

-- Information about the crash:
Kwin crashes and restarts after waking my PC from sleep.  Works OK, but I always get a Drkonqi notification after logging in.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault

[New LWP 2322]
[New LWP 2393]
[New LWP 2483]
[New LWP 3699]
[New LWP 22633]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
0x00007f8e66c0799f in __GI___poll (fds=0x7fffcaf91a38, nfds=1, timeout=1000) at ../sysdeps/unix/sysv/linux/poll.c:29
__preamble__
____drkonqi_qmltrace_thread:1____
Failed to do pygdbmi parsing: No module named 'pygdbmi'
frame={level="0",func="onWindowResize",file="/home/aronkvh/.local/share/kwin/scripts/kdesnapassist/contents/ui/code/windows.js",fullname="/home/aronkvh/.local/share/kwin/scripts/kdesnapassist/c".
---------------------------------
(beware that frames may have been optimized out)

[Current thread is 1 (Thread 0x7f8e61e259c0 (LWP 2315))]

Thread 6 (Thread 0x7f8e03fff700 (LWP 22633)):
#0  0x00007f8e66c07a96 in __ppoll (fds=fds@entry=0x7f8dfc089d98, nfds=nfds@entry=1, timeout=<optimized out>, timeout@entry=0x0, sigmask=sigmask@entry=0x0) at ../sysdeps/unix/sysv/linux/ppoll.c:44
#1  0x00007f8e6803a4a9 in ppoll (__ss=<optimized out>, __timeout=<optimized out>, __nfds=<optimized out>, __fds=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/poll2.h:77
#2  qt_ppoll (timeout_ts=0x0, nfds=1, fds=0x7f8dfc089d98) at kernel/qcore_unix.cpp:132
#3  qt_ppoll (timeout_ts=0x0, nfds=1, fds=0x7f8dfc089d98) at kernel/qcore_unix.cpp:129
#4  qt_safe_poll(pollfd*, unsigned long, timespec const*) (fds=0x7f8dfc089d98, nfds=1, timeout_ts=timeout_ts@entry=0x0) at kernel/qcore_unix.cpp:155
#5  0x00007f8e6803bb63 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=<optimized out>, flags=...) at ../../include/QtCore/../../src/corelib/tools/qarraydata.h:212
#6  0x00007f8e67fe276b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f8e03ffebe0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#7  0x00007f8e67dfc372 in QThread::exec() (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#8  0x00007f8e67dfd553 in QThreadPrivate::start(void*) (arg=0x7f8e5c0070e0) at thread/qthread_unix.cpp:331
#9  0x00007f8e68963609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007f8e66c14133 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7f8e51873700 (LWP 3699)):
#0  0x00007f8e66c07a96 in __ppoll (fds=fds@entry=0x55886b0644c8, nfds=nfds@entry=1, timeout=<optimized out>, timeout@entry=0x0, sigmask=sigmask@entry=0x0) at ../sysdeps/unix/sysv/linux/ppoll.c:44
#1  0x00007f8e6803a4a9 in ppoll (__ss=<optimized out>, __timeout=<optimized out>, __nfds=<optimized out>, __fds=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/poll2.h:77
#2  qt_ppoll (timeout_ts=0x0, nfds=1, fds=0x55886b0644c8) at kernel/qcore_unix.cpp:132
#3  qt_ppoll (timeout_ts=0x0, nfds=1, fds=0x55886b0644c8) at kernel/qcore_unix.cpp:129
#4  qt_safe_poll(pollfd*, unsigned long, timespec const*) (fds=0x55886b0644c8, nfds=1, timeout_ts=timeout_ts@entry=0x0) at kernel/qcore_unix.cpp:155
#5  0x00007f8e6803bb63 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=<optimized out>, flags=...) at ../../include/QtCore/../../src/corelib/tools/qarraydata.h:212
#6  0x00007f8e67fe276b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f8e51872be0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#7  0x00007f8e67dfc372 in QThread::exec() (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#8  0x00007f8e67dfd553 in QThreadPrivate::start(void*) (arg=0x55886a6d9680) at thread/qthread_unix.cpp:331
#9  0x00007f8e68963609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007f8e66c14133 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f8e3bfff700 (LWP 2483)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55886ad883e0) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55886ad88390, cond=0x55886ad883b8) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=cond@entry=0x55886ad883b8, mutex=mutex@entry=0x55886ad88390) at pthread_cond_wait.c:647
#3  0x00007f8e67e035fb in QWaitConditionPrivate::wait(QDeadlineTimer) (deadline=..., this=0x55886ad88390) at thread/qwaitcondition_unix.cpp:146
#4  QWaitCondition::wait(QMutex*, QDeadlineTimer) (this=<optimized out>, mutex=0x55886ad68990, deadline=...) at thread/qwaitcondition_unix.cpp:225
#5  0x00007f8e65d612f4 in  () at /lib/x86_64-linux-gnu/libQt5Quick.so.5
#6  0x00007f8e65d61769 in  () at /lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007f8e67dfd553 in QThreadPrivate::start(void*) (arg=0x55886ad688f0) at thread/qthread_unix.cpp:331
#8  0x00007f8e68963609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007f8e66c14133 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f8e53736700 (LWP 2393)):
#0  0x00007f8e66c07a96 in __ppoll (fds=fds@entry=0x7f8e44000d78, nfds=nfds@entry=1, timeout=<optimized out>, timeout@entry=0x0, sigmask=sigmask@entry=0x0) at ../sysdeps/unix/sysv/linux/ppoll.c:44
#1  0x00007f8e6803a4a9 in ppoll (__ss=<optimized out>, __timeout=<optimized out>, __nfds=<optimized out>, __fds=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/poll2.h:77
#2  qt_ppoll (timeout_ts=0x0, nfds=1, fds=0x7f8e44000d78) at kernel/qcore_unix.cpp:132
#3  qt_ppoll (timeout_ts=0x0, nfds=1, fds=0x7f8e44000d78) at kernel/qcore_unix.cpp:129
#4  qt_safe_poll(pollfd*, unsigned long, timespec const*) (fds=0x7f8e44000d78, nfds=1, timeout_ts=timeout_ts@entry=0x0) at kernel/qcore_unix.cpp:155
#5  0x00007f8e6803bb63 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=<optimized out>, flags=...) at ../../include/QtCore/../../src/corelib/tools/qarraydata.h:212
#6  0x00007f8e67fe276b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f8e53735bc0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#7  0x00007f8e67dfc372 in QThread::exec() (this=this@entry=0x55886aa19290) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#8  0x00007f8e68d091b9 in QQmlThreadPrivate::run() (this=0x55886aa19290) at qml/ftw/qqmlthread.cpp:155
#9  0x00007f8e67dfd553 in QThreadPrivate::start(void*) (arg=0x55886aa19290) at thread/qthread_unix.cpp:331
#10 0x00007f8e68963609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#11 0x00007f8e66c14133 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f8e593f0700 (LWP 2322)):
#0  0x00007f8e66c07a96 in __ppoll (fds=fds@entry=0x7f8e5400f1c8, nfds=nfds@entry=1, timeout=<optimized out>, timeout@entry=0x0, sigmask=sigmask@entry=0x0) at ../sysdeps/unix/sysv/linux/ppoll.c:44
#1  0x00007f8e6803a4a9 in ppoll (__ss=<optimized out>, __timeout=<optimized out>, __nfds=<optimized out>, __fds=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/poll2.h:77
#2  qt_ppoll (timeout_ts=0x0, nfds=1, fds=0x7f8e5400f1c8) at kernel/qcore_unix.cpp:132
#3  qt_ppoll (timeout_ts=0x0, nfds=1, fds=0x7f8e5400f1c8) at kernel/qcore_unix.cpp:129
#4  qt_safe_poll(pollfd*, unsigned long, timespec const*) (fds=0x7f8e5400f1c8, nfds=1, timeout_ts=timeout_ts@entry=0x0) at kernel/qcore_unix.cpp:155
#5  0x00007f8e6803bb63 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=<optimized out>, flags=...) at ../../include/QtCore/../../src/corelib/tools/qarraydata.h:212
#6  0x00007f8e67fe276b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f8e593efbb0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#7  0x00007f8e67dfc372 in QThread::exec() (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#8  0x00007f8e67030f4b in  () at /lib/x86_64-linux-gnu/libQt5DBus.so.5
#9  0x00007f8e67dfd553 in QThreadPrivate::start(void*) (arg=0x7f8e670b4d80) at thread/qthread_unix.cpp:331
#10 0x00007f8e68963609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#11 0x00007f8e66c14133 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f8e61e259c0 (LWP 2315)):
[KCrash Handler]
#4  KWin::Window::output() const (this=this@entry=0x0) at ./src/window.cpp:422
#5  0x00007f8e6915f74a in KWin::Workspace::clientArea(KWin::clientAreaOption, KWin::Window const*) const (this=0x55886a929b50, opt=KWin::PlacementArea, window=0x0) at ./src/workspace.cpp:2304
#6  0x00007f8e690f8abf in KWin::WorkspaceWrapper::clientArea(KWin::WorkspaceWrapper::ClientAreaOption, KWin::Window*) const (c=<optimized out>, option=<optimized out>, this=0x55886a9edb10) at ./src/workspace.h:68
#7  KWin::WorkspaceWrapper::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=_o@entry=0x55886a9edb10, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=96, _a=_a@entry=0x7fffcaf92840) at ./obj-x86_64-linux-gnu/src/kwin_autogen/include/moc_workspace_wrapper.cpp:697
#8  0x00007f8e690f99a3 in KWin::WorkspaceWrapper::qt_metacall(QMetaObject::Call, int, void**) (this=this@entry=0x55886a9edb10, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=96, _a=_a@entry=0x7fffcaf92840) at ./obj-x86_64-linux-gnu/src/kwin_autogen/include/moc_workspace_wrapper.cpp:963
#9  0x00007f8e690f9a25 in KWin::DeclarativeScriptWorkspaceWrapper::qt_metacall(QMetaObject::Call, int, void**) (this=0x55886a9edb10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffcaf92840) at ./obj-x86_64-linux-gnu/src/kwin_autogen/include/moc_workspace_wrapper.cpp:1343
#10 0x00007f8e68c9c5c5 in QQmlObjectOrGadget::metacall(QMetaObject::Call, int, void**) const (this=this@entry=0x7fffcaf92b80, type=type@entry=QMetaObject::InvokeMetaMethod, index=<optimized out>, index@entry=101, argv=<optimized out>) at ../../include/QtQml/5.15.5/QtQml/private/../../../../../src/qml/qml/ftw/qflagpointer_p.h:351
#11 0x00007f8e68b643d5 in CallMethod(QQmlObjectOrGadget const&, int, int, int, int*, QV4::ExecutionEngine*, QV4::CallData*, QMetaObject::Call) (object=..., index=<optimized out>, returnType=returnType@entry=19, argCount=<optimized out>, argTypes=<optimized out>, engine=engine@entry=0x55886aa3ab40, callArgs=<optimized out>, callType=<optimized out>) at jsruntime/qv4qobjectwrapper.cpp:1300
#12 0x00007f8e68b664b6 in CallPrecise(QQmlObjectOrGadget const&, QQmlPropertyData const&, QV4::ExecutionEngine*, QV4::CallData*, QMetaObject::Call) (object=..., data=..., engine=engine@entry=0x55886aa3ab40, callArgs=callArgs@entry=0x7f8e52af7690, callType=callType@entry=QMetaObject::InvokeMetaMethod) at ../../include/QtQml/5.15.5/QtQml/private/../../../../../src/qml/qml/qqmlpropertydata_p.h:285
#13 0x00007f8e68b675a1 in CallOverloaded (callType=QMetaObject::InvokeMetaMethod, propertyCache=0x55886a96a9d0, callArgs=0x7f8e52af7690, engine=0x55886aa3ab40, data=..., object=...) at jsruntime/qv4qobjectwrapper.cpp:1644
#14 QV4::QObjectMethod::callInternal(QV4::Value const*, QV4::Value const*, int) const (this=<optimized out>, thisObject=<optimized out>, argv=<optimized out>, argc=<optimized out>) at jsruntime/qv4qobjectwrapper.cpp:2132
#15 0x00007f8e68b9753b in QV4::FunctionObject::call(QV4::Value const*, QV4::Value const*, int) const (argc=2, argv=0x7f8e52af75f0, thisObject=0x7f8e52af75d8, this=0x7fffcaf92ce8) at jsruntime/qv4functionobject_p.h:172
#16 QV4::Runtime::CallPropertyLookup::call(QV4::ExecutionEngine*, QV4::Value const&, unsigned int, QV4::Value*, int) (engine=0x55886aa3ab40, base=..., index=<optimized out>, argv=0x7f8e52af75f0, argc=2) at jsruntime/qv4runtime.cpp:1460
#17 0x00007f8e595e71d0 in  ()
#18 0x0000000000000000 in  ()
[Inferior 1 (process 2315) detached]

Reported using DrKonqi
Comment 1 Nate Graham 2022-09-01 16:25:03 UTC
> Failed to do pygdbmi parsing: No module named 'pygdbmi'
> frame={level="0",func="onWindowResize",file="/home/aronkvh/.local/share/kwin/scripts/kdesnapassist/contents/ui/code/windows.js",fullname="/home/aronkvh/.local/share/kwin/scripts/kdesnapassist/c".

This is an issue caused by a bug in the 3rd-party Snap Assist KWin script. Evidently your system is missing the "pygdbmi" python modue, and this causes it to crash. You should be able to fix this by installing that module, and you should also report tihs to the developer because the script shouldn't cause KWin to crash if it's missing that module.
Comment 2 Nate Graham 2022-09-01 16:44:23 UTC
*** Bug 458585 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2022-09-01 17:15:59 UTC
*** Bug 458547 has been marked as a duplicate of this bug. ***
Comment 4 aronkvh 2022-09-01 17:50:18 UTC
(In reply to Nate Graham from comment #1)
> > Failed to do pygdbmi parsing: No module named 'pygdbmi'
> > frame={level="0",func="onWindowResize",file="/home/aronkvh/.local/share/kwin/scripts/kdesnapassist/contents/ui/code/windows.js",fullname="/home/aronkvh/.local/share/kwin/scripts/kdesnapassist/c".
> 
> This is an issue caused by a bug in the 3rd-party Snap Assist KWin script.
> Evidently your system is missing the "pygdbmi" python modue, and this causes
> it to crash. You should be able to fix this by installing that module, and
> you should also report tihs to the developer because the script shouldn't
> cause KWin to crash if it's missing that module.

Thanks for the explanation, reported it.
Comment 5 Max 2022-09-01 22:52:00 UTC
(In reply to Nate Graham from comment #1)
> This is an issue caused by a bug in the 3rd-party Snap Assist KWin script.
> Evidently your system is missing the "pygdbmi" python modue, and this causes
> it to crash

But this script doesn't depend on "pygdbmi" module, or any other external libraries or modules other than the official KWin Scripting API. The fact that the crash happens only after waking from sleep also makes me suspicious. 

Is it possible that "clientArea()" method from the API somehow requires "pygdbmi" dependency under the hood? As it seems to be the exact place where the crash happens.
Comment 6 Nicolas Fella 2022-09-03 15:46:27 UTC
pydgbmi (https://github.com/cs01/pygdbmi) is related to GDB, i.e. what happens after the crash. It has nothing to do with the snap assistant or the actual cause of the crash
Comment 7 Nicolas Fella 2022-09-03 15:49:11 UTC
This looks a lot like https://bugs.kde.org/show_bug.cgi?id=448102
Comment 8 Nicolas Fella 2022-09-03 15:52:12 UTC
pygdbmi is used by DrKonqi when creating crash reports
Comment 9 Nicolas Fella 2022-09-05 15:44:10 UTC
With current master

#0  __GI___pthread_sigmask (how=1, newmask=<optimized out>, oldmask=0x0) at pthread_sigmask.c:43
#1  0x00007f964ca77c6d in __GI___sigprocmask (how=<optimized out>, set=<optimized out>, oset=<optimized out>) at ../sysdeps/unix/sysv/linux/sigprocmask.c:25
#2  0x00007f96503aae28 in KCrash::setCrashHandler(void (*)(int)) (handler=handler@entry=0x0) at /home/nico/kde/src/kcrash/src/kcrash.cpp:415
#3  0x00007f96503aba02 in KCrash::defaultCrashHandler(int) (sig=11) at /home/nico/kde/src/kcrash/src/kcrash.cpp:632
#4  0x00007f964ca77a70 in <signal handler called> () at /lib64/libc.so.6
#5  KWin::Window::output() const (this=this@entry=0x0) at /home/nico/kde/src/kwin/src/window.cpp:421
#6  0x00007f964ffe8d8e in KWin::Workspace::clientArea(KWin::clientAreaOption, KWin::Window const*) const (this=0x1183d00, opt=KWin::PlacementArea, window=0x0) at /home/nico/kde/src/kwin/src/workspace.cpp:2524
#7  0x00007f964ff84822 in KWin::WorkspaceWrapper::clientArea(KWin::WorkspaceWrapper::ClientAreaOption, KWin::Window*) const (c=<optimized out>, option=<optimized out>, this=<optimized out>)
    at /home/nico/kde/src/kwin/src/scripting/workspace_wrapper.cpp:290
#8  KWin::WorkspaceWrapper::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7fff247140d0)
    at /home/nico/kde/build/kwin/src/kwin_autogen/include/moc_workspace_wrapper.cpp:697
#9  0x00007f964ff85ab3 in KWin::WorkspaceWrapper::qt_metacall(QMetaObject::Call, int, void**) (this=this@entry=0x14cf100, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=96, _a=_a@entry=0x7fff247140d0)
    at /home/nico/kde/build/kwin/src/kwin_autogen/include/moc_workspace_wrapper.cpp:963
#10 0x00007f964ff85b71 in KWin::DeclarativeScriptWorkspaceWrapper::qt_metacall(QMetaObject::Call, int, void**) (this=0x14cf100, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff247140d0)
    at /home/nico/kde/build/kwin/src/kwin_autogen/include/moc_workspace_wrapper.cpp:1343
#11 0x00007f964f487793 in QQmlObjectOrGadget::metacall(QMetaObject::Call, int, void**) const (this=this@entry=0x7fff24714370, type=type@entry=QMetaObject::InvokeMetaMethod, index=<optimized out>, index@entry=101, argv=<optimized out>)
    at qml/qqmlobjectorgadget.cpp:51
#12 0x00007f964f36b929 in CallMethod (callType=<optimized out>, callArgs=0x3, engine=<optimized out>, argTypes=<optimized out>, argCount=<optimized out>, returnType=<optimized out>, index=<optimized out>, object=...)
    at /home/nico/workspace/qt5/qtbase/include/QtCore/../../src/corelib/tools/qvarlengtharray.h:189
#13 CallPrecise(QQmlObjectOrGadget const&, QQmlPropertyData const&, QV4::ExecutionEngine*, QV4::CallData*, QMetaObject::Call)
     (object=..., data=<optimized out>, engine=engine@entry=0x12d46a0, callArgs=callArgs@entry=0x7f95fd60b690, callType=callType@entry=QMetaObject::InvokeMetaMethod) at jsruntime/qv4qobjectwrapper.cpp:1568
#14 0x00007f964f36d71b in CallOverloaded (callType=<optimized out>, propertyCache=<optimized out>, callArgs=<optimized out>, engine=<optimized out>, data=<optimized out>, object=<optimized out>) at jsruntime/qv4qobjectwrapper.cpp:1644
#15 QV4::QObjectMethod::callInternal(QV4::Value const*, QV4::Value const*, int) const (this=<optimized out>, thisObject=<optimized out>, argv=<optimized out>, argc=<optimized out>) at jsruntime/qv4qobjectwrapper.cpp:2132
#16 0x00007f964f39b6d9 in QV4::FunctionObject::call(QV4::Value const*, QV4::Value const*, int) const (argc=2, argv=0x7f95fd60b5f0, thisObject=0x7f95fd60b5d8, this=0x7fff24714480) at jsruntime/qv4functionobject_p.h:202
#17 QV4::Runtime::CallPropertyLookup::call(QV4::ExecutionEngine*, QV4::Value const&, unsigned int, QV4::Value*, int) (engine=0x12d46a0, base=..., index=<optimized out>, argv=0x7f95fd60b5f0, argc=2) at jsruntime/qv4runtime.cpp:1460
#18 0x00007f95fcfe72b1 in  ()
#19 0x0000000000000000 in  ()
Comment 10 aronkvh 2022-09-07 20:31:28 UTC
Created attachment 151904 [details]
New crash information added by DrKonqi

kwin_x11 (5.25.5) using Qt 5.15.5

Kwin crashed as ethernet was reconnected and I got the approp. notifications.

-- Backtrace (Reduced):
#4  KWin::Window::output() const (this=this@entry=0x0) at ./src/window.cpp:422
#5  0x00007f6d82a6b78a in KWin::Workspace::clientArea(KWin::clientAreaOption, KWin::Window const*) const (this=0x5637015b1070, opt=KWin::PlacementArea, window=0x0) at ./src/workspace.cpp:2304
#6  0x00007f6d82a04aff in KWin::WorkspaceWrapper::clientArea(KWin::WorkspaceWrapper::ClientAreaOption, KWin::Window*) const (c=<optimized out>, option=<optimized out>, this=0x563701826030) at ./src/workspace.h:68
#7  KWin::WorkspaceWrapper::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=_o@entry=0x563701826030, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=96, _a=_a@entry=0x7ffec83bc590) at ./obj-x86_64-linux-gnu/src/kwin_autogen/include/moc_workspace_wrapper.cpp:697
#8  0x00007f6d82a059e3 in KWin::WorkspaceWrapper::qt_metacall(QMetaObject::Call, int, void**) (this=this@entry=0x563701826030, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=96, _a=_a@entry=0x7ffec83bc590) at ./obj-x86_64-linux-gnu/src/kwin_autogen/include/moc_workspace_wrapper.cpp:963
Comment 11 Bug Janitor Service 2022-09-08 15:08:03 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kwin/-/merge_requests/2917
Comment 12 Vlad Zahorodnii 2022-09-09 06:30:36 UTC
Git commit 287ad9561d6b7bccec1626dc78efe1190d3ccfd9 by Vlad Zahorodnii.
Committed on 09/09/2022 at 06:10.
Pushed by vladz into branch 'master'.

scripting: Add null window guard in WorkspaceWrapper::clientArea()

Workspace::clientArea(clientAreaOpt, Window*) expects a valid pointer.

M  +6    -0    src/scripting/workspace_wrapper.cpp

https://invent.kde.org/plasma/kwin/commit/287ad9561d6b7bccec1626dc78efe1190d3ccfd9
Comment 13 Nate Graham 2022-09-09 22:33:34 UTC
*** Bug 458938 has been marked as a duplicate of this bug. ***
Comment 14 aronkvh 2022-09-11 17:31:01 UTC
Created attachment 151990 [details]
New crash information added by DrKonqi

kwin_x11 (5.25.5) using Qt 5.15.5

Kwin crashes everytime when launching Krita. 2 monitors, nvidia graphics

-- Backtrace (Reduced):
#4  KWin::Window::output() const (this=this@entry=0x0) at ./src/window.cpp:422
#5  0x00007fce1fa7778a in KWin::Workspace::clientArea(KWin::clientAreaOption, KWin::Window const*) const (this=0x5578a471a370, opt=KWin::PlacementArea, window=0x0) at ./src/workspace.cpp:2304
#6  0x00007fce1fa10aff in KWin::WorkspaceWrapper::clientArea(KWin::WorkspaceWrapper::ClientAreaOption, KWin::Window*) const (c=<optimized out>, option=<optimized out>, this=0x5578a48083a0) at ./src/workspace.h:68
#7  KWin::WorkspaceWrapper::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=_o@entry=0x5578a48083a0, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=96, _a=_a@entry=0x7fff5882ce60) at ./obj-x86_64-linux-gnu/src/kwin_autogen/include/moc_workspace_wrapper.cpp:697
#8  0x00007fce1fa119e3 in KWin::WorkspaceWrapper::qt_metacall(QMetaObject::Call, int, void**) (this=this@entry=0x5578a48083a0, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=96, _a=_a@entry=0x7fff5882ce60) at ./obj-x86_64-linux-gnu/src/kwin_autogen/include/moc_workspace_wrapper.cpp:963
Comment 15 Nate Graham 2022-09-13 18:43:24 UTC
*** Bug 458990 has been marked as a duplicate of this bug. ***
Comment 16 Vlad Zahorodnii 2022-09-15 07:28:35 UTC
*** Bug 459097 has been marked as a duplicate of this bug. ***
Comment 17 Vlad Zahorodnii 2022-09-19 08:27:55 UTC
*** Bug 458707 has been marked as a duplicate of this bug. ***
Comment 18 Zamundaaa 2022-09-25 14:50:32 UTC
*** Bug 458568 has been marked as a duplicate of this bug. ***
Comment 19 Vlad Zahorodnii 2022-09-26 08:13:17 UTC
*** Bug 458652 has been marked as a duplicate of this bug. ***
Comment 20 Reggie 2022-09-26 12:54:29 UTC
Created attachment 152434 [details]
attachment-23010-0.html

I am just now seeing these updates.  Traveling so not sure if progress was
made.  I can try when I land later today.  If no changes please respond to
this email if possible.
*Reginald Pierre*
Senior Systems Administrator
770-624-9443
r
<https://mail.capitalcityclub.org/owa/redir.aspx?C=8826c0a2573b42529d6a3521df366ce9&URL=mailto%3ajdoe%40capitalcityclub.org>
eginald.pierre@gmail.com




On Mon, Sep 26, 2022 at 4:13 AM Vlad Zahorodnii <bugzilla_noreply@kde.org>
wrote:

> https://bugs.kde.org/show_bug.cgi?id=458598
>
> Vlad Zahorodnii <vlad.zahorodnii@kde.org> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>                  CC|                            |knuteirikj@gmail.com
>
> --- Comment #19 from Vlad Zahorodnii <vlad.zahorodnii@kde.org> ---
> *** Bug 458652 has been marked as a duplicate of this bug. ***
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
Comment 21 aronkvh 2022-09-30 12:36:10 UTC
Created attachment 152520 [details]
New crash information added by DrKonqi

kwin_x11 (5.25.5) using Qt 5.15.6

After waking from sleep mode the second monitor is black until clicking on the area

-- Backtrace (Reduced):
#4  KWin::Window::output() const (this=this@entry=0x0) at ./src/window.cpp:422
#5  0x00007f6bd25e579a in KWin::Workspace::clientArea(KWin::clientAreaOption, KWin::Window const*) const (this=0x55d9619aa6b0, opt=KWin::PlacementArea, window=0x0) at ./src/workspace.cpp:2304
#6  0x00007f6bd257eb0f in KWin::WorkspaceWrapper::clientArea(KWin::WorkspaceWrapper::ClientAreaOption, KWin::Window*) const (c=<optimized out>, option=<optimized out>, this=0x55d961a3ed60) at ./src/workspace.h:68
#7  KWin::WorkspaceWrapper::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=_o@entry=0x55d961a3ed60, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=96, _a=_a@entry=0x7fff97edeb80) at ./obj-x86_64-linux-gnu/src/kwin_autogen/include/moc_workspace_wrapper.cpp:697
#8  0x00007f6bd257f9f3 in KWin::WorkspaceWrapper::qt_metacall(QMetaObject::Call, int, void**) (this=this@entry=0x55d961a3ed60, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=96, _a=_a@entry=0x7fff97edeb80) at ./obj-x86_64-linux-gnu/src/kwin_autogen/include/moc_workspace_wrapper.cpp:963
Comment 22 aronkvh 2022-10-01 10:25:31 UTC
Created attachment 152529 [details]
New crash information added by DrKonqi

kwin_x11 (5.25.5) using Qt 5.15.6

This time I was doing nothing special just a few apps open like firefox, okular, dolphin
btw is there a point in attaching each crashlog?

-- Backtrace (Reduced):
#4  KWin::Window::output() const (this=this@entry=0x0) at ./src/window.cpp:422
#5  0x00007f1925b5779a in KWin::Workspace::clientArea(KWin::clientAreaOption, KWin::Window const*) const (this=0x55b7bc8f7740, opt=KWin::PlacementArea, window=0x0) at ./src/workspace.cpp:2304
#6  0x00007f1925af0b0f in KWin::WorkspaceWrapper::clientArea(KWin::WorkspaceWrapper::ClientAreaOption, KWin::Window*) const (c=<optimized out>, option=<optimized out>, this=0x55b7bc9b2f40) at ./src/workspace.h:68
#7  KWin::WorkspaceWrapper::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=_o@entry=0x55b7bc9b2f40, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=96, _a=_a@entry=0x7ffe3f40faf0) at ./obj-x86_64-linux-gnu/src/kwin_autogen/include/moc_workspace_wrapper.cpp:697
#8  0x00007f1925af19f3 in KWin::WorkspaceWrapper::qt_metacall(QMetaObject::Call, int, void**) (this=this@entry=0x55b7bc9b2f40, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=96, _a=_a@entry=0x7ffe3f40faf0) at ./obj-x86_64-linux-gnu/src/kwin_autogen/include/moc_workspace_wrapper.cpp:963