Bug 458990 - kwin_wayland segfaults
Summary: kwin_wayland segfaults
Status: RESOLVED DUPLICATE of bug 458598
Alias: None
Product: kwin
Classification: Plasma
Component: wayland-generic (show other bugs)
Version: 5.25.5
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-09-11 08:49 UTC by Toni Lipponen
Modified: 2022-09-13 18:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Output of dmesg right after crashing (83.39 KB, text/plain)
2022-09-11 08:49 UTC, Toni Lipponen
Details
Backtrace (35.46 KB, text/plain)
2022-09-11 08:50 UTC, Toni Lipponen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toni Lipponen 2022-09-11 08:49:12 UTC
Created attachment 151976 [details]
Output of dmesg right after crashing

All open windows suddenly close seemingly out of nowhere. Also if I use CLion from JetBrains toolbox, the same exact thing seems to happen almost immediately. Looking at the output of dmesg, I notice a segfault right as the crash happens  '[   47.207222] kwin_wayland[748]: segfault at 10 ip 00007f4e93bb2994 sp 00007ffeab7c9788 error 4 in libkwin.so.5.25.5[7f4e93a51000+297000]'

Only surefire way to reproduce this bug is to open JetBrains toolbox, and launch CLion and start editing a file. 
Otherwise this seems to happen at random.


Operating system: Arch Linux
KDE Plasma Version: 5.25.5
KDE Frameworks Version: 5.97.0
Qt Version: 5.15.6
Graphics Platform: Wayland
Comment 1 Toni Lipponen 2022-09-11 08:50:46 UTC
Created attachment 151977 [details]
Backtrace
Comment 2 Nate Graham 2022-09-13 18:43:24 UTC
Pasting inline for searchability: 

                Stack trace of thread 748:
                #0  0x00007f4e93bb2994 _ZNK4KWin6Window6outputEv (libkwin.so.5 + 0x2a2994)
                #1  0x00007f4e93bdc27a _ZNK4KWin9Workspace10clientAreaENS_16clientAreaOptionEPKNS_6WindowE (libkwin.so.5 + 0x2cc27a)
                #2  0x00007f4e93b7285e n/a (libkwin.so.5 + 0x26285e)
                #3  0x00007f4e93b73cc3 n/a (libkwin.so.5 + 0x263cc3)
                #4  0x00007f4e93b73ce5 n/a (libkwin.so.5 + 0x263ce5)
                #5  0x00007f4e93711784 n/a (libQt5Qml.so.5 + 0x276784)
                #6  0x00007f4e93615dd1 n/a (libQt5Qml.so.5 + 0x17add1)
                #7  0x00007f4e93617388 _ZNK3QV413QObjectMethod12callInternalEPKNS_5ValueES3_i (libQt5Qml.so.5 + 0x17c388)
                #8  0x00007f4e9363c74e _ZN3QV47Runtime18CallPropertyLookup4callEPNS_15ExecutionEngineERKNS_5ValueEjPS4_i (libQt5Qml.so.5 + 0x1a174e)
                #9  0x00007f4e3f21035f n/a (n/a + 0x0)
                #10 0x00007f4e9362fd7d n/a (libQt5Qml.so.5 + 0x194d7d)
                #11 0x00007f4e935d6720 n/a (libQt5Qml.so.5 + 0x13b720)
                #12 0x00007f4e93640498 _ZN3QV47Runtime28CallQmlContextPropertyLookup4callEPNS_15ExecutionEngineEjPNS_5ValueEi (libQt5Qml.so.5 + 0x1a5498)
                #13 0x00007f4e522cdea9 n/a (n/a + 0x0)
                #14 0x00007f4e9362fd7d n/a (libQt5Qml.so.5 + 0x194d7d)
                #15 0x00007f4e935d6720 n/a (libQt5Qml.so.5 + 0x13b720)
                #16 0x00007f4e936149a3 n/a (libQt5Qml.so.5 + 0x1799a3)
                #17 0x00007f4e9297d361 n/a (libQt5Core.so.5 + 0x2bd361)
                #18 0x00007f4e93779399 _ZN9QQmlTimer5eventEP6QEvent (libQt5Qml.so.5 + 0x2de399)
                #19 0x00007f4e91ec6b1c _ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent (libQt5Widgets.so.5 + 0x178b1c)
                #20 0x00007f4e9294cb68 _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt5Core.so.5 + 0x28cb68)
                #21 0x00007f4e9294d673 _ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData (libQt5Core.so.5 + 0x28d673)
                #22 0x00007f4e92996df7 _ZN20QEventDispatcherUNIX13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5 + 0x2d6df7)
                #23 0x0000557ea855e2a2 n/a (kwin_wayland + 0x1282a2)
                #24 0x00007f4e9294530c _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5 + 0x28530c)
                #25 0x00007f4e9294fe39 _ZN16QCoreApplication4execEv (libQt5Core.so.5 + 0x28fe39)
                #26 0x0000557ea8483eb5 n/a (kwin_wayland + 0x4deb5)
                #27 0x00007f4e917892d0 n/a (libc.so.6 + 0x232d0)
                #28 0x00007f4e9178938a __libc_start_main (libc.so.6 + 0x2338a)
                #29 0x0000557ea84855d5 n/a (kwin_wayland + 0x4f5d5)

*** This bug has been marked as a duplicate of bug 458598 ***