Bug 458707 - kwin crashing
Summary: kwin crashing
Status: RESOLVED DUPLICATE of bug 458598
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 5.25.4
Platform: Neon Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2022-09-04 18:57 UTC by Reggie
Modified: 2022-09-19 08:27 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.21 KB, text/plain)
2022-09-18 07:55 UTC, Hyena
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Reggie 2022-09-04 18:57:48 UTC
Application: kwin_x11 (5.25.4)

Qt Version: 5.15.5
Frameworks Version: 5.97.0
Operating System: Linux 5.15.54-xanmod1-tt x86_64
Windowing System: X11
Distribution: KDE neon User - 5.25
DrKonqi: 5.25.4 [KCrashBackend]

-- Information about the crash:
made some settings changes to kwin then when notifications came from KDE connect kwin just crashed.

The crash can be reproduced sometimes.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault

[KCrash Handler]
#4  KWin::Window::output (this=this@entry=0x0) at ./src/window.cpp:422
#5  0x00007f55f64cc74a in KWin::Workspace::clientArea (this=0x55be6d2c22e0, opt=KWin::PlacementArea, window=0x0) at ./src/workspace.cpp:2304
#6  0x00007f55f6465abf in KWin::WorkspaceWrapper::clientArea (c=<optimized out>, option=<optimized out>, this=0x55be6d6c6520) at ./src/scripting/workspace_wrapper.cpp:285
#7  KWin::WorkspaceWrapper::qt_static_metacall (_o=_o@entry=0x55be6d6c6520, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=96, _a=_a@entry=0x7ffe6c77b4a0) at ./obj-x86_64-linux-gnu/src/kwin_autogen/include/moc_workspace_wrapper.cpp:697
#8  0x00007f55f64669a3 in KWin::WorkspaceWrapper::qt_metacall (this=this@entry=0x55be6d6c6520, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=96, _a=_a@entry=0x7ffe6c77b4a0) at ./obj-x86_64-linux-gnu/src/kwin_autogen/include/moc_workspace_wrapper.cpp:963
#9  0x00007f55f6466a25 in KWin::DeclarativeScriptWorkspaceWrapper::qt_metacall (this=0x55be6d6c6520, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffe6c77b4a0) at ./obj-x86_64-linux-gnu/src/kwin_autogen/include/moc_workspace_wrapper.cpp:1343
#10 0x00007f55f60095c5 in QQmlObjectOrGadget::metacall (this=this@entry=0x7ffe6c77b7e0, type=type@entry=QMetaObject::InvokeMetaMethod, index=<optimized out>, index@entry=101, argv=<optimized out>) at qml/qqmlobjectorgadget.cpp:51
#11 0x00007f55f5ed13d5 in CallMethod (object=..., index=<optimized out>, returnType=returnType@entry=19, argCount=<optimized out>, argTypes=<optimized out>, engine=engine@entry=0x55be6d3df030, callArgs=<optimized out>, callType=<optimized out>) at jsruntime/qv4qobjectwrapper.cpp:1300
#12 0x00007f55f5ed34b6 in CallPrecise (object=..., data=..., engine=engine@entry=0x55be6d3df030, callArgs=callArgs@entry=0x7f55c81b2690, callType=callType@entry=QMetaObject::InvokeMetaMethod) at jsruntime/qv4qobjectwrapper.cpp:1568
#13 0x00007f55f5ed45a1 in CallOverloaded (callType=QMetaObject::InvokeMetaMethod, propertyCache=0x55be6d98d220, callArgs=0x7f55c81b2690, engine=0x55be6d3df030, data=..., object=...) at jsruntime/qv4qobjectwrapper.cpp:1644
#14 QV4::QObjectMethod::callInternal (this=<optimized out>, thisObject=<optimized out>, argv=<optimized out>, argc=<optimized out>) at jsruntime/qv4qobjectwrapper.cpp:2132
#15 0x00007f55f5f0453b in QV4::FunctionObject::call (argc=2, argv=0x7f55c81b25f0, thisObject=0x7f55c81b25d8, this=0x7ffe6c77b948) at jsruntime/qv4functionobject_p.h:202
#16 QV4::Runtime::CallPropertyLookup::call (engine=0x55be6d3df030, base=..., index=<optimized out>, argv=0x7f55c81b25f0, argc=2) at jsruntime/qv4runtime.cpp:1460
#17 0x00007f55b00412b1 in ?? ()
#18 0x0000000000000000 in ?? ()
[Inferior 1 (process 8468) detached]

Reported using DrKonqi
Comment 1 Nicolas Fella 2022-09-05 15:45:08 UTC
Do you use "KDE Snap Assistant"?
Comment 2 Nate Graham 2022-09-09 03:58:26 UTC
.
Comment 3 Hyena 2022-09-18 07:55:55 UTC
Created attachment 152179 [details]
New crash information added by DrKonqi

kwin_x11 (5.24.6) using Qt 5.15.3

- What I was doing when the application crashed:
Opening the Application Menu and mousing through the list.

- Unusual behavior I noticed:
When you move fast enough down the list, the submenu will not appear and KWin will segfault.

- Custom settings of the application:
Composition is OFF.
List of KWin Scripts loaded:
	- KDE Snap Assist
	- Sticky Window Snapping
No specific window rules applied.

-- Backtrace (Reduced):
#6  0x00007f1af4df7d78 in QRect::center() const (this=<optimized out>, this=<optimized out>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qrect.h:263
#7  KWin::Workspace::clientArea(KWin::clientAreaOption, KWin::Toplevel const*) const (this=0x55990a780150, opt=KWin::PlacementArea, window=0x0) at ./src/workspace.cpp:2354
#8  0x00007f1af4caddf2 in KWin::WorkspaceWrapper::clientArea(KWin::WorkspaceWrapper::ClientAreaOption, KWin::AbstractClient const*) const (this=<optimized out>, c=<optimized out>, option=<optimized out>) at ./src/scripting/workspace_wrapper.cpp:260
#9  KWin::WorkspaceWrapper::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=_o@entry=0x55990aecacd0, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=93, _a=_a@entry=0x7ffeb25fec80) at ./obj-x86_64-linux-gnu/src/kwin_autogen/7KDSW62DQT/moc_workspace_wrapper.cpp:680
#10 0x00007f1af4caf5f3 in KWin::WorkspaceWrapper::qt_metacall(QMetaObject::Call, int, void**) (this=this@entry=0x55990aecacd0, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=93, _a=_a@entry=0x7ffeb25fec80) at ./obj-x86_64-linux-gnu/src/kwin_autogen/7KDSW62DQT/moc_workspace_wrapper.cpp:946
Comment 4 Vlad Zahorodnii 2022-09-19 08:27:55 UTC

*** This bug has been marked as a duplicate of bug 458598 ***